Bug 470 - Permit drivers to enable their devices for wake (e.g. sleep button)
Summary: Permit drivers to enable their devices for wake (e.g. sleep button)
Status: REJECTED DUPLICATE of bug 1415
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Len Brown
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-03-18 14:01 UTC by Andy Grover
Modified: 2004-06-28 21:55 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.5.65
Tree: Mainline
Regression: ---


Attachments

Description Andy Grover 2003-03-18 14:01:50 UTC
ACPI has an interface for devices who know what their GPE is to enable it for 
wake, but most of the time a device doesn't know what its GPE is, and it must 
be determined by calling _PRW.

We need to add a function that hides this complexity from drivers. Preferably 
it will take only the ACPI device handle.

We will also need to add a non-ACPI-specific version for other drivers to call.
Comment 1 Shaohua 2003-11-03 20:53:21 UTC
I have implemented a patch for this feature. the patch is at Bug 1415
Comment 2 Len Brown 2004-06-28 21:55:25 UTC

*** This bug has been marked as a duplicate of 1415 ***

Note You need to log in before you can comment on or make changes to this bug.