Bug 4652 - S3 resume: no video, hang - Dell Precision M70
S3 resume: no video, hang - Dell Precision M70
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: Venkatesh Pallipadi
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-22 22:58 UTC by Vladimir Vukicevic
Modified: 2005-10-29 02:35 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.12-rc4-mm2
Tree: Mainline
Regression: ---


Attachments
acpidmp output (67.63 KB, text/plain)
2005-05-22 22:58 UTC, Vladimir Vukicevic
Details
dmidecode output (13.54 KB, text/plain)
2005-05-22 22:59 UTC, Vladimir Vukicevic
Details
lspci -vv output (14.53 KB, text/plain)
2005-05-22 22:59 UTC, Vladimir Vukicevic
Details
/proc/interrupts (597 bytes, text/plain)
2005-05-22 23:00 UTC, Vladimir Vukicevic
Details
pre-suspend dmesg output, with acpi glue debug turned on (22.58 KB, text/plain)
2005-05-22 23:00 UTC, Vladimir Vukicevic
Details

Description Vladimir Vukicevic 2005-05-22 22:58:14 UTC
Fedora Core 4 test 3, with updates; tested with
2.6.11.8, 2.6.11-1.1329_FC4, 2.6.12-rc4-mm2, and 2.6.12-rc4-mm2 with the IDE
GTM/STM patch in
http://marc.theaimsgroup.com/?l=acpi4linux&m=111680155305976&w=2, though at this
point I don't think the issue is necessarily IDE related.

With all of the above tested kernels, the system enters S3 suspend (with a
minimum of modules loaded, init=/bin/sh.. ata_piix & ext3 are the only things
loaded, essentially).  On unsuspend, I hear the dvd drive make a click, and the
HDD light lights up, as does the wireless light.  The LCD backlight does not
turn on; the system is responsive to caps lock changes and Fn-F2 hardware
wireless kill switch toggle.

I'll attempt to get a serial console going and see if that can provide some more
insight as to what's going on.  I'm open to any ideas as far as debugging and
collecting info.
Comment 1 Vladimir Vukicevic 2005-05-22 22:58:51 UTC
Created attachment 5082 [details]
acpidmp output
Comment 2 Vladimir Vukicevic 2005-05-22 22:59:17 UTC
Created attachment 5083 [details]
dmidecode output
Comment 3 Vladimir Vukicevic 2005-05-22 22:59:43 UTC
Created attachment 5084 [details]
lspci -vv output
Comment 4 Vladimir Vukicevic 2005-05-22 23:00:08 UTC
Created attachment 5085 [details]
/proc/interrupts
Comment 5 Vladimir Vukicevic 2005-05-22 23:00:50 UTC
Created attachment 5086 [details]
pre-suspend dmesg output, with acpi glue debug turned on
Comment 6 Vladimir Vukicevic 2005-05-23 21:25:27 UTC
> the system is responsive to caps lock changes 

Sorry, I take that back -- the system is NOT repsonsive to caps lock/scroll
lock/etc.  I misremembered when filing the bug, just double checked.  However,
it does respond to things like the hardware RF toggle switch.

I hooked up a serial console -- no output at all on unsuspend.  It's just
completely wedged.
Comment 7 Vladimir Vukicevic 2005-05-25 22:47:39 UTC
Some more info.. swsusp works (with compiled-in ata_piix, instead of as
modules); suspend2 does not.
Comment 8 Len Brown 2005-08-14 23:49:31 UTC
see Documentation/power/video.txt
for workarounds to attempt to get video to restore.

Also, be sure you've got the latest BIOS
and the latest X and video driver for the hardware.
Comment 9 Vladimir Vukicevic 2005-08-17 13:36:56 UTC
Part of the problem was due to PCI-E bridge config space not being restored
after suspend; this was fixed by a patch from Shaohua Li about a month ago (was
in issue with tg3 etherntet on the acpi-devel list; MARC isn't working for me
atm, so I can't provide a link).  It's an nvidia video card, so I have to use
the nvidia binary driver which complicates things somewhat.  It's not clear
whether their driver has to do anything special for PCIE support or not. 
However, with the pcie-portdrv patch, as well as a patch from Jens Axboe to
support ACPI suspend on SATA, I'm now able to suspend the machine and bring it
back as long as the nvidia kernel module is not loaded (and thus no X).  I've
unfortunately not heard anything back from nvidia yet.
Comment 10 Venkatesh Pallipadi 2005-10-28 17:42:50 UTC
As the problem here seems to be in nvidia binary driver and kernel issues
addressed in this bugzilla are fixed now (Shaohua's and Jen's patch in the base)
I think we can close the bug now.

Please feel free to reopen if you think there is some other kernel issue that
needs attention.

Thanks.
Comment 11 Vladimir Vukicevic 2005-10-29 02:35:44 UTC
2.6.14 stock does not have the SATA suspend bits in yet, so out of the box it
has no chance at successfully resuming.  Applying the latest version of jens'
patch results in a failure to suspend due to kauditd not being able to be
stopped.  Booting with init=/bin/sh results in a supposedly successful suspend,
and a resume that seems to work until the disk is touched (find / -> hd light
lights up, lockup).  However, the specific tg3 issue is fixed, and separate bugs
should probably be filed for the remaining issues.

I've really given up on this for now; there are too many pieces involved and I
have no idea really where to start to even be able to help get this working in
any reasonable amount of time. =/

Note You need to log in before you can comment on or make changes to this bug.