Bug 4645 - PCIe Machine - Acpi throws out a series of Errors upon starting.
PCIe Machine - Acpi throws out a series of Errors upon starting.
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Other
i386 Linux
: P2 low
Assigned To: Robert Moore
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-20 21:51 UTC by Arturo Mann
Modified: 2006-02-02 15:07 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.11.6
Tree: Mainline
Regression: ---


Attachments

Description Arturo Mann 2005-05-20 21:51:21 UTC
Distribution: Gentoo! Linux 2005.0
Hardware Environment: x86 PCIe Intel 925x based mainboard, Pentium 4 HT EE 2mb
l3 cache, LPGa 775, PCIe based mainboard.
Software Environment: i686-pc-linux-gnu kernel 2.6.11.6 gcc 3.4.3
Problem Description:
Upon starting up the kernel, before the splash starts - ACPI gives out the
following Error:
pufreqMay  9 20:13:54 Orion ACPI-1138: *** Error: Method execution failed
[\MCTH] (Node dfffeb40), AE_AML_BUFFER_LIMIT
May  9 20:13:54 Orion ACPI-1138: *** Error: Method execution failed [\OSFL]
(Node dfffeb60), AE_AML_BUFFER_LIMIT
May  9 20:13:54 Orion ACPI-1138: *** Error: Method execution failed
[\_SB_.PCI0.SBRG.PS2K._STA] (Node dfec5ca0), AE_AML_BUFFER_LIMIT
May  9 20:13:54 Orion ACPI-0158: *** Error: Method execution failed
[\_SB_.PCI0.SBRG.PS2K._STA] (Node dfec5ca0), AE_AML_BUFFER_LIMIT
May  9 20:13:54 Orion ACPI-1138: *** Error: Method execution failed [\MCTH]
(Node dfffeb40), AE_AML_BUFFER_LIMIT
May  9 20:13:54 Orion ACPI-1138: *** Error: Method execution failed [\OSFL]
(Node dfffeb60), AE_AML_BUFFER_LIMIT
May  9 20:13:54 Orion ACPI-1138: *** Error: Method execution failed
[\_SB_.PCI0.SBRG.PS2M._STA] (Node dfec5c00), AE_AML_BUFFER_LIMIT
May  9 20:13:54 Orion ACPI-0158: *** Error: Method execution failed
[\_SB_.PCI0.SBRG.PS2M._STA] (Node dfec5c00), AE_AML_BUFFER_LIMITd triggers
ACPI-* errors on reading battery state
3 bugs found. 
Steps to reproduce:
It is just required to compile in acpi to the kernel, and then you will see the
ugly error every time your machine boots up. It also takes a few seconds to be
cleared from the screen and for the machine to move on.
Comment 1 Robert Moore 2005-05-26 10:33:46 UTC
What version of ACPI CA are you using?  This was probably fixed in version 
20050310:

10 March 2005.  Summary of changes for version 20050310:

1) ACPI CA Core Subsystem:

The string-to-buffer implicit conversion code has been modified again after a 
change to the ACPI specification.  In order to match the behavior of the other 
major ACPI implementation, the target buffer is no longer truncated if the 
source string is smaller than an existing target buffer. This change requires 
an update to the ACPI spec, and should eliminate the recent 
AE_AML_BUFFER_LIMIT issues.

Comment 2 Arturo Mann 2005-05-28 14:05:26 UTC
The version for this particular error is : 20050211
I am now attempting to get 2.6.11.11 to see if the problem is still there.

Comment 3 Arturo Mann 2005-06-03 06:38:17 UTC
The bug remains in Kernel version 2.6.11.10.
Comment 4 Robert Moore 2005-06-03 07:47:16 UTC
Therefore, the question remains: What version of ACPI CA? 
Comment 5 Arturo Mann 2005-06-04 11:39:54 UTC
cat /proc/acpi/info
version:                 20050211

,,,should I try kernel 2.6.12?
Comment 6 Robert Moore 2005-09-29 14:04:02 UTC
This was fixed in 20050310
Comment 7 Len Brown 2006-02-02 15:07:05 UTC
20050309 shipped in Linux-2.6.12 -- closing.

Note You need to log in before you can comment on or make changes to this bug.