Bug 4542 - S3 resume: no video - Averatec 3300
S3 resume: no video - Averatec 3300
Status: REJECTED DUPLICATE of bug 7225
Product: Drivers
Classification: Unclassified
Component: Video(Other)
i386 Linux
: P2 normal
Assigned To: Rafael J. Wysocki
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-25 11:50 UTC by John Elliott Martin
Modified: 2007-04-28 12:49 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.11.4-20050418133015-default
Tree: Mainline
Regression: ---


Attachments

Description John Elliott Martin 2005-04-25 11:50:54 UTC
Distribution: 
Suse Linux 9.2 
 
Hardware Environment: 
Averatec 3300 laptop. Intel 855GM chipset. 
 
Software Environment: 
kernel 2.6.11.4-20050418133015-default 
 
Problem Description: 
Standby goes down fine, but when resuming there is no video. I have tried this 
from the console and from X and the same thing happens. Also, I have tried 
logging in 'blind' after resuming, but still nothing. I cannot SSH into the 
computer after the resume either. 
 
Steps to reproduce: 
Get an Averatec 3300 laptop. Put it in standby mode from linux. Resume the PC.
Comment 1 Len Brown 2005-08-17 12:28:45 UTC
Any luck with:
1. BIOS upgrade.
2. X upgrade, or at least X video driver
3. workarounds in Documentation/power/video.txt?
Comment 2 Adrian Bunk 2006-02-09 12:18:46 UTC
Please reopen this bug if:
- it is still present in kernel 2.6.16-rc2 and
- you can answer Len's questions.
Comment 3 John Elliott Martin 2006-02-13 16:17:22 UTC
I have tried all your suggestions. Let me answer them here for you.   
   
First off, there are no available BIOS upgrades for my laptop.  I tried a new  
video driver for this board, and had the same results. I tried all the  
workarounds in Documentation/power/video.txt, and still had the same results.  
  
I just downloaded, compiled and booted into 2.6.16rc2 and when I come back 
from S3 with that kernel I can drive, but I can't see. I booted to runlevel 3 
and tried init 5 from the console after resuming and got nothing on the 
display either. ctrl alt 1 and init 6 rebooted though, so it's just the 
display. 
 
If there is anything I can do to help, or any data I can provide, let me know 
as I have a good test environment set up now. 
Comment 4 Len Brown 2006-08-09 20:48:46 UTC
Video restore on resume from S3 is a BIOS or video driver issue,
not an ACPI issue.  Moving to drivers/video.
Comment 5 Rafael J. Wysocki 2006-09-28 16:31:02 UTC

*** This bug has been marked as a duplicate of 7225 ***

Note You need to log in before you can comment on or make changes to this bug.