Bug 45321 - Quantal Alpha 2, No Sound on HDMI screen.
Summary: Quantal Alpha 2, No Sound on HDMI screen.
Status: CLOSED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jaroslav Kysela
URL: https://bugs.launchpad.net/ubuntu/+so...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-30 10:31 UTC by Hansen
Modified: 2013-11-19 10:07 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.5 rc6
Tree: Mainline
Regression: Yes


Attachments
Apport-collect files (203.48 KB, application/x-gzip)
2012-07-30 10:34 UTC, Hansen
Details

Description Hansen 2012-07-30 10:31:23 UTC
Ubuntu launchpad bug:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1020041

Lenovo Ideapad s205 AMD64 E-450
No sound on HDMI screen, not even if plugged in at boot.
No able to select it in sound settings.
Tested with Kernel v3.5-rc6-quantal, bug still present.
It works on older kernels.
Attached files from ubuntu apport-collect.

ApportVersion: 2.3-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: mads 1836 F.... pulseaudio
 /dev/snd/controlC0: mads 1836 F.... pulseaudio
CurrentDmesg: [ 38.488008] init: plymouth-stop pre-start process (1328) terminated with status 1
DistroRelease: Ubuntu 12.10
HibernationDevice: RESUME=UUID=3f8eb1eb-e922-4eec-aa30-39ccd17fe056
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120709.1)
MachineType: LENOVO 1038D4G
Package: linux (not installed)
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.5.0-4-generic root=UUID=d6a193cf-f328-477a-b050-a99989a018f8 ro quiet splash
ProcVersionSignature: Ubuntu 3.5.0-4.4-generic 3.5.0-rc6
RelatedPackageVersions:
 linux-restricted-modules-3.5.0-4-generic N/A
 linux-backports-modules-3.5.0-4-generic N/A
 linux-firmware 1.83
StagingDrivers: rts5139
Tags: quantal running-unity staging
Uname: Linux 3.5.0-4-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 08/10/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 4BCN24WW
dmi.board.asset.tag: Base Board Asset Tag Unknown
dmi.board.name: Inagua
dmi.board.vendor: LENOVO
dmi.board.version: 109-B78210-00A
dmi.chassis.asset.tag: Chassis Asset Tag Unknown
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Chassis Version Unknown
dmi.modalias: dmi:bvnLENOVO:bvr4BCN24WW:bd08/10/2011:svnLENOVO:pn1038D4G:pvrIdeapadS205:rvnLENOVO:rnInagua:rvr109-B78210-00A:cvnLENOVO:ct10:cvrChassisVersionUnknown:
dmi.product.name: 1038D4G
dmi.product.version: Ideapad S205
dmi.sys.vendor: LENOVO
Comment 1 Hansen 2012-07-30 10:34:30 UTC
Created attachment 76501 [details]
Apport-collect files
Comment 2 Takashi Iwai 2012-09-06 15:54:19 UTC
Did you pass audio=1 option to radeon driver?  Otherwise HDMI/DP audio is disabled as default.

And which older kernel did it work exactly?
Comment 3 Hansen 2012-09-07 07:36:07 UTC
In Ubuntu 11.10 it worked without problems, in 12.04 the screen needs to be connected at bootup, and in 12.10 it does not work at all. (all version numbers with default kernels).

Regarding "audio=1" i have not done anything but to test Quantal Alpha on my laptop, and my skill are insufficient to test this without guiding.
-Please advice.
thanks you.
Comment 4 Takashi Iwai 2012-09-07 07:45:26 UTC
Better to ask on Ubuntu's forum, then...
Comment 5 Hansen 2012-09-07 07:54:29 UTC
As part of testing for Ubuntu QA team i have reported a bug on this, on launchpad: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1020041
See comment #24
If it is futile or i am to unskilled please tell me and i will reported it back.
Comment 6 Takashi Iwai 2012-09-07 08:16:54 UTC
Usually passing "radeon.audio=1" at boot option should work.  But this isn't guaranteed to work always, depending on distro and its version, so I suggested to ask Ubuntu how to do it.  More than that I cannot help at this moment.
Comment 7 Hansen 2012-09-07 08:18:58 UTC
Ok, thank you.
I will do.
Comment 8 Takashi Iwai 2012-09-07 08:42:01 UTC
Also, it's not clear what you exactly tested.  Such a problem is often not only in the kernel but in other levels.

Did you test the problem with an older kernel on the new system?  I mean just replacing the kernel with old one but keeping others as is.  This is the standard test for a kernel regression.

The bug description doesn't tell what application is used with which sound backend.  Or, imagine how you can reproduce the problem on other machines with other distribution.  See?  The bug must be reproduced in a more low-level way, e.g. just using ALSA-native apps like aplay without PulseAudio.

So, please try to strip down the way to reproduce the bug on a minimal system not being Ubuntu-specific.  Then it'll make easier to understand the cause of the problem.
Comment 9 Hansen 2012-09-07 08:57:44 UTC
Thank you for your advice.
My laptop are in for repair (mouse button), but as soon as i get it back i will get on with testing.

Note You need to log in before you can comment on or make changes to this bug.