Bug 4502 - GCC, other applications segfault with kernels 2.6.11 - 12
GCC, other applications segfault with kernels 2.6.11 - 12
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Platform Specific/Hardware
Classification: Unclassified
Component: PPC-32
i386 Linux
: P2 normal
Assigned To: Josh Boyer
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-04-15 13:35 UTC by d'Ronin
Modified: 2007-05-16 05:40 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.12-rc2
Tree: Mainline
Regression: ---


Attachments

Description d'Ronin 2005-04-15 13:35:06 UTC
Distribution: Gentoo
Hardware Environment: On three separate G4 based systems. G4 windtunnel, TiBook,
Mac Mini
Software Environment: gcc, X, kde, etc.
Problem Description:

I am experiencing random segfaults with kernel 2.6.11 and up. Usualy happens
after running for a day or two. Heavy emerging/compiling seems to bring it on
faster.
It seems that the problem goes away after I disable "Preemtible Kernel" option
in the the kernel config. I experienced this problem on G4 Windtunnel as well as
on G4 TiBook and Mac Mini.

Reproducible: Sometimes
Steps to Reproduce:
No exact steps to reproduce it. Just emerge something heavy like Firefox.
Problem should manifest.
Actual Results:  
powerpc-unknown-linux-gnu-gcc -o prmwait.o -c    -mtune=G4 -mabi=altivec -pipe
-pipe -ansi  -pthread -O2 -fPIC  -UDEBUG -DMOZILLA_CLIENT=1 -DNDEBUG=1
-DXP_UNIX=1 -D_POSIX_SOURCE=1 -D_BSD_SOURCE=1 -D_SVID_SOURCE=1
-D_LARGEFILE64_SOURCE=1 -DHAVE_FCNTL_FILE_LOCKING=1 -DLINUX=1 -DHAVE_LCHOWN=1
-DHAVE_STRERROR=1 -D_REENTRANT=1  -DFORCE_PR_LOG -D_PR_PTHREADS
-UHAVE_CVAR_BUILT_ON_SEM -D_NSPR_BUILD_
-I/var/tmp/portage/mozilla-firefox-1.0.2/work/mozilla/dist/include/nspr
-I../../../pr/include -I../../../pr/include/private  prmwait.c
prmwait.c: In function `_MW_PollInternal':
prmwait.c:599: internal compiler error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
distcc[434] ERROR: compile prmwait.c on localhost failed
Comment 1 Colin Leroy 2005-05-29 02:26:44 UTC
I think CONFIG_PREEMPT is still not safe on PPC.
Comment 2 Lars Weiler 2005-06-06 07:20:04 UTC
If you enable CONFIG_PREEMPT and CONFIG_SMP on ppc32 (even if this is a
uniprocessor machine), Preemption works quite fine.

I use it now for about two weeks on my G3 and G4 with a 2.6.10 and a 2.6.12_rc5
kernel.
Comment 3 d'Ronin 2005-06-20 09:09:16 UTC
Yes, enabling CONFIG_SMP seems to fix the problem. Been running for two weeks
now, with no issues.
Comment 4 Daniel Drake 2005-09-17 09:58:09 UTC
Downstream bug report: http://bugs.gentoo.org/show_bug.cgi?id=86544
Comment 5 Josh Boyer 2007-05-15 05:28:47 UTC
Does this behavior still occur on the latest kernels?
Comment 6 Lars Weiler 2007-05-16 05:24:49 UTC
Nope.  I can use PREEMPT without SMP enabled.  It's working since 2.6.16 or 
so.
Comment 7 Josh Boyer 2007-05-16 05:32:53 UTC
Thanks Lars.  Closing this bug out then.

Note You need to log in before you can comment on or make changes to this bug.