Bug 44821 - Sound setup failure
Sound setup failure
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Alan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-15 07:58 UTC by Victor Mineev
Modified: 2012-08-15 21:59 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.4.4
Tree: Mainline
Regression: No


Attachments
Fix patch for kernel warning wrt mpu401 (1.19 KB, patch)
2012-07-23 09:39 UTC, Takashi Iwai
Details | Diff

Description Victor Mineev 2012-07-15 07:58:47 UTC
The x86 machine with kernel 3.4.4 was fail of sound setup. Also test Front Left get sound on right speaker and Front Right silence on both. The name of hardware is 'K9N Neo'. Does i right the 'Hardware name' not english, that how to hardware?

[   22.210277] ------------[ cut here ]------------
[   22.210285] WARNING: at kernel/irq/manage.c:1193 __free_irq+0x91/0x190()
[   22.210287] Hardware name: MS-7260
[   22.210288] Trying to free already-free IRQ 0
[   22.210290] Modules linked in: snd_mpu401(+) snd_mpu401_uart snd_seq_midi snd_rawmidi snd_seq_midi_event ttm snd_seq snd_timer snd_seq_device drm_kms_helper drm nv_tco gspca_pac207 gspca_main i2c_nforce2 i2c_algo_bit videodev snd mxm_wmi soundcore video snd_page_alloc ppdev wmi ns558 lp gameport k8temp parport_pc parport hid_a4tech usbhid hid usb_storage uas floppy forcedeth sata_nv pata_amd
[   22.210313] Pid: 588, comm: modprobe Tainted: G          I  3.4.4 #2
[   22.210315] Call Trace:
[   22.210320]  [<c1032b02>] warn_slowpath_common+0x72/0xa0
[   22.210323]  [<c10adc01>] ? __free_irq+0x91/0x190
[   22.210326]  [<c10adc01>] ? __free_irq+0x91/0x190
[   22.210329]  [<c1032bd3>] warn_slowpath_fmt+0x33/0x40
[   22.210332]  [<c10adc01>] __free_irq+0x91/0x190
[   22.210335]  [<c10ade73>] free_irq+0x43/0xa0
[   22.210338]  [<f82659ed>] snd_mpu401_uart_free+0x1d/0x30 [snd_mpu401_uart]
[   22.210343]  [<f826a211>] snd_rawmidi_free+0x71/0x80 [snd_rawmidi]
[   22.210346]  [<f826a230>] snd_rawmidi_dev_free+0x10/0x20 [snd_rawmidi]
[   22.210355]  [<f81e273d>] snd_device_free+0x5d/0xc0 [snd]
[   22.210358]  [<f826597e>] snd_mpu401_uart_new+0x2ee/0x340 [snd_mpu401_uart]
[   22.210362]  [<f8281154>] snd_mpu401_create+0x117/0x14f [snd_mpu401]
[   22.210365]  [<f8281284>] ? snd_mpu401_probe+0x8c/0x8c [snd_mpu401]
[   22.210368]  [<f8281284>] ? snd_mpu401_probe+0x8c/0x8c [snd_mpu401]
[   22.210371]  [<f8281429>] snd_mpu401_pnp_probe+0x1a5/0x1ad [snd_mpu401]
[   22.210375]  [<f8281284>] ? snd_mpu401_probe+0x8c/0x8c [snd_mpu401]
[   22.210379]  [<c1324e59>] pnp_device_probe+0x59/0xd0
[   22.210383]  [<c136a138>] driver_probe_device+0x68/0x1e0
[   22.210386]  [<c1324de1>] ? match_device.isra.1+0x31/0x50
[   22.210389]  [<c136a341>] __driver_attach+0x91/0xa0
[   22.210391]  [<c136a2b0>] ? driver_probe_device+0x1e0/0x1e0
[   22.210394]  [<c1368a42>] bus_for_each_dev+0x42/0x70
[   22.210396]  [<c1369d11>] driver_attach+0x21/0x30
[   22.210399]  [<c136a2b0>] ? driver_probe_device+0x1e0/0x1e0
[   22.210401]  [<c1369977>] bus_add_driver+0x187/0x260
[   22.210404]  [<c1324c40>] ? pnp_device_detach+0x40/0x40
[   22.210407]  [<c136a7d6>] driver_register+0x66/0x110
[   22.210410]  [<c1324bfc>] pnp_register_driver+0x1c/0x20
[   22.210413]  [<f80640b0>] alsa_card_mpu401_init+0xb0/0x1000 [snd_mpu401]
[   22.210417]  [<f8064000>] ? 0xf8063fff
[   22.210420]  [<c1001114>] do_one_initcall+0x34/0x170
[   22.210422]  [<f8064000>] ? 0xf8063fff
[   22.210426]  [<c108a940>] sys_init_module+0x2c0/0x1ae0
[   22.210432]  [<c155e61f>] sysenter_do_call+0x12/0x28
[   22.210434] ---[ end trace 524a7b1977170492 ]---
Comment 1 Victor Mineev 2012-07-17 16:24:58 UTC
The syslog is because of ramdisk broken with modifies of Linux Mint 12. But sound also failed if clean kernel. I was not seen syslog of errors while it.
Comment 2 Alan 2012-07-20 12:31:23 UTC
The uart401 driver mishandles filing to register. I don't think that is related to your other sound problem but its a trivial fix in itself so I'll get it queued up.
Comment 3 Takashi Iwai 2012-07-23 09:38:22 UTC
The kernel warning is due to the missing initialization of irq field in mpu401_uart driver.  This should be fixed by the patch below.

However, the original issue, the missing sound, is irrelevant with this warning.
It's more about the broken pin-configuration of HD-audio by BIOS.
Comment 4 Takashi Iwai 2012-07-23 09:39:12 UTC
Created attachment 75931 [details]
Fix patch for kernel warning wrt mpu401
Comment 5 Florian Mickler 2012-08-04 19:10:25 UTC
A patch referencing this bug report has been merged in Linux v3.6-rc1:

commit bc733d495267a23ef8660220d696c6e549ce30b3
Author: Takashi Iwai <tiwai@suse.de>
Date:   Mon Jul 23 11:35:55 2012 +0200

    ALSA: mpu401: Fix missing initialization of irq field

Note You need to log in before you can comment on or make changes to this bug.