Bug 4453 - Since 2.6.10 with radeon 9000 mobile return from a suspend gets screen scrambled
Since 2.6.10 with radeon 9000 mobile return from a suspend gets screen scrambled
Status: REJECTED INSUFFICIENT_DATA
Product: Drivers
Classification: Unclassified
Component: Console/Framebuffers
i386 Linux
: P2 high
Assigned To: Antonino Daplas
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2005-04-06 17:04 UTC by Mauro M.
Modified: 2007-12-12 17:05 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.10, 2.6.11.6
Tree: Mainline
Regression: Yes


Attachments
Screen picture (camera snapshot) representing the issue described. (971.37 KB, image/jpeg)
2005-04-06 17:16 UTC, Mauro M.
Details

Description Mauro M. 2005-04-06 17:04:54 UTC
Distribution: EzPlanet One 2.0 and Fedora Core 3
Hardware Environment: Dell Inspiron 8200 with Radeon 9000 Mobile
Software Environment: xorg, KDE
Problem Description: When resuming from suspend mode, the screen get scrambled
both in graphic (xorg) and console mode. This does not happen with kernel 2.6.9
as the problem has been introduced with kernel 2.6.10. I have tested both radeon
new and old drivers with the same result.

Steps to reproduce: Go into suspend. After resuming from suspend the screen
scrambles.
Comment 1 Andrew Morton 2005-04-06 17:09:34 UTC
Could you try 2.6.12-rc2 please?
Comment 2 Mauro M. 2005-04-06 17:16:35 UTC
Created attachment 4871 [details]
Screen picture (camera snapshot) representing the issue described.
Comment 3 Benjamin Herrenschmidt 2005-04-06 17:18:48 UTC
Note that radeonfb isn't doing much on suspend/resume on non-pmacs. it basically
blanks the screen on suspend, and re-sets the mode & unblanks the screen on
resume. I don't know what could cause it to get "scrambled" (can you explain
what you actually mean by "scrambled" ? best is to get a snapshot of the screen
with a digital camera). Probably yet another interaction with the BIOS ...

Comment 4 Benjamin Herrenschmidt 2005-04-06 17:20:36 UTC
Ah ok, here it is. Thanks. Weird ... what if you kill and restart X ? Does that
fixes it ? radeon "old" driver is really the same as 2.6.9 one so I suspect it's
something else causing this, like some ACPI update or something, causing the
BIOS to do something to the chip that triggers that issue...
Comment 5 Mauro M. 2005-04-06 17:21:33 UTC
More info: the video card is reported as: ATI Radeon Mobility M9. I have
attached a picture taken from the screen with a digital camera. You may see in
the picture  dotted vertical lines. The picture only represents a static
snapshot, however those lines "vibrate" through the screen making reading
impossible. The only workaround in this situation is a shutdown. I will be too
happy to supply further information if required.

Mauro
Comment 6 Mauro M. 2005-04-06 17:24:38 UTC
Killing and restarting X does not solve the problem, in fact when leaving X the
same effect applies to console mode.

I will try 2.6.12-rc2, however I will have to build from scratch and it will
take some time (tomorrow, is 1:25am here now).

Mauro
Comment 7 Mauro M. 2005-04-07 06:46:45 UTC
I have tested 2.6.11-rc2 with both old and new driver and the same problem occurs.
Mauro
Comment 8 Dirk Reiss 2005-04-20 18:08:18 UTC
I think I have the same problem here. I do not resume from suspend but just
boot. Setup: Kernel 2.6.11.7 (debian source), ATI Radeon Mobility 9000 (M9)

After booting, sometimes the screen is scrambled like described and shown in the
picture above. Then, moving the mouse cursor over some gui element (a button for
example), this part of the screen gets rendered correctly (it only works
sometimes, unreproducibly). In this state, killing the X server restores X and
console to a correct state. 

If I can help with providing more info, please contact me.
Comment 9 Andrew Morton 2005-05-25 22:02:00 UTC
Guys, are these problems still happening in 2.6.12-rc5?
Comment 10 Dirk Reiss 2005-06-06 07:42:18 UTC
I have 2.6.12rc5 now running for one week and until now, no problems regarding 
this bug occurred. Hope it stays this way, otherwise, I will post again. Thanks 
very much! 
Comment 11 Fredrik St 2005-06-28 07:23:06 UTC
Dirk Reiss' problem sounds like a different one to me. I have the same hardware
(Inspiron 8200 + Radeon 9000 Mobile), running Mandriva LE2005 with kernel
2.6.11-6mdk. After s3 suspend to ram, the screen is black with no backlight. If
I instead do the following (from console):

vbetool dpms off; echo "3" > /proc/acpi/sleep; vbetool dpms on; vbetool post

the screen comes back scrambled most of the time.  It clearly is a video issue
since I can type away at the terminal without problems. The strange thing is
that every ten times or so the screen comes back just fine!

I have tried all sorts of things, including:
- Booting without framebuffer
- Suspending from Xorg with VBERestore = true
- Kernel options acpi_sleep=s3_bios or acpi_sleep=s3_mode (gives reboot without
backlight, so probably not applicable)
- Kernel patch acpi_sleep=s3_late_bios
- Various alternatives to vbetool: radeontool, boot-radeon, video_post

The same thing happens with unpatched kernels 2.6.11.11 and 2.6.12.1.
Comment 12 Dirk Reiss 2005-06-29 18:08:32 UTC
Unfortunately, 2.6.12.1 still lets this problem occur, less frequently, but still.
 
Regarding comment #11: I am not sure if it is the same problem, but the screen
actually looks like the image attached to this report, the console in this
scrambled state looks also broken (blinking and colored characters all over),
the only difference seems to be that it gets broken even if not resuming. 

Comment 13 Antonino Daplas 2007-04-28 17:14:53 UTC
I'll close this just because it's been almost 2 years since the last comment. 
Reopen if the problem persist.
Comment 14 Mauro M. 2007-06-19 09:25:17 UTC
Guys, I am now at Fedora 7, two years later this bug is still unresolved: when I suspend my Inspiron 8200, after it comes back the picture still looks like the one posted two years ago. The only solution is a shutdown and reboot. Nedless to say that there are no problems with Windoze.

Is anyone looking at this issue?
Comment 15 Rafael J. Wysocki 2007-09-12 10:23:54 UTC
Please try s2ram (http://en.opensuse.org/s2ram).
Comment 16 Rafael J. Wysocki 2007-09-23 05:24:12 UTC
Also, there is an important fix that may be related to this problem in the current Linus' tree (2.6.23-rc7-git4 as of today).  Please test it.
Comment 17 Rafael J. Wysocki 2007-10-12 13:11:28 UTC
Update:
Please try 2.6.23 and s2ram.

[If there's no response within 2 weeks, I will stop tracking this bug.]
Comment 18 Rafael J. Wysocki 2007-12-12 17:05:18 UTC
As I said, I'm closing this bug.  Please reopen if necessary, thanks.

Note You need to log in before you can comment on or make changes to this bug.