Bug 44401 - MPMAN TK250 storage device does not connect
Summary: MPMAN TK250 storage device does not connect
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-07-10 16:54 UTC by Jose
Modified: 2013-12-23 16:28 UTC (History)
1 user (show)

See Also:
Kernel Version: -
Tree: Mainline
Regression: No


Attachments
dmesg log (2.85 KB, application/octet-stream)
2012-07-10 16:54 UTC, Jose
Details

Description Jose 2012-07-10 16:54:00 UTC
Created attachment 75171 [details]
dmesg log

While it works with Windows XP, even through a Virtualbox VM, this device is not handled by Linux kernel.

I join dmesg logs.
Comment 1 Jose 2012-07-10 16:57:17 UTC
lsusb -v says :

Bus 002 Device 000: ID 1cae:4efc  
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0        64
  idVendor           0x1cae 
  idProduct          0x4efc 
  bcdDevice            0.00
  iManufacturer           1 
  iProduct                2 
  iSerial                 3 
  bNumConfigurations      1
Couldn't get configuration descriptor 0, some information will be missing
Couldn't get configuration descriptor 0, some information will be missing
Comment 2 Jose 2012-07-14 12:54:25 UTC
Looks like this is not a usb_storage problem, as even asking it to ignore the device with the quirks, the bug is here :

[18906.371063] usb 5-1: new high-speed USB device number 4 using ehci_hcd
[18921.473058] usb 5-1: device descriptor read/64, error -110
[18936.676052] usb 5-1: device descriptor read/64, error -110
[18936.879056] usb 5-1: new high-speed USB device number 5 using ehci_hcd
[18951.981059] usb 5-1: device descriptor read/64, error -110
[18967.184056] usb 5-1: device descriptor read/64, error -110
[18967.387060] usb 5-1: new high-speed USB device number 6 using ehci_hcd
[18972.399149] usb 5-1: device descriptor read/8, error -110
[18977.511136] usb 5-1: device descriptor read/8, error -110
[18977.714061] usb 5-1: new high-speed USB device number 7 using ehci_hcd
[18982.726116] usb 5-1: device descriptor read/8, error -110
[18987.838107] usb 5-1: device descriptor read/8, error -110
[18987.939071] hub 5-0:1.0: unable to enumerate USB device on port 1
[18988.180049] usb 1-1: new full-speed USB device number 2 using uhci_hcd
[19003.288048] usb 1-1: device descriptor read/64, error -110
[19018.497242] usb 1-1: device descriptor read/64, error -110
[19018.700056] usb 1-1: new full-speed USB device number 3 using uhci_hcd
[19033.805055] usb 1-1: device descriptor read/64, error -110
[19049.011046] usb 1-1: device descriptor read/64, error -110
[19049.214053] usb 1-1: new full-speed USB device number 4 using uhci_hcd
[19054.231915] usb 1-1: device descriptor read/8, error -110
[19059.344904] usb 1-1: device descriptor read/8, error -110
[19059.547056] usb 1-1: new full-speed USB device number 5 using uhci_hcd
[19064.563889] usb 1-1: device descriptor read/8, error -110
[19069.676877] usb 1-1: device descriptor read/8, error -110
[19069.777070] hub 1-0:1.0: unable to enumerate USB device on port 1

Note You need to log in before you can comment on or make changes to this bug.