Bug 44311 - S3 wake up on Gigabyte M720-US3 causes reboot since commit 2feec47d4c5f80b05f1650f5a24865718978eea4
S3 wake up on Gigabyte M720-US3 causes reboot since commit 2feec47d4c5f80b05f...
Status: CLOSED DUPLICATE of bug 43641
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
All Linux
: P1 normal
Assigned To: acpi_power-sleep-wake
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-07 22:46 UTC by Maciej Szmigiero
Modified: 2012-07-17 02:06 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.4 and current git
Tree: Mainline
Regression: Yes


Attachments
temporary workaround (617 bytes, patch)
2012-07-07 22:46 UTC, Maciej Szmigiero
Details | Diff

Description Maciej Szmigiero 2012-07-07 22:46:42 UTC
Created attachment 75031 [details]
temporary workaround

When resuming from Suspend to RAM (S3) state on Gigabyte GA-M720-US3 motherboard with BIOS version F7n the computer reboots.

This happens since commit 2feec47d4c5f80b05f1650f5a24865718978eea4 (ACPICA: ACPI 5: Support for new FADT SleepStatus, SleepControl registers) on (at least) 3.4 and current git.

If I define out disabling of BM arbitration on sleep introduced by this commit the computer wakes up successfully on both 3.4 and current git.

The attached patch contains a temporary workaround that I use to make the S3 working again.
Comment 1 Len Brown 2012-07-17 02:06:48 UTC

*** This bug has been marked as a duplicate of bug 43641 ***

Note You need to log in before you can comment on or make changes to this bug.