Bug 44261 - bisected - Notebook doesn't shutdown on poweroff, wakes up again immediately after
bisected - Notebook doesn't shutdown on poweroff, wakes up again immediately ...
Status: NEW
Product: Timers
Classification: Unclassified
Component: Realtime Clock
All Linux
: P1 normal
Assigned To: timers_realtime-clock
:
Depends on:
Blocks: 44321
  Show dependency treegraph
 
Reported: 2012-07-05 13:14 UTC by Heinz Wiesinger
Modified: 2015-02-19 16:37 UTC (History)
7 users (show)

See Also:
Kernel Version: 3.9
Tree: Mainline
Regression: Yes


Attachments

Description Heinz Wiesinger 2012-07-05 13:14:12 UTC
I have a HP EliteBook 8530w. In 3.2.21 I have the issue that my notebook doesn't shutdown anymore, but instead reboots. I did a bisect on the kernel and tracked it down to the following commit:

commit 63d1c8663a622c8861b65d89b6f24578cb485655
Author: Rabin Vincent <rabin.vincent@stericsson.com>
Date:   Tue Nov 22 11:03:14 2011 +0100

    rtc: Disable the alarm in the hardware (v2)

Please let me know if you need any more input.
Comment 1 Heinz Wiesinger 2012-07-15 11:10:10 UTC
still happening on 3.2.23
Comment 2 Enrico Tagliavini 2012-10-17 09:57:33 UTC
It happens to me too on kernel 3.6.0 .1 and .2. On 3.5 it works as expected. I have a lenovo thinkpad e530.
Comment 3 Jonathan Nieder 2012-11-05 09:15:23 UTC
References: http://thread.gmane.org/gmane.linux.kernel/1275580/focus=1388471
Comment 4 Jonathan Nieder 2012-11-05 09:17:39 UTC
First-bad-commit: 41c7f7424259ff11009449f87c95656f69f9b186 (?)
Comment 5 janne.m.boman 2013-05-23 16:19:17 UTC
Hi, any activity on this bug? I'm happy to test, since this is still persistent for me in Linux 3.9
Thanks.
-Janne
Comment 6 Benedikt Reinartz 2013-09-09 13:12:16 UTC
This does still happen in 3.10 with the Lenovo E530, however switching all tunables in powertop to the "Good" state "fixes" this issue. I haven't been able to determine the smallest set of variables to set.

It does also not happen when the device is on battery, though it does turn immediately on when having been shutdown and I plug it in.
Comment 7 ms 2013-09-19 20:39:20 UTC
Dear all,

This bug also appears on a tyan server running debian ( kernel 3.2.0-4). Last good kernel is debian 2.6.32-5, all on amd64 versions.
Hope that helps someone in the know to remove that bug. :)
Cheers
Michael

Note You need to log in before you can comment on or make changes to this bug.