Bug 44221 - (Denny) Acer Aspire AO531h (among other netbooks) requires reboot=b,f
(Denny)
Acer Aspire AO531h (among other netbooks) requires reboot=b,f
Status: RESOLVED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
https://bugs.launchpad.net/ubuntu/+so...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-03 17:57 UTC by Dennis Andrew Gutowski Jr
Modified: 2015-02-19 16:39 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.5.0-030500rc5-generic
Tree: Mainline
Regression: No


Attachments
dmesg output (52.55 KB, text/plain)
2012-07-03 17:57 UTC, Dennis Andrew Gutowski Jr
Details
dmidecode output (9.83 KB, text/plain)
2012-07-03 17:58 UTC, Dennis Andrew Gutowski Jr
Details
lspci output (10.95 KB, text/plain)
2012-07-03 17:59 UTC, Dennis Andrew Gutowski Jr
Details
/proc/mtrr output (572 bytes, text/plain)
2012-07-03 17:59 UTC, Dennis Andrew Gutowski Jr
Details
/proc/interrupts output (1.41 KB, text/plain)
2012-07-03 18:00 UTC, Dennis Andrew Gutowski Jr
Details
Patch to force reboot type to bios for Acer Aspire AO531h (1.17 KB, patch)
2013-06-13 18:28 UTC, Ash Willis
Details | Diff

Description Dennis Andrew Gutowski Jr 2012-07-03 17:57:58 UTC
Created attachment 74721 [details]
dmesg output

My Acer Aspire AO531h can start up and shut down just fine, but reboot locks up the machine with the bottom left lights and the HD light all lit like the fourth of July.

This has been happening in Ubuntu 11.10 and 12.04. 

Older versions of Ubuntu, as well as the newest crunchbang, all work just fine.

I have started a bug over at Launchpad, and here is the url:
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1019496/

uname -r reports it is using 3.5.0-030500rc5-generic.

I have attached:

dmesg output.
lspci -vvnn output.
/proc/interrupts output.
/proc/mtrr output.

I followed the step by step instructions on how to do this here:
https://wiki.ubuntu.com/Bugs/Upstream/kernel

I hope this helps, I seriously do not have a clue where this bug report belongs.

-Denny
Comment 1 Dennis Andrew Gutowski Jr 2012-07-03 17:58:30 UTC
Created attachment 74731 [details]
dmidecode output
Comment 2 Dennis Andrew Gutowski Jr 2012-07-03 17:59:05 UTC
Created attachment 74741 [details]
lspci output
Comment 3 Dennis Andrew Gutowski Jr 2012-07-03 17:59:33 UTC
Created attachment 74751 [details]
/proc/mtrr output
Comment 4 Dennis Andrew Gutowski Jr 2012-07-03 18:00:02 UTC
Created attachment 74761 [details]
/proc/interrupts output
Comment 5 Alan 2012-07-05 09:45:57 UTC
Where can be hard to guess.

If you do the following what occurs

boot with the kernel option init=/bin/sh

at the shell prompt
reboot -f



Also if you go to a text mode console and do a reboot -f does that hang in the same way ?

(problem is it could be hanging for various reasons including driver shutdown, BIOS funnies so it's sometimes fun trying to figure out the culprit)
Comment 6 Dennis Andrew Gutowski Jr 2012-07-06 17:56:10 UTC
I tried both reboot -f and init=/bin/sh, both do nothing to solve this.

Thanks for the suggestions though.
Comment 7 Alan 2012-07-06 19:19:15 UTC
another thing to check is that if you boot the machine and at the grub menu fro which kernel hit ctrl-alt-del does the box then hang rather than reboot ?
Comment 8 Alan 2012-07-06 19:31:29 UTC
If that does work then it means the bios is probably ok, if that fails then you've got a BIOS problem.

If it succeeds then try the boot options for how to reboot

reboot=bios
reboot=kbd

are the two most likely ones
Comment 9 Dennis Andrew Gutowski Jr 2012-07-06 21:17:39 UTC
how do you use the reboot=bios or reboot=kbd options?
Comment 10 Anon 2012-07-09 03:16:19 UTC
If I could add to this, same problem with an Acer Aspire D257-N57 netbook, shutdown works fine, 12.04 precise fresh install.

Ctrl-alt-del works from the grub menu. However, I have done a sudo reboot from the shell to see what it would hang on and all it did was logout from my current user and produce a root shell, although I'm not entirely sure if this is a related issue.
Comment 11 Anon 2012-07-09 03:29:18 UTC
edit: details on a root shell being produced are not related, separate issue.
Comment 12 danis 2012-09-21 08:21:17 UTC
I have the same machine, and had the same reboot problem on Ubuntu 12.04 LTS.

After countless combinations of suggestions made on the Web, I concluded solving mine with these, in terminal:

1. gksudo gedit /etc/default/grub
2. I found the line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
3. Changed it to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash reboot=b,f"
4. Saved and closed the file
5. sudo update-grub

Then, I shut it down, opened again, tried to reboot, and worked fine!
Comment 13 Alan 2012-09-21 12:42:38 UTC
Thanks - thats really useful to confirm.
Comment 14 danis 2012-09-21 16:32:08 UTC
(In reply to comment #13)
> Thanks - thats really useful to confirm.

I was so enthusiastic to post my first contribution to the solution of a bug, that I didn't check which one of the two parameters b (for bios) or f (for force) is used by the kernel. After the heat's gone, I can confirm that "reboot=b" works for me, and "reboot=f" not.
 
So, Alan, yes, you were right to advise experimenting with the reboot parameters.

I should lastly say that if after my step 5. I try reboot directly, as some people advise, it will hang again. It must be shut down first.
Comment 15 Ash Willis 2013-06-13 18:28:24 UTC
Created attachment 104671 [details]
Patch to force reboot type to bios for Acer Aspire AO531h

Dennis, Danis, please confirm whether this bug is still present in the latest kernel (3.10-rc5)
If the bug is still present, please revert any boot line quirks and try the attached patch. Please let me know if it's successful so we can get this bug closed.

Anon, please post your dmidecode output and I'll modify the patch to target your model of laptop too :)

Thanks guys,

Ash
Comment 16 Dennis Andrew Gutowski Jr 2013-06-13 22:24:55 UTC
Sorry I can't confirm, I no longer own that machine. I traded it for a Compaq CQ57.

-Denny
Comment 17 Ash Willis 2013-07-04 01:01:19 UTC
Before testing my proposed patch, Danis tested the latest kernel after revoking kernel boot parameter 'reboot' in grub. He confirms that this bug is no longer present in the latest kernel.

Note You need to log in before you can comment on or make changes to this bug.