Bug 4410 - Handler for [EmbeddedControl] returned AE_TIME - Asus laptop L4500R
Handler for [EmbeddedControl] returned AE_TIME - Asus laptop L4500R
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Other
i386 Linux
: P2 high
Assigned To: Alexey Starikovskiy
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-27 02:47 UTC by Milo Casagrande
Modified: 2006-08-10 00:04 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.11.6
Tree: Mainline
Regression: ---


Attachments
output from acpidmp (96.42 KB, text/plain)
2005-03-27 04:49 UTC, Milo Casagrande
Details
output from dmidecode (8.09 KB, text/plain)
2005-03-27 04:52 UTC, Milo Casagrande
Details
output from lspci -vv (9.09 KB, text/plain)
2005-03-27 04:56 UTC, Milo Casagrande
Details
output from /proc/interrupts (663 bytes, text/plain)
2005-03-27 04:58 UTC, Milo Casagrande
Details
output from dmesg -s64000 (5.96 KB, text/plain)
2005-09-10 12:56 UTC, Milo Casagrande
Details
output of acpidump (96.54 KB, text/plain)
2005-11-20 05:52 UTC, Milo Casagrande
Details
output of dmesg -s64000 (15.37 KB, text/plain)
2005-11-20 05:53 UTC, Milo Casagrande
Details
output of dmidecode (8.09 KB, text/plain)
2005-11-20 05:55 UTC, Milo Casagrande
Details
output of lspci -vv (9.24 KB, text/plain)
2005-11-20 05:56 UTC, Milo Casagrande
Details
output of `cat /proc/interrupts` (586 bytes, text/plain)
2005-11-20 05:57 UTC, Milo Casagrande
Details
output of `acpidump -t DSDT` (90.99 KB, text/plain)
2005-11-20 05:58 UTC, Milo Casagrande
Details
.config of kernel (55.36 KB, text/plain)
2006-07-26 12:03 UTC, Milo Casagrande
Details
output from /proc/cpuinfo (425 bytes, text/plain)
2006-07-26 12:04 UTC, Milo Casagrande
Details

Description Milo Casagrande 2005-03-27 02:47:51 UTC
Distribution: Ubuntu Hoary
Hardware Environment: Asus laptop L4500R

Problem Description: acpi doesn't work with the patched kernel, it used to work
with the 2.6.9 patched kernel.

dmesg -s40000:

100000 - 0000000017f40000 (usable)
 BIOS-e820: 0000000017f40000 - 0000000017f50000 (ACPI data)
 BIOS-e820: 0000000017f50000 - 0000000018000000 (ACPI NVS)
 BIOS-e820: 00000000ff7c0000 - 0000000100000000 (reserved)
383MB LOWMEM available.
On node 0 totalpages: 98112
  DMA zone: 4096 pages, LIFO batch:1
  Normal zone: 94016 pages, LIFO batch:16
  HighMem zone: 0 pages, LIFO batch:1
DMI 2.3 present.
ACPI: RSDP (v000 ACPIAM                                ) @ 0x000fad90
ACPI: RSDT (v001 A M I  OEMRSDT  0x05000425 MSFT 0x00000097) @ 0x17f40000
ACPI: FADT (v001 A M I  OEMFACP  0x05000425 MSFT 0x00000097) @ 0x17f40200
ACPI: ECDT (v001 A M I  OEMECDT  0x05000425 MSFT 0x00000097) @ 0x17f40360
ACPI: OEMB (v001 A M I  OEMBIOS  0x05000425 MSFT 0x00000097) @ 0x17f50040
ACPI: SSDT (v001    AMI   CPU1PM 0x00000001 INTL 0x20030522) @ 0x17f45250
ACPI: DSDT (v001  A0009 A0009000 0x00000000 INTL 0x20030522) @ 0x00000000
ACPI: PM-Timer IO Port: 0x808
Allocating PCI resources starting at 18000000 (gap: 18000000:e77c0000)
Built 1 zonelists
Kernel command line: root=/dev/hda3 ro quiet splash
__iounmap: bad address c00fffd9
Found and enabled local APIC!
mapped APIC to ffffd000 (fee00000)
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 32768 bytes)
Detected 1400.274 MHz processor.
Using pmtmr for high-res timesource
Console: colour VGA+ 80x25
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 384272k/392448k available (2520k kernel code, 7676k reserved, 1176k data
, 240k init, 0k highmem)
Checking if this processor honours the WP bit even in supervisor mode... Ok.
Calibrating delay loop... 2785.28 BogoMIPS (lpj=1392640)
Security Framework v1.0.0 initialized
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
CPU: After generic identify, caps: a7e9fbbf 00000000 00000000 00000000 00000180
00000000 00000000
CPU: After vendor identify, caps: a7e9fbbf 00000000 00000000 00000000 00000180 0
0000000 00000000
CPU: L1 I cache: 32K, L1 D cache: 32K
CPU: L2 cache: 1024K
CPU: After all inits, caps: a7e9fbbf 00000000 00000000 00000040 00000180 0000000
0 00000000
CPU: Intel(R) Pentium(R) M processor 1400MHz stepping 05
Enabling fast FPU save and restore... done.
Enabling unmasked SIMD FPU exception support... done.
Checking 'hlt' instruction... OK.
ACPI: setting ELCR to 0200 (from 0e30)
NET: Registered protocol family 16
EISA bus registered
PCI: PCI BIOS revision 2.10 entry at 0xf0031, last bus=3
PCI: Using configuration type 1
mtrr: v2.0 (20020519)
ACPI: Subsystem revision 20050309
ACPI: Found ECDT
    ACPI-0405: *** Error: Handler for [EmbeddedControl] returned AE_TIME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.SBRG.EC0_.RDC3] (N
ode d7f06dc0), AE_TIME
    ACPI-1138: *** Error: Method execution failed [\ECIO] (Node d7f06900), AE_TI ME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.BAT0._STA] (Node d
7f062c0), AE_TIME
    ACPI-0158: *** Error: Method execution failed [\_SB_.PCI0.BAT0._STA] (Node d
7f062c0), AE_TIME
ACPI: Interpreter enabled
ACPI: Using PIC for interrupt routing
ACPI: PCI Root Bridge [PCI0] (0000:00)
PCI: Probing PCI hardware (bus 00)
PCI: Ignoring BAR0-3 of IDE controller 0000:00:14.1
PCI: Transparent bridge - 0000:00:14.4
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P1._PRT]
ACPI: Embedded Controller [EC0] (gpe 6)
    ACPI-0405: *** Error: Handler for [EmbeddedControl] returned AE_TIME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.SBRG.EC0_.RDC3] (N
ode d7f06dc0), AE_TIME
    ACPI-1138: *** Error: Method execution failed [\ECIO] (Node d7f06900), AE_TI ME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.BAT0._STA] (Node d
7f062c0), AE_TIME
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0.P0P2._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 *5 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 *4 5 7 10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 5 7 *10 11 12 14 15)
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
    ACPI-0405: *** Error: Handler for [EmbeddedControl] returned AE_TIME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.SBRG.EC0_.RDC3] (N
ode d7f06dc0), AE_TIME
    ACPI-1138: *** Error: Method execution failed [\ECIO] (Node d7f06900), AE_TI ME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.BAT0._STA] (Node d
7f062c0), AE_TIME
    ACPI-0158: *** Error: Method execution failed [\_SB_.PCI0.BAT0._STA] (Node d
7f062c0), AE_TIME
pnp: PnP ACPI: found 13 devices
SCSI subsystem initialized
usbcore: registered new driver usbfs
usbcore: registered new driver hub
PCI: Using ACPI for IRQ routing
** PCI interrupts are no longer routed automatically.  If this
** causes a device to stop working, it is probably because the
** driver failed to call pci_enable_device().  As a temporary
** workaround, the "pci=routeirq" argument restores the old
** behavior.  If this argument makes the device work again,
** please email the output of "lspci" to bjorn.helgaas@hp.com
** so I can fix the driver.
pnp: 00:07: ioport range 0x228-0x22f has been reserved
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x0
NTFS driver 2.1.22 [Flags: R/W].
Initializing Cryptographic API
pci_hotplug: PCI Hot Plug PCI Core version: 0.5
acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.4
    ACPI-0405: *** Error: Handler for [EmbeddedControl] returned AE_TIME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.SBRG.EC0_.RDC3] (N
ode d7f06dc0), AE_TIME
    ACPI-1138: *** Error: Method execution failed [\ECIO] (Node d7f06900), AE_TI ME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.BAT0._STA] (Node d
7f062c0), AE_TIME
    ACPI-0158: *** Error: Method execution failed [\_SB_.PCI0.BAT0._STA] (Node d
7f062c0), AE_TIME
shpchp: shpc_init : shpc_cap_offset == 0
shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
ACPI: PCI Interrupt 0000:01:05.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ  11
radeonfb: Retreived PLL infos from BIOS
radeonfb: Reference=14.32 MHz (RefDiv=6) Memory=300.00 Mhz, System=133.34 MHz
radeonfb: PLL min 20000 max 35000
Non-DDC laptop panel detected
radeonfb: Monitor 1 type LCD found
radeonfb: Monitor 2 type no found
radeonfb: panel ID string: 1024x768
radeonfb: detected LVDS panel size from BIOS: 1024x768
radeondb: BIOS provided dividers will be used
Console: switching to colour frame buffer device 128x48
radeonfb: Dynamic Clock Power Management enabled
radeonfb (0000:01:05.0): ATI Radeon X5
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12
Non-volatile memory driver v1.2
Linux agpgart interface v0.100 (c) Dave Jones
agpgart: Detected Ati IGP9100/M chipset
agpgart: Maximum main memory to use for agp memory: 321M
agpgart: AGP aperture is 256M @ 0xe0000000
[drm] Initialized drm 1.0.0 20040925
ACPI: PCI Interrupt 0000:01:05.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ  11
[drm] Initialized radeon 1.14.0 20050125 on minor 0: PCI device 1002:5835 (ATI T
echnologies Inc)
ipmi message handler version v33
i8042.c: Detected active multiplexing controller, rev 1.1.
serio: i8042 AUX0 port at 0x60,0x64 irq 12
serio: i8042 AUX1 port at 0x60,0x64 irq 12
serio: i8042 AUX2 port at 0x60,0x64 irq 12
serio: i8042 AUX3 port at 0x60,0x64 irq 12
serio: i8042 KBD port at 0x60,0x64 irq 1
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
loop: loaded (max 8 devices)
PS2ESDI: error initialising device, releasing resources
nbd: registered device at major 43
b44.c:v0.95 (Aug 3, 2004)
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 4
PCI: setting IRQ 4 as level-triggered
ACPI: PCI Interrupt 0000:02:06.0[A] -> Link [LNKC] -> GSI 4 (level, low) -> IRQ 4
eth0: Broadcom 4400 10/100BaseT Ethernet 00:11:d8:38:63:c2
Uniform Multi-Platform E-IDE driver Revision: 7.00alpha2
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
ATIIXP: IDE controller at PCI slot 0000:00:14.1
ACPI: PCI Interrupt 0000:00:14.1[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ  11
ATIIXP: chipset revision 0
ATIIXP: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xff00-0xff07, BIOS settings: hda:DMA, hdb:pio
    ide1: BM-DMA at 0xff08-0xff0f, BIOS settings: hdc:DMA, hdd:pio
Probing IDE interface ide0...
hda: IC25N040ATMR04-0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
Probing IDE interface ide1...
hdc: TOSHIBA DVD-ROM SD-R2312, ATAPI CD/DVD-ROM drive
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 1024KiB
hda: 78140160 sectors (40007 MB) w/1740KiB Cache, CHS=16383/255/63, UDMA(100)
hda: cache flushes supported
 /dev/ide/host0/bus0/target0/lun0: p1 p2 p3 p4
hdc: ATAPI 24X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
ieee1394: Initialized config rom entry `ip1394'
ohci1394: $Rev: 1223 $ Ben Collins <bcollins@debian.org>
ACPI: PCI Interrupt 0000:02:05.1[B] -> Link [LNKC] -> GSI 4 (level, low) -> IRQ 4
ohci1394: fw-host0: OHCI-1394 1.0 (PCI): IRQ=[4]  MMIO=[fe000000-fe0007ff]  Max
Packet=[2048]
video1394: Installed video1394 module
ieee1394: raw1394: /dev/raw1394 device initialized
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 10
PCI: setting IRQ 10 as level-triggered
ACPI: PCI Interrupt 0000:00:13.2[A] -> Link [LNKD] -> GSI 10 (level, low) -> IRQ  10
ehci_hcd 0000:00:13.2: PCI device 1002:4345 (ATI Technologies Inc)
ehci_hcd 0000:00:13.2: irq 10, pci mem 0xfeb00000
ehci_hcd 0000:00:13.2: new USB bus registered, assigned bus number 1
ehci_hcd 0000:00:13.2: USB 2.0 initialized, EHCI 1.00, driver 10 Dec 2004
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 6 ports detected
hub 1-0:1.0: over-current change on port 1
ohci_hcd: 2004 Nov 08 USB 1.1 'Open' Host Controller (OHCI) Driver (PCI)
ACPI: PCI Interrupt 0000:00:13.0[A] -> Link [LNKD] -> GSI 10 (level, low) -> IRQ  10
ohci_hcd 0000:00:13.0: PCI device 1002:4347 (ATI Technologies Inc)
ohci_hcd 0000:00:13.0: irq 10, pci mem 0xfe900000
ohci_hcd 0000:00:13.0: new USB bus registered, assigned bus number 2
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 3 ports detected
ACPI: PCI Interrupt 0000:00:13.1[A] -> Link [LNKD] -> GSI 10 (level, low) -> IRQ  10
ohci_hcd 0000:00:13.1: PCI device 1002:4348 (ATI Technologies Inc)
ohci_hcd 0000:00:13.1: irq 10, pci mem 0xfea00000
ohci_hcd 0000:00:13.1: new USB bus registered, assigned bus number 3
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 3 ports detected
hub 1-0:1.0: over-current change on port 6
usbcore: registered new driver cdc_acm
drivers/usb/class/cdc-acm.c: v0.23:USB Abstract Control Model driver for USB mod
ems and ISDN adapters
usbcore: registered new driver usblp
drivers/usb/class/usblp.c: v0.13: USB Printer Device Class driver
Initializing USB Mass Storage driver...
usb 3-1: new low speed USB device using ohci_hcd and address 2
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
usbcore: registered new driver hiddev
input: USB HID v1.10 Mouse [Logitech Optical USB Mouse] on usb-0000:00:13.1-1
usbcore: registered new driver usbhid
drivers/usb/input/hid-core.c: v2.0:USB HID core driver
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard on isa0060/serio0
input: ImPS/2 Generic Wheel Mouse on isa0060/serio4
EISA: Probing bus 0 at eisa0
EISA: Detected 0 cards.
Advanced Linux Sound Architecture Driver Version 1.0.8 (Thu Jan 13 09:39:32 2005
 UTC).
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:00:14.5[B] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
ieee1394: Host added: ID:BUS[0-00:1023]  GUID[00e0180003276826]
ACPI: PCI Interrupt 0000:00:14.6[B] -> Link [LNKB] -> GSI 5 (level, low) -> IRQ 5
ALSA device list:
  #0: ATI IXP rev 0 with AD1980 at 0xfe700000, irq 5
  #1: ATI IXP Modem rev 1 at 0xfe800000, irq 5
NET: Registered protocol family 2
IP: routing cache hash table of 4096 buckets, 32Kbytes
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 16384 (order: 4, 65536 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 15
NET: Registered protocol family 8
NET: Registered protocol family 20
ACPI wakeup devices:
MC97 USB1 USB2 P0P2 BLAN SLPB
ACPI: (supports S0 S3 S4 S5)
EXT3-fs: mounted filesystem with ordered data mode.
VFS: Mounted root (ext3 filesystem) readonly.
Freeing unused kernel memory: 240k freed
kjournald starting.  Commit interval 5 seconds
Adding 514072k swap on /dev/hda4.  Priority:-1 extents:1
EXT3 FS on hda3, internal journal
Probing IDE interface ide2...
Probing IDE interface ide3...
Probing IDE interface ide4...
Probing IDE interface ide5...
lp: driver loaded but no devices found
cdrom: open failed.
kjournald starting.  Commit interval 5 seconds
EXT3 FS on hda2, internal journal
EXT3-fs: mounted filesystem with ordered data mode.
NET4: DECnet for Linux: V.2.5.68s (C) 1995-2003 Linux DECnet Project Team
DECnet: Routing cache hash table of 1024 buckets, 8Kbytes
NET: Registered protocol family 12
b44: eth0: BUG!  Timeout waiting for bit 80000000 of register 428 to clear.
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]
lp0: using parport0 (interrupt-driven).
b44: eth0: Link is down.
b44: eth0: Link is up at 100 Mbps, full duplex.
b44: eth0: Flow control is off for TX and off for RX.
    ACPI-0405: *** Error: Handler for [EmbeddedControl] returned AE_TIME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.SBRG.EC0_.RDC3] (N
ode d7f06dc0), AE_TIME
    ACPI-1138: *** Error: Method execution failed [\ECIO] (Node d7f06900), AE_TI ME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.SBRG.EC0_.ACPS] (N
ode d7f06e40), AE_TIME
    ACPI-1138: *** Error: Method execution failed [\ACPS] (Node d7f024a0), AE_TI ME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.AC0_._PSR] (Node d
7f06480), AE_TIME
Asus Laptop ACPI Extras version 0.29
  L4R model detected, supported
ACPI: Power Button (FF) [PWRF]
ACPI: Lid Switch [LID]
ACPI: Sleep Button (CM) [SLPB]
    ACPI-0405: *** Error: Handler for [EmbeddedControl] returned AE_TIME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.SBRG.EC0_.RDC3] (N
ode d7f06dc0), AE_TIME
    ACPI-1138: *** Error: Method execution failed [\ECIO] (Node d7f06900), AE_TI ME
    ACPI-1138: *** Error: Method execution failed [\_SB_.PCI0.SBRG.EC0_.ACPS] (N
ode d7f06e40), AE_TIME
    ACPI-1138: *** Error: Method execution failed [\ACPS] (Node d7f024a0), AE_TI ME
    ACPI-1138: *** Error: Method execution failed [\_PR_.CPU1._PPC] (Node d7f09c
c0), AE_TIME
ACPI: Thermal Zone [THRM] (58 C)
ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
agpgart: Found an AGP 3.0 compliant device at 0000:00:00.0.
agpgart: Xorg passes broken AGP3 flags (1f00020f). Fixed.
agpgart: Putting AGP V3 device at 0000:00:00.0 into 8x mode
agpgart: Putting AGP V3 device at 0000:01:05.0 into 8x mode
[drm] Loading R200 Microcode
NET: Registered protocol family 10
IPv6 over IPv4 tunneling driver
Comment 1 Milo Casagrande 2005-03-27 04:49:56 UTC
Created attachment 4805 [details]
output from acpidmp
Comment 2 Milo Casagrande 2005-03-27 04:52:03 UTC
Created attachment 4806 [details]
output from dmidecode
Comment 3 Milo Casagrande 2005-03-27 04:56:33 UTC
Created attachment 4807 [details]
output from lspci -vv
Comment 4 Milo Casagrande 2005-03-27 04:58:21 UTC
Created attachment 4808 [details]
output from /proc/interrupts
Comment 5 Luming Yu 2005-03-27 17:49:47 UTC
Please try 2.6.12-rc1-mm3
Comment 6 Andrew Morton 2005-05-25 21:16:46 UTC
Can we please have an update on this?  Does 2.6.12-rc5 work OK?
2.6.12-rc5-mm1?
Comment 7 Milo Casagrande 2005-05-31 01:19:43 UTC
I can get to compile 2.6.12-rc5, it gives me error on i8042.
Even 2.6.12-rc5-mm1 gives me the same error.
Comment 8 Adrian Bunk 2005-07-28 04:46:07 UTC
Is this problem still present in 2.6.13-rc3-mm3?
Comment 9 Milo Casagrande 2005-07-31 08:06:41 UTC
I can't compile 2.6.13-rc3-mm3, it gives me some error on 'netlink', on 2.6.12.3
without acpi patch it still doesn't work. i will try with acpi patch asap and
also with 2.6.13-rc4-mm1
Comment 10 Milo Casagrande 2005-08-01 00:33:18 UTC
I compiled 2.6.12.3 with acpi-20050729 patch from acpi.sourceforge.net:
frequency works, backlight switch (on/off) works but battery status doesn't
work, it says there's no battery.
Will try later with 2.6.13-rc4-mm1.
Comment 11 Milo Casagrande 2005-08-02 02:05:18 UTC
Compiled 2.6.13-rc4-mm1 but nothing works: frequency, backlight and even battery.
If some output are needed, ask me.
Comment 12 Len Brown 2005-08-16 15:29:53 UTC
Is it possible to compare:
2.6.13 -- latest kernel.org tree w/o any mm or ACPI patches
2.6.13 + latest ACPI patch
http://ftp.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/release/2.6.13/
2.6.13 + latest mm patch
Comment 13 Milo Casagrande 2005-08-20 08:09:03 UTC
Here the results:
2.6.13-rc6: frequency scaling works, battery status and backlight don't work.
2.6.13-rc6 + ACPI patch: frequency and backlight work, battery doesn't. At boot
it says: "ACPI unable to load the System Description Tables"
2.6.13-rc6 + mm patch: as 2.6.13-rc6 + ACPI patch.

with ACPI and mm patch when i plug in/out the AC adapter the brightness is
adjusting automatically.
Comment 14 Len Brown 2005-09-07 21:21:07 UTC
> Unable to load the System Description Tables

That means ACPI bailed out and you are running with it disabled.
Please re-test with 2.6.13 final.  If it still
fails this way, build it with CONFIG_ACPI_DEBUG=y
and attach the output from dmesg -s64000.
Comment 15 Milo Casagrande 2005-09-10 12:55:15 UTC
Now with 2.6.13.1 ACPI doesn't complain anymore, but only frequency works.
Comment 16 Milo Casagrande 2005-09-10 12:56:22 UTC
Created attachment 5967 [details]
output from dmesg -s64000
Comment 17 Alexey Starikovskiy 2005-09-12 03:34:24 UTC
It seems that it is another problem with EC device.
Comment 18 Daniel Drake 2005-09-17 10:15:22 UTC
Downstream bug report: http://bugs.gentoo.org/show_bug.cgi?id=105072
Comment 19 Luming Yu 2005-09-17 19:51:53 UTC
Please test linux-2.6.14-rc1 with ec_burst=1.
Comment 20 Alexey Starikovskiy 2005-11-17 06:41:30 UTC
No response from bug submitter for 2 months. Please reopen if bug is still present.
Comment 21 Milo Casagrande 2005-11-20 05:51:10 UTC
I've tried 2.6.14 with no patch: CPU frequency is not working, battery and
backlight switch also are not working.
I'm going to try with the 2.6.14.2 and also with 2.6.14-mm2 patch.
Thanks!
Comment 22 Milo Casagrande 2005-11-20 05:52:36 UTC
Created attachment 6621 [details]
output of acpidump
Comment 23 Milo Casagrande 2005-11-20 05:53:48 UTC
Created attachment 6622 [details]
output of dmesg -s64000
Comment 24 Milo Casagrande 2005-11-20 05:55:45 UTC
Created attachment 6623 [details]
output of dmidecode
Comment 25 Milo Casagrande 2005-11-20 05:56:36 UTC
Created attachment 6624 [details]
output of lspci -vv
Comment 26 Milo Casagrande 2005-11-20 05:57:24 UTC
Created attachment 6625 [details]
output of `cat /proc/interrupts`
Comment 27 Milo Casagrande 2005-11-20 05:58:11 UTC
Created attachment 6626 [details]
output of `acpidump -t DSDT`
Comment 28 Alexey Starikovskiy 2005-12-01 05:08:04 UTC
Did you try command line option "ec_burst=1", suggested in #19?
Comment 29 Milo Casagrande 2005-12-03 02:25:05 UTC
I did try with `ec_burst=1` on kernel 2.6.14.3, but it is not working. With
2.6.14.3 even the CPU frequency is not working.
Comment 30 Alexey Starikovskiy 2006-07-11 03:45:26 UTC
Please try latest stable kernel with patch from
http://bugzilla.kernel.org/show_bug.cgi?id=6455
Please also try 2.6.18-rc1 -- it should have all these patches applied.
Regarding processor control, please attach your .config and /proc/cpuinfo.
Comment 31 Milo Casagrande 2006-07-26 11:59:17 UTC
I compiled 2.6.18-rc2 and everything now is working. I only have some issue with
suspend (it is not working... but I don't use it very often).
Thank you!
Comment 32 Milo Casagrande 2006-07-26 12:03:41 UTC
Created attachment 8619 [details]
.config of kernel

.config of the compiled kernel
Comment 33 Milo Casagrande 2006-07-26 12:04:55 UTC
Created attachment 8620 [details]
output from /proc/cpuinfo

output from /proc/cpuinfo
Comment 34 Len Brown 2006-08-10 00:04:02 UTC
> I compiled 2.6.18-rc2 and everything now is working.

thanks.  closed.

Note You need to log in before you can comment on or make changes to this bug.