Bug 4393 - CONFIG_ACPI_DEBUG boot _STA hang unless ACPI_ENABLE_OBJECT_CACHE
Summary: CONFIG_ACPI_DEBUG boot _STA hang unless ACPI_ENABLE_OBJECT_CACHE
Status: REJECTED DUPLICATE of bug 5121
Alias: None
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core (show other bugs)
Hardware: i386 Linux
: P2 low
Assignee: Alexey Starikovskiy
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-23 10:47 UTC by Sergey Vlasov
Modified: 2006-09-28 13:12 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.11
Tree: Mainline
Regression: ---


Attachments
dmesg from booting 2.6.10 (15.05 KB, text/plain)
2005-03-23 10:49 UTC, Sergey Vlasov
Details
/proc/acpi/dsdt from MaxSelect A7wide (24.97 KB, application/octet-stream)
2005-03-23 10:51 UTC, Sergey Vlasov
Details

Description Sergey Vlasov 2005-03-23 10:47:34 UTC
Distribution: ALT Linux
Hardware Environment: MaxSelect A7wide notebook (AMD Mobile AMD Athlon(tm) XP
2500+, SiS 746 chipset)

Kernel 2.6.11 with ACPI enabled does not boot on this machine - it hangs after
printing "Executing all Device _STA and_INI methods:...".  Booting with
acpi_dbg_level=0x2f shows that it hangs on calling the \_SB_.BAT0._STA method.

Kernel 2.6.10 booted on this machine without problems. 2.6.11 with ACPI parts
(drivers/acpi/*, *include/*acpi*, drivers/pnp/pnpbios/core.c) reverted to 2.6.10
versions boots without hang.

2.6.11 with
http://www.kernel.org/pub/linux/kernel/people/lenb/acpi/patches/release/2.6.11/acpi-20050309-2.6.11.diff.bz2
was tried - it hangs the same way.

Booting 2.6.11 with acpi_dbg_level=0x3f shows an endless stream of these messages:

exregion-0294 [30] ex_system_io_space_han: system_io 0 (8 width)
adress=000000000000006c
exregion-0294 [31] ex_system_io_space_han: system_io 1 (8 width)
adress=000000000000006c

The hang seems to happen in this loop inside \_SB.PCI0.LPC0.PMRD:

                        While (RCMD (0x80, Local0))
                        {
                            Noop
                            Noop
                            Store (PMUC, Local5)
                            If (And (Local5, 0x01, Local2))
                            {
                                Store (PMUD, Local5)
                            }
                        }

(other loops seem to have timeouts, but this does not)
Comment 1 Sergey Vlasov 2005-03-23 10:49:58 UTC
Created attachment 4788 [details]
dmesg from booting 2.6.10

This is the dmesg output from the 2.6.10 kernel which works on this machine;
2.6.11 starts to call _STA/_INI methods in the same order, but hangs on
\_SB_.BAT0._STA.
Comment 2 Sergey Vlasov 2005-03-23 10:51:47 UTC
Created attachment 4789 [details]
/proc/acpi/dsdt from MaxSelect A7wide
Comment 3 Shaohua 2005-03-29 22:00:03 UTC
If you change the 'Noop' statement to 'stall(10)' in the 'RCMD' and 
the 'while' statement, what's the result?
The loop loops like waitting for BIOS to complete the operation, but BIOS 
seems doesn't respond.
Comment 4 Anton Farygin 2005-05-19 00:42:20 UTC
>If you change the 'Noop' statement to 'stall(10)' in the 'RCMD' and 
>the 'while' statement, what's the result?

no effect
Comment 5 Sergey Vlasov 2005-05-19 08:23:40 UTC
Boot hang seems to go away if ACPI debugging is turned off:

--- config-2.6.11-std26-up      2005-05-14 11:07:49 +0400
+++ .config     2005-05-19 18:52:25 +0400
@@ -1,7 +1,7 @@
 #
 # Automatically generated make config: don't edit
-# Linux kernel version: 2.6.11-std26-up-alt9
-# Fri May 13 18:44:03 2005
+# Linux kernel version: 2.6.11-std26-up-alt10
+# Thu May 19 18:52:25 2005
 #
 CONFIG_X86=y
 CONFIG_MMU=y
@@ -163,7 +163,7 @@
 CONFIG_ACPI_IBM=m
 CONFIG_ACPI_TOSHIBA=m
 CONFIG_ACPI_BLACKLIST_YEAR=0
-CONFIG_ACPI_DEBUG=y
+# CONFIG_ACPI_DEBUG is not set
 CONFIG_ACPI_BUS=y
 CONFIG_ACPI_EC=y
 CONFIG_ACPI_POWER=y
Comment 6 Sergey Vlasov 2005-05-19 08:27:06 UTC
Another data point: even if CONFIG_ACPI_DEBUG is enabled, the hang does not
occur if ACPI object caching is enabled with this patch:

--- linux-2.6.11/include/acpi/platform/acenv.h.acpi-cache	2005-03-02 10:37:50 +0300
+++ linux-2.6.11/include/acpi/platform/acenv.h	2005-05-19 19:15:21 +0400
@@ -44,6 +44,7 @@
 #ifndef __ACENV_H__
 #define __ACENV_H__
 
+#define ACPI_ENABLE_OBJECT_CACHE
 
 /*
  * Configuration for ACPI tools and utilities
Comment 7 Andrew Morton 2005-05-25 17:15:43 UTC
Is this problem still present in 2.6.12-rc5?
Comment 8 Anton Farygin 2005-05-26 01:51:17 UTC
Yes.
Comment 9 Anton Farygin 2005-05-26 04:26:58 UTC
this bug also reproduced on NEC Versa FM340

Comment 10 Len Brown 2005-08-16 14:41:49 UTC
still an issue in 2.6.13?
Comment 11 Anton Farygin 2005-08-17 05:03:29 UTC
This bug is reproduced on MaxSelect a7wide with kernel 2.6.13-rc6
Comment 12 Alexey Starikovskiy 2005-08-22 06:16:00 UTC
Reducing severity to low, because DEBUG mode is not intended for production systems.
Comment 13 Alexey Starikovskiy 2005-08-24 22:11:51 UTC

*** This bug has been marked as a duplicate of 5121 ***

Note You need to log in before you can comment on or make changes to this bug.