Bug 4371 - Battery doesn't work after suspend
Battery doesn't work after suspend
Status: REJECTED DUPLICATE of bug 4340
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 high
Assigned To: Pavel Machek
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-19 09:05 UTC by Pierre Ossman
Modified: 2005-06-04 09:23 UTC (History)
0 users

See Also:
Kernel Version: 2.6.11
Tree: Mainline
Regression: ---


Attachments
DSDT for the machine (164.94 KB, text/plain)
2005-03-19 09:07 UTC, Pierre Ossman
Details

Description Pierre Ossman 2005-03-19 09:05:51 UTC
Distribution: Fedora Core 3
Hardware Environment: HP/Compaq nx7010
Problem Description:

After suspend-to-ram the battery is sometimes not readable. The following error
is reported:

    ACPI-0405: *** Error: Handler for [EmbeddedControl] returned AE_TIME
    ACPI-1138: *** Error: Method execution failed [\_SB_.C046.C059.C0EA.C132]
(Node dff4e334), AE_TIME
    ACPI-1138: *** Error: Method execution failed [\_SB_.C132] (Node dff4943c),
AE_TIME
    ACPI-1138: *** Error: Method execution failed [\_SB_.C11F._BST] (Node
dff498b4), AE_TIME
Comment 1 Pierre Ossman 2005-03-19 09:07:15 UTC
Created attachment 4759 [details]
DSDT for the machine
Comment 2 Andrew Morton 2005-03-21 19:29:09 UTC
Did this work correctly in earlier kernels?   If so which versions?

Thanks.
Comment 3 Luming Yu 2005-03-22 00:15:53 UTC
Please test burst-mode EC patch filed at bug 3851
Comment 4 Pierre Ossman 2005-03-28 04:11:47 UTC
Suspend did not work on this laptop until very recently (2.6.11) so it is
difficult to tell if this is a regression or not.

I will try the patch and see if the bug seems to go away.
Comment 5 Pierre Ossman 2005-03-28 13:03:42 UTC
The patch made the error go away but I got a new one instead. The system now
believes that there is no battery connected after a suspend. Reloading 'battery'
has no effect.
Comment 6 Francois Munch 2005-04-27 06:51:31 UTC
Seems to be the same problem as bug #4340 (same hardware, same error messages)
unloading ohci1394 module before S3 suspend could be a temporary workaround
Comment 7 Andrew Morton 2005-05-25 16:23:51 UTC
Can you please test 2.6.12-rc5 and provide a status update?
Comment 8 Francois Munch 2005-05-31 09:05:54 UTC
tested whith 2.6.12-rc5 but without patch from bug #3851. the errors are still
present. rmmod 1394ohci prior to suspend solves the problem but then can't have
it working again.
Comment 9 Pierre Ossman 2005-05-31 09:33:04 UTC
Confirmed. Problem still present on 2.6.12-rc5.
Comment 10 Pavel Machek 2005-06-04 09:23:36 UTC

*** This bug has been marked as a duplicate of 4340 ***

Note You need to log in before you can comment on or make changes to this bug.