Bug 43581 - Sony Vaio Vgn-Fw21e Brightness Problem
Sony Vaio Vgn-Fw21e Brightness Problem
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: acpi_power-video
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-19 14:29 UTC by stratovarius
Modified: 2012-06-24 19:48 UTC (History)
0 users

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description stratovarius 2012-06-19 14:29:42 UTC
İ have radeon mobility hd 3470 card , my system is x86_64.  Before kernel 3.4.2 i check /sys/class/backlight/ file and i have setting about brightness setting(acpi_video) in this folder and i dont have any problem about brightness.

After update my kernel to 3.4.2 or new /sys/class/backlight/ is empty. 

Ps: i have same problem with both open driver (free) and fglrx driver. 

My laptop is sony vaio vgn-fw21e.

Lspci ;

http://paste.kde.org/503558/ 

Dmesg log ;

http://paste.kde.org/502346/

Kernel log;

http://paste.kde.org/502340/

My Chakra system;

uname -a
Linux PC 3.4.2-1-CHAKRA #1 SMP PREEMPT Mon Jun 11 15:21:32 UTC 2012 x86_64 GNU/Linux

My Arch system;

Linux PC 3.4.3-1-ARCH #1 SMP PREEMPT Mon Jun 18 08:28:29 CEST 2012 x86_64 GNU/Linux
Comment 1 stratovarius 2012-06-24 19:46:40 UTC

*** This bug has been marked as a duplicate of bug 43168 ***
Comment 2 stratovarius 2012-06-24 19:48:06 UTC
Patch of Bug 43168 is solve my problem.

New kernel of arch linux 3.4.4-2 is have this patch. 

Thanks.

Note You need to log in before you can comment on or make changes to this bug.