Bug 43371 - Lenovo touch inductive SlideNav panel not work
Summary: Lenovo touch inductive SlideNav panel not work
Status: RESOLVED DUPLICATE of bug 16004
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-06-13 18:54 UTC by Arnoques
Modified: 2012-06-14 10:20 UTC (History)
2 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments
Output of various commands (2.47 KB, text/plain)
2012-06-13 18:54 UTC, Arnoques
Details

Description Arnoques 2012-06-13 18:54:47 UTC
Created attachment 73584 [details]
Output of various commands

Hi,
  I'm cloning this bug because it was assigned to other_other and there was no answer in almost two years. I think Input Devices is the right component for this so I hope someone can help us with it.
  As stated in the original bug, I have very little experience compiling kernel modules, but I'm willing to learn whatever is needed to help you help me get this to work.

Thanks,
  Arnoques

More information:
-----------------
According to Lenovo's website (consumersupport.lenovo.com/ot/en/DriversDownLoads/Drivers_Show_4482.html), in Windows the SlideNav depends on the Synaptics driver. This makes me think that the SlideNav manufacturer is Synaptics. It is also called slidebar in many hardware manuals from Lenovo.

In addition, in /proc/bus/input/devices I have a "PS/2 Generic Mouse" even when there's no PS/2 connector in my notebook. Since Synaptics touchpads are also PS/2, I'm guessing that the slidenav is detected as that extra mouse.

Related bugs:
-------------
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/543119
https://bugs.freedesktop.org/show_bug.cgi?id=50660


+++ This bug was initially created as a clone of Bug #16004 +++

Lenovo Yxx0 laptops have a touch inductive panel http://www.gigamark.com/images/stories/8/Lenovo_y550/Untitled-4.jpg contains the pretty cool navigation slidebar http://www.fcenter.ru/img/article/notebooks/Lenovo_IdeaPad_Y550P/152399.jpg
How SlideNav should work:
User assign applications to the numbers. When user want to launch one of them, they touch slidenav in any place (touch but did not raise finger), after that driver show applications list on the screen http://www.fcenter.ru/img/article/notebooks/Lenovo_IdeaPad_Y550P/152341.jpg User move finger to the lift or to the right, until needed application was selected on the screen. After apllication selected user raise finger and this application started.

I tried use tp-smapi-dkms for detect slidenav buttons, but it's not work for me with error: No such device.
Comment 1 Alan 2012-06-14 10:20:15 UTC
Folding it back into one bug (and I'll move the assignment)

However bugzilla is a bug tracking facility not a way to ask for new drivers so I am not surprised it has been ignored.

*** This bug has been marked as a duplicate of bug 16004 ***

Note You need to log in before you can comment on or make changes to this bug.