Bug 43345 - EFI_STUB doesn't work on 3.5-rc1 for Thinkpads laptops
EFI_STUB doesn't work on 3.5-rc1 for Thinkpads laptops
Status: RESOLVED DUPLICATE of bug 43309
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 15:46 UTC by Alessandro Crismani
Modified: 2012-06-07 11:10 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.5-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Alessandro Crismani 2012-06-06 15:46:42 UTC
Hi everybody,

I'm enjoying the new EFI STUB interface for booting the kernel without additional bootloaders.

Particularly, I have an entry that the UEFI bios boots automatically on startup, where the entry was added with efibootmgr.

Yesterday, I've tried building 3.5-rc1. Upon rebooting, my system could not boot up, with the UEFI bios jumping to the second entry in the boot order, which is an UEFI shell.

From the UEFI shell, upon issuing:
-> vmlinuz.efi initrd=initramfs-linux.img root=/dev/... 

I get a Load: Error and the system halts.

The same procedure works beautifully with 3.3 and 3.4 and the boot process gives me a working linux laptop.

Bad news for me, I do not how to debug it further.

My machine is a Thinkpad T420s, and at least another Thinkpad user is experiencing the same problem at https://bbs.archlinux.org/viewtopic.php?id=136833&p=4 (end of the page)

On the same forum post, another user reports that it works for him, hence it may very well be that the Thinkpad UEFI does something strange this time.

I am sorry if I do not add more information, but all this stuff is new and obscure to me (and I am sorry if I am talking nonsense in the report). I'll gladly come back with as much information as I am guided to provide.

Alessandro
Comment 1 Matt Fleming 2012-06-07 10:28:53 UTC
I suspect this is the same bug as #43309. Can you try the commit in comment #5 and see if that kernel boots for you?
Comment 2 Alessandro Crismani 2012-06-07 10:57:04 UTC
Great,
Compiled, installed and booted. It came up like a charm! Seems that the linked commit does its magic!

Out of curiosity, will it be merged in 3.5-rc2?

Thanks a lot,
Alessandro
Comment 3 Matt Fleming 2012-06-07 10:59:20 UTC
Thanks very much for testing.

Yes, this regression is hitting quite a few users so it will likely be merged for -rc2.
Comment 4 Alessandro Crismani 2012-06-07 11:00:33 UTC
Great news,
Thank you for the prompt feedback and for such an outstanding job on Linux
Comment 5 Alan 2012-06-07 11:10:44 UTC

*** This bug has been marked as a duplicate of bug 43309 ***

Note You need to log in before you can comment on or make changes to this bug.