Bug 43342 - WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x1aa/0x1c0()
WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x1aa/0x1c0()
Status: RESOLVED DUPLICATE of bug 15704
Product: Networking
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Arnaldo Carvalho de Melo
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 22:44 UTC by gvs
Modified: 2012-08-24 15:41 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.4.1
Tree: Mainline
Regression: Yes


Attachments
dmesg / kernel.log output for this issue (2.37 KB, text/plain)
2012-06-28 10:22 UTC, Stefan J. Betz
Details

Description gvs 2012-06-05 22:44:40 UTC
Upgraded my kernel to 3.4.1 today, half a day later this appeared in dmesg. The box serves as a router for my lan.

------------[ cut here ]------------
WARNING: at net/sched/sch_generic.c:256 dev_watchdog+0x1aa/0x1c0()
Hardware name: VX800 
NETDEV WATCHDOG: eth0 (r8169): transmit queue 0 timed out
Modules linked in: via_rng rng_core veth ipt_ULOG cpufreq_conservative cpufreq_userspace cpufreq_powersave cls_u32 cls_flow sch_sfq sch_htb xt_TCPMSS xt_tcpmss iptable_mangle pppoe pppox xcbc sha512_generic fuse ppp_generic slhc xt_tcpudp ipt_MASQUERADE nf_conntrack_ipv6 nf_defrag_ipv6 xt_state ip6table_filter ip6_tables iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 iptable_filter ip_tables x_tables loop sd_mod usb_storage usblp uhci_hcd i2c_viapro i2c_core ehci_hcd fan button
Pid: 0, comm: swapper Not tainted 3.4.1 #1
Call Trace:
 [<c1021818>] ? warn_slowpath_common+0x78/0xb0
 [<c12a09aa>] ? dev_watchdog+0x1aa/0x1c0
 [<c12a09aa>] ? dev_watchdog+0x1aa/0x1c0
 [<c10218e3>] ? warn_slowpath_fmt+0x33/0x40
 [<c12a09aa>] ? dev_watchdog+0x1aa/0x1c0
 [<c102a79c>] ? run_timer_softirq+0xdc/0x200
 [<c128c33b>] ? process_backlog+0x6b/0x110
 [<c12a0800>] ? __netdev_watchdog_up+0x60/0x60
 [<c10264b7>] ? __do_softirq+0x67/0xf0
 [<c1026450>] ? irq_enter+0x60/0x60
 <IRQ>  [<c10262ae>] ? irq_exit+0x5e/0x90
 [<c10162d3>] ? smp_apic_timer_interrupt+0x43/0x80
 [<c1356436>] ? apic_timer_interrupt+0x2a/0x30
 [<c1008a84>] ? default_idle+0x14/0x30
 [<c1008c8a>] ? cpu_idle+0x4a/0x70
 [<c147d740>] ? start_kernel+0x278/0x27d
 [<c147d343>] ? kernel_init+0x192/0x192
---[ end trace b56852c622a8ca02 ]---
r8169 0000:02:00.0: eth0: link up

Linux bes 3.4.1 #1 Tue Jun 5 13:35:11 CEST 2012 i686 GNU/Linux
 
Gnu C                  4.4.7
Gnu make               3.81
binutils               2.20.1
util-linux             2.17.2
mount                  support
module-init-tools      3.12
e2fsprogs              1.41.12
PPP                    2.4.5
Linux C Library        2.13
Dynamic linker (ldd)   2.13
Procps                 3.3.2
Net-tools              1.60
Console-tools          0.2.3
Sh-utils               8.5
Modules Loaded         via_rng rng_core veth ipt_ULOG cpufreq_conservative cpufreq_userspace cpufreq_powersave cls_u32 cls_flow sch_sfq sch_htb xt_TCPMSS xt_tcpmss iptable_mangle pppoe pppox xcbc sha512_generic fuse ppp_generic slhc xt_tcpudp ipt_MASQUERADE nf_conntrack_ipv6 nf_defrag_ipv6 xt_state ip6table_filter ip6_tables iptable_nat nf_nat nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 iptable_filter ip_tables x_tables loop sd_mod usb_storage usblp uhci_hcd i2c_viapro i2c_core ehci_hcd fan button
Comment 1 Stefan J. Betz 2012-06-28 10:22:25 UTC
Created attachment 74411 [details]
dmesg / kernel.log output for this issue
Comment 2 Stefan J. Betz 2012-06-28 10:22:53 UTC
Affects me too, see attachment.
Comment 3 Alan 2012-08-24 15:41:39 UTC

*** This bug has been marked as a duplicate of bug 15704 ***

Note You need to log in before you can comment on or make changes to this bug.