Bug 4334 - kernel support for netmos 9835/9735 crippled since 2.6.9
Summary: kernel support for netmos 9835/9735 crippled since 2.6.9
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Parallel (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: drivers_parallel
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-03-13 01:11 UTC by Steven Brudenell
Modified: 2005-08-25 16:59 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.9 2.6.10 2.6.11 2.6.11.2
Tree: Mainline
Regression: ---


Attachments
Netmos combo card support (14.75 KB, patch)
2005-03-22 14:18 UTC, Bjorn Helgaas
Details | Diff

Description Steven Brudenell 2005-03-13 01:11:21 UTC
Distribution: Any
Hardware Environment: NetMos 9835 or 9735
Software Environment: Any
Problem Description: In kernel 2.6.9, a patch was added to parport_pc to support
the parallel port on netmos 9835 and 9735 chipsets, which are found on combo
parallel/serial pci cards. Support for these chips already existed in
parport_serial prior to this. Since parport_serial depends on parport_pc,
parport_pc always gets loaded first, with limited (parallel port only) support
for these cards, and the complete (parallel+serial) functionality in
parport_serial is superseded. The serial functionality of these cards does not
work in either 2.6.9 or 2.6.10.

Reproducible: Always
Steps to Reproduce:
1. Obtain NetMos 9835 or 9735 board.
2. Compile linux 2.6.9 or 2.6.10 with support for parport_serial enabled
(built-in or module, either way works).
3. Boot with this kernel.

Actual Results:  
Only the parallel port on this board is identified.

Expected Results:  
Both the parallel port and the serial ports (there are two on the 9835, which I
have) should be identified.

I have read of other people having an identical problem, with the same boards on
the same kernel version.
Removing support in parport_pc for these netmos boards produces the required
functionality.
Using 2.6.8.1 with the same configuration also works.
Comment 1 Bjorn Helgaas 2005-03-22 14:18:55 UTC
Created attachment 4781 [details]
Netmos combo card support

Better Netmos support
Comment 2 Adrian Bunk 2005-08-25 16:59:26 UTC
The patch from this bug is already applied in kernel 2.6.12, and I'm therefore
assuming that this issue is already fixed.

Note You need to log in before you can comment on or make changes to this bug.