Bug 43310 - no backlight control present for 3.4 - Sony VAIO VGN-FW21M, ATI Radeon HD 3400, Intel Core 2 Duo (P8600)
no backlight control present for 3.4 - Sony VAIO VGN-FW21M, ATI Radeon HD 340...
Status: CLOSED DUPLICATE of bug 43168
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: acpi_power-video
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 14:43 UTC by fafatheone
Modified: 2012-06-18 19:28 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.4
Tree: Mainline
Regression: Yes


Attachments
output of fwts on the latest linux 3.4 from the ubuntu quantal repositories. (123.00 KB, text/x-log)
2012-05-28 14:43 UTC, fafatheone
Details
DSDT disassembly (282.19 KB, text/x-dsl)
2012-05-28 14:44 UTC, fafatheone
Details
dmesg output on 3.4 from ubuntu quantal. (60.26 KB, text/x-log)
2012-05-28 14:45 UTC, fafatheone
Details

Description fafatheone 2012-05-28 14:43:32 UTC
Created attachment 73445 [details]
output of fwts on the latest linux 3.4 from the ubuntu quantal repositories.

beginning with 3.4-rc1 (I think), backlight control seems to be not in a working state for my laptop.
the keyboard shortcuts have no effect (but work) and the backlight settings are not displayed in gnome-control-center.

I compiled the latest 3.3.7 kernel from kernel.org and those things just work fine.
but it neither works with the latest kernel from the ubuntu quantal repository, nor with the latest kernel from kernel.ubuntu.com/~kernel-ppa/mainline, nor with a manually compiled kernel from kernel.org mainline git.

Hardware details:
Sony VAIO VGN-FW21M, ATI Radeon HD 3400, Intel Core 2 Duo (P8600)


Setting acpi_backlight=vendor didn't change anything, still no entries in /sys/class/backlight for 3.4.

I encountered some errors concering the DSDT, though.
I tried with both 3.4 ubuntu kernel and my vanilla 3.3.7 kernel, I got the same results using fwts:
The reassembly of DSDT failed because of some "zero length" errors.

Something odd I found in my dmesg for 3.4 and 3.3.7 is the two lines
[ 0.687620] [Firmware Bug]: ACPI: No _BQC method, cannot determine initial brightness
[ 24.098132] sony_laptop: brightness ignored, must be controlled by ACPI video driver
for both kernels.

But then, I wonder why backlight control works with 3.3.7 and it doesn't with 3.4, when I get the same test results and corresponding dmesg outputs.
Comment 1 fafatheone 2012-05-28 14:44:12 UTC
Created attachment 73446 [details]
DSDT disassembly
Comment 2 fafatheone 2012-05-28 14:45:22 UTC
Created attachment 73447 [details]
dmesg output on 3.4 from ubuntu quantal.
Comment 3 Len Brown 2012-06-05 02:12:15 UTC
Lets focus on the upstream compiled kernels...

you mentioned that kernel.org 3.3.7 works fine.
Does the latest upstream (4.0) work?
What is the 1st upstream kernel.org kernel that fails?
Can you bisect which commit broke machine?
Comment 4 fafatheone 2012-06-07 13:10:02 UTC
I did a git bisect of Linus' mainline kernel tree (between v3.3 and v3.4-rc1, v3.3 being the last kernel that works and v3.4-rc1 being the first that doesn't work), and it seems that commit
b60e7f6166857c76871977794fa266b02da1f394
is the cause of this bug.

The latest stable upstream v3.4.1 doesn't work, neither does the latest v3.5-rc1.
Comment 5 fafatheone 2012-06-07 14:05:10 UTC
Oh, I am sorry, it seems that I copied the wrong commit ID.
Here is the output of my git bisect:

ea9f8856bd6d4ed45885b06a338f7362cd6c60e5 is the first bad commit
commit ea9f8856bd6d4ed45885b06a338f7362cd6c60e5
Author: Igor Murzov <intergalactic.anonymous@gmail.com>
Date:   Fri Mar 30 21:32:08 2012 +0400

    ACPI video: Harden video bus adding.
    
    It is always better to check return values, so add some new checks and
    correct existing ones.
    
    v2: Be consistent and don't mix errors from -E* and AE_* namespaces.
    
    Signed-off-by: Igor Murzov <e-mail@date.by>
    Signed-off-by: Len Brown <len.brown@intel.com>

:040000 040000 aae58fd9e4c1f8216e00ff3236c72ed20220f2bd 466e3008e5e44c7976a49c59f0226ccb91d3c2f9 M	drivers
Comment 6 Len Brown 2012-06-12 03:04:00 UTC
thanks for the bisect.
for better or worse, you have company,
and so we'll close this as a duplicate of 43186

lets work this bug there...

*** This bug has been marked as a duplicate of bug 43186 ***
Comment 7 Len Brown 2012-06-12 03:06:09 UTC
bug 43168, that is

*** This bug has been marked as a duplicate of bug 43168 ***

Note You need to log in before you can comment on or make changes to this bug.