Bug 43309 - Kernel can't load throught UEFI (rEFInd)
Kernel can't load throught UEFI (rEFInd)
Status: CLOSED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 high
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
: 43345 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-28 06:42 UTC by Steve
Modified: 2012-06-20 04:52 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.4
Tree: Mainline
Regression: No


Attachments
Git bisection log (2.89 KB, text/plain)
2012-05-28 06:42 UTC, Steve
Details
Git bisection message (1.08 KB, text/plain)
2012-05-28 06:42 UTC, Steve
Details

Description Steve 2012-05-28 06:42:19 UTC
Created attachment 73439 [details]
Git bisection log

Kernel version v3.4+ can't load:

Error: Load Error while loading kernel ...

Git bisection included also as attachment:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux.git;a=commit;h=2e064b1e131eba262c0ba4268cb79dbc72edeece

Previous v3.4-rc7+ was working without any issues.

System - HW:
Intel board: DQ57TM; EFI v2.00
Intel CPU: i5 660@3.33GHz

System - SW:
gcc: 4.7.0 (20120430)
glibc: 2.15
binutils: 2.22.52.20120503
kernel: latest git
kmod: latest git
udev: latest git
util-linux: latest git

Please could you look at the bug.

Thank you for your time.
Comment 1 Steve 2012-05-28 06:42:46 UTC
Created attachment 73440 [details]
Git bisection message
Comment 2 Steve 2012-05-29 08:56:35 UTC
rEFInd: 0.4.1
Comment 3 Steve 2012-05-29 08:58:23 UTC
Kernel version 3.4 from tag v3.4 works fine.
Comment 4 Matt Fleming 2012-06-05 11:25:07 UTC
Does reverting the offending commit result in a working kernel?
Comment 5 Matt Fleming 2012-06-07 07:28:07 UTC
Could you try the following commit,

http://cgit.freedesktop.org/~jljusten/linux/commit/?id=17f82c609a7117556a46bfd7cb60d38bffb58221

(it might be easiest to just checkout Jordan's repository).
Comment 6 Alan 2012-06-07 11:10:44 UTC
*** Bug 43345 has been marked as a duplicate of this bug. ***
Comment 7 Steve 2012-06-11 20:06:26 UTC
Above patch from Jordan Justen solved this bug.
Also applied in kernel v3.5-rc2+ and it works correctly now.

Thank you for your time.
Comment 8 Keshav Amburay 2012-06-20 04:49:15 UTC
This is not yet fixed in mainline kernel 3.5-rc3 .
Comment 9 Keshav Amburay 2012-06-20 04:52:53 UTC
(In reply to comment #8)
> This is not yet fixed in mainline kernel 3.5-rc3 .

Strike that. I did not notice that this has been committed to mainline. Sorry guys.

Note You need to log in before you can comment on or make changes to this bug.