Bug 43299 - fails to suspend - ubuntu 12.04 amd64 - Asus 1201n
Summary: fails to suspend - ubuntu 12.04 amd64 - Asus 1201n
Status: CLOSED DUPLICATE of bug 43081
Alias: None
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: power-management_other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-25 20:11 UTC by uoL
Modified: 2013-02-10 06:41 UTC (History)
6 users (show)

See Also:
Kernel Version: 3.2.0-24-generic
Tree: Mainline
Regression: No


Attachments
Apport info (174.88 KB, application/zip)
2012-05-25 20:11 UTC, uoL
Details

Description uoL 2012-05-25 20:11:14 UTC
Created attachment 73393 [details]
Apport info

I have an Asus 1201n netbook, when I click suspend it start suspending but starts again and return to the login screen. Used to work fine in Ubuntu Desktop amd64 11.10.
(this same problem used to happen to me with debian squeeze)

part of the syslog goes like this:

May 24 18:02:09 uolbook3 kernel: [ 1214.444277] PM: suspend of drv:snd_hda_intel dev:0000:00:08.0 complete after 325.500 msecs
May 24 18:02:09 uolbook3 kernel: [ 1214.681880] PM: suspend of drv:sd dev:0:0:0:0 complete after 640.673 msecs
May 24 18:02:09 uolbook3 kernel: [ 1214.681930] PM: suspend of drv:scsi dev:target0:0:0 complete after 640.633 msecs
May 24 18:02:09 uolbook3 kernel: [ 1214.682011] PM: suspend of drv:scsi dev:host0 complete after 564.354 msecs
May 24 18:02:09 uolbook3 kernel: [ 1214.696059] PM: suspend of drv:ahci dev:0000:00:0b.0 complete after 577.447 msecs
May 24 18:02:09 uolbook3 kernel: [ 1214.696109] PM: suspend of drv: dev:pci0000:00 complete after 576.426 msecs
May 24 18:02:09 uolbook3 kernel: [ 1214.696148] PM: suspend of devices complete after 655.454 msecs
May 24 18:02:09 uolbook3 kernel: [ 1214.696155] PM: suspend devices took 0.656 seconds
May 24 18:02:09 uolbook3 kernel: [ 1214.728279] ehci_hcd 0000:00:06.1: PME# enabled
May 24 18:02:09 uolbook3 kernel: [ 1214.728310] ehci_hcd 0000:00:06.1: wake-up capability enabled by ACPI
May 24 18:02:09 uolbook3 kernel: [ 1214.744076] ohci_hcd 0000:00:06.0: PME# enabled
May 24 18:02:09 uolbook3 kernel: [ 1214.744093] ohci_hcd 0000:00:06.0: wake-up capability enabled by ACPI
May 24 18:02:09 uolbook3 kernel: [ 1214.760076] ehci_hcd 0000:00:04.1: PME# enabled
May 24 18:02:09 uolbook3 kernel: [ 1214.760092] ehci_hcd 0000:00:04.1: wake-up capability enabled by ACPI
May 24 18:02:09 uolbook3 kernel: [ 1214.776074] ohci_hcd 0000:00:04.0: PME# enabled
May 24 18:02:09 uolbook3 kernel: [ 1214.776090] ohci_hcd 0000:00:04.0: wake-up capability enabled by ACPI
May 24 18:02:09 uolbook3 kernel: [ 1214.792569] PM: late suspend of devices complete after 96.403 msecs
May 24 18:02:09 uolbook3 kernel: [ 1214.792620] ACPI: Preparing to enter system sleep state S3
May 24 18:02:09 uolbook3 kernel: [ 1214.820835] PM: Saving platform NVS memory
May 24 18:02:09 uolbook3 kernel: [ 1214.822036] Disabling non-boot CPUs ...
May 24 18:02:09 uolbook3 kernel: [ 1214.824661] CPU 1 is now offline
May 24 18:02:09 uolbook3 kernel: [ 1214.928046] CPU 2 is now offline
May 24 18:02:09 uolbook3 kernel: [ 1214.929733] Broke affinity for irq 22
May 24 18:02:09 uolbook3 kernel: [ 1215.032053] CPU 3 is now offline
May 24 18:02:09 uolbook3 kernel: [ 1215.033043] Extended CMOS year: 2000
May 24 18:02:09 uolbook3 kernel: [ 1215.033043] ACPI: Low-level resume complete
May 24 18:02:09 uolbook3 kernel: [ 1215.033043] PM: Restoring platform NVS memory
May 24 18:02:09 uolbook3 kernel: [ 1215.033043] Extended CMOS year: 2000
May 24 18:02:09 uolbook3 kernel: [ 1215.038941] Enabling non-boot CPUs ...
May 24 18:02:09 uolbook3 kernel: [ 1215.039234] Booting Node 0 Processor 1 APIC 0x2
May 24 18:02:09 uolbook3 kernel: [ 1215.039239] smpboot cpu 1: start_ip = 9a000
May 24 18:02:09 uolbook3 kernel: [ 1214.824508] Calibrating delay loop (skipped) already calibrated this CPU
May 24 18:02:09 uolbook3 kernel: [ 1214.824508] Disabled fast string operations
May 24 18:02:09 uolbook3 kernel: [ 1215.051072] NMI watchdog enabled, takes one hw-pmu counter.
May 24 18:02:09 uolbook3 kernel: [ 1215.052187] CPU1 is up

It seems to be suspending ok, but then it starts again, no aparent errors.

This user seems to be having the same problem http://www.ubuntu-es.org/node/167890

This is the related bug in Ubuntu's launchad https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1004178 where they told me to fill a new bug here.

Thanks in advance !
Comment 1 Vaccinus 2012-06-19 18:16:02 UTC
The same here.

As mentioned before:
http://www.ubuntu-es.org/node/167890

edit file /etc/rc.local and add two lines conataining:

echo US15 | sudo tee /proc/acpi/wakeup
echo USB0 | sudo tee /proc/acpi/wakeup

So it's like:
###########################################################################
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

echo US15 | sudo tee /proc/acpi/wakeup
echo USB0 | sudo tee /proc/acpi/wakeup

exit 0
#########################################################################


Works for me.
Have a good day!
Comment 2 uoL 2012-06-20 05:06:59 UTC
Yes! they updated and found the solution.. Works for me too. Will mark it as resolved.

Thanks !!
Comment 3 Gilboa Davara 2012-07-04 08:40:14 UTC
Work-around confirmed working on a number of Fedora 17 / x86_64 machines w/ 3.4 kernel.

- Gilboa
Comment 4 Jonathan Nieder 2012-07-07 21:02:53 UTC
Probably a duplicate of bug 43081.
Comment 5 Alan 2012-09-06 11:46:41 UTC
Probably will be ok without the workaround from 3.6
Comment 6 Len Brown 2013-02-08 17:58:41 UTC

*** This bug has been marked as a duplicate of bug 43081 ***
Comment 7 fpgahardwareengineer 2013-02-10 06:41:33 UTC
Hi,

As someone who has dealt with ASUS mainboards and chipset USB ports with OHCI USB controllers, I am not surprised that Eee PC 1201N has this bug.
This netbook uses NVIDIA chipset and is made by ASUS.
There is a recurring pattern of ASUS products and computers with OHCI USB controllers having this wakeup issues.
Not all such products have this bug, but it is a strong predictor.

Regards,

fpgahardwareengineer

Note You need to log in before you can comment on or make changes to this bug.