Bug 43252 - bdflush(2) is obsolete
Summary: bdflush(2) is obsolete
Status: CLOSED INVALID
Alias: None
Product: Documentation
Classification: Unclassified
Component: man-pages (show other bugs)
Hardware: All Linux
: P1 enhancement
Assignee: documentation_man-pages@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-16 06:37 UTC by Kazuo Moriwaka
Modified: 2012-08-16 07:39 UTC (History)
1 user (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: No


Attachments

Description Kazuo Moriwaka 2012-05-16 06:37:23 UTC
In recent kernel, bdflush(2) syscall is deprecated and not effective to anything.

Adding some statement about this situation to DESCRIPTION or NOTES section will be helpful for readers.

I think affected pages are: bdflush(2) and syscalls(2)

Best Regards,
Comment 1 Michael Kerrisk 2012-08-16 06:22:48 UTC
The bdflush(2) man page has long carried this text:

       Note:  Since Linux 2.6, this system call is deprecated and does
       nothing.  It is likely to disappear altogether in a future ker‐
       nel release.  Nowadays, the task performed by bdflush() is han‐
       dled by the kernel pdflush thread.

As far as I can see, the system call still exists, at least for x86-32.

If something further has changed (which exact recent kernel version, and, ideally a commit ID), please add this info to this bug.
Comment 2 Kazuo Moriwaka 2012-08-16 07:39:52 UTC
I'm sorry for I missed the note.  I close this bug. 
Thanks,

Note You need to log in before you can comment on or make changes to this bug.