Bug 43250 - [REGRESSION]Can't wake up PC form suspend to ram using usb devices on Asus P8P67 Pro
[REGRESSION]Can't wake up PC form suspend to ram using usb devices on Asus P8...
Status: CLOSED DUPLICATE of bug 43278
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: Lan Tianyu
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-15 18:31 UTC by rat.o.drat
Modified: 2013-02-08 18:07 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.3.5
Tree: Mainline
Regression: Yes


Attachments
offending patch to revert (3.60 KB, patch)
2012-06-05 02:31 UTC, Len Brown
Details | Diff

Description rat.o.drat 2012-05-15 18:31:25 UTC
Overview:
Starting form version 3.4.5 I can't wake up my PC from suspend to ram using any usb device. The devices are enabled in /proc/acpi/wakeup. In previous versions of the kernel this works with the same configuration.

Steps to reproduce:
echo EUSB > /proc/acpi/wakeup
echo USBE > /proc/acpi/wakeup
echo mem > /sys/power/state
Press a key on a usb keyboard connected to the PC.
Actual Results:
The PC stays suspended.
Expected Results:
The PC wakes up form suspend.

Additional information:
My motherboard is Asus P8P67 Pro.

I'm not sure but I think this bug is because of this commit: https://git.kernel.org/?p=linux/kernel/git/stable/linux-stable.git;a=commit;h=1ce9245f5aff46201fa81fdd3f796a6c9f3ad1ab
Comment 1 rat.o.drat 2012-05-16 09:09:49 UTC
I'm really sorry. I meant 3.3.5 and 3.3.6.
Comment 2 Alan 2012-05-17 14:10:49 UTC
Which was the last release that worked ?
Comment 3 rat.o.drat 2012-05-17 17:09:59 UTC
Alan: 3.3.4
Comment 4 Len Brown 2012-05-22 02:22:17 UTC
> I'm not sure but I think this bug is because of this commit

It looks like that commit will git revert cleanly -- 
can you test 3.4 with that commit reverted?
Comment 5 rat.o.drat 2012-05-24 13:11:40 UTC
Len Brown: how do I do that?
Comment 6 Len Brown 2012-06-05 02:30:48 UTC
If you have a git tree,

git revert 1ce9245f5aff46201fa81fdd3f796a6c9f3ad1ab

otherwise, get the (attached) patch
and revert it with patch -Rpn < bad.patch
Comment 7 Len Brown 2012-06-05 02:31:29 UTC
Created attachment 73509 [details]
offending patch to revert
Comment 8 Zhang Rui 2012-11-28 13:31:25 UTC
does the problem still exist in the latest upstream kernel?
Comment 9 Zhang Rui 2012-11-28 13:33:09 UTC
please verify if this is a duplicate of bug #43278
Comment 10 Lan Tianyu 2012-12-03 02:43:50 UTC
ping...
Comment 11 rat.o.drat 2012-12-04 20:39:18 UTC
I'm sorry for the lack of contact, I had some health problems.
The issue was fixed for me at least since 3.5.6.
#43278 seems to be the same bug.
Comment 12 Alan 2012-12-04 21:51:32 UTC
Thanks
Comment 13 Len Brown 2013-02-08 18:07:30 UTC

*** This bug has been marked as a duplicate of bug 43278 ***

Note You need to log in before you can comment on or make changes to this bug.