Bug 43231 - black screen on sonyvaio vpccw1
black screen on sonyvaio vpccw1
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-11 17:39 UTC by black_painkiller
Modified: 2012-11-13 07:47 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.4
Tree: Mainline
Regression: Yes


Attachments

Description black_painkiller 2012-05-11 17:39:21 UTC
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/984866

I though it was a nouveau problem but they told me it's from ACPI.
Also, on 3.3 backlight is reported as software , on 3.4 kernel thinks it is hardware and so nouveau does not enable control over it
Comment 1 Len Brown 2012-05-15 02:18:11 UTC
so 3.3.4 works and 3.4 fails?
can you bisect which commit caused the failure?
Comment 2 black_painkiller 2012-05-21 07:50:45 UTC
I'm not able to do that, sorry.
Comment 3 black_painkiller 2012-06-05 20:08:35 UTC
https://bugzilla.kernel.org/show_bug.cgi?id=43221
Comment 4 Vlad K 2012-06-06 07:41:58 UTC
This does appear to be a bug in drivers/acpi/video.c likely from commit ea9f8856bd6d4ed45885b06a338f7362cd6c60e5 as mentioned in other bug report. I was able to copy video.c from 3.3.6 branch and system booted no problem. Also I booted fine with "nomodeset" option and manually inserted nouveau, which produced these messages in kern.log: http://pastebin.com/3D3UZiw8
Comment 5 Vlad K 2012-06-07 20:30:14 UTC
After further testing it seems my previous comment is unrelated to this bug.
Comment 6 black_painkiller 2012-06-07 20:37:17 UTC
i reverted the version of drivers/acpi/video.c before that commit and recompile the kernel and it works.
did you mean the second part of your comment?
Comment 7 Vlad K 2012-06-07 21:29:24 UTC
yeah, after bisecting it appears to be a different regression in drm (43353).
Comment 8 black_painkiller 2012-06-19 20:57:41 UTC
dublicate of https://bugs.freedesktop.org/show_bug.cgi?id=50175.

in comments there the patch
https://bugzilla.kernel.org/attachment.cgi?id=73576

that fixes it!
Comment 9 Emil Velikov 2012-06-24 21:50:26 UTC
Vlad K

Copying files accross different kernel versions is a bad idea. Please consider reverting the commit in the future

Furthermore according to your dmesg you're experiencing another issue bug 43353

To the original reporter - the issue has been reported on freedesktop.org bug 5017 as well as kernel.org bug 43168, although it is an ACPI in nature

Consider closing the bug as a duplicate of bug 43168, as per original report
Comment 10 Zhang Rui 2012-11-13 07:47:58 UTC
Patch in bug #43168 has been shipped in upstream linux kernel.

please reopen the bug report if the problem still exists.

Note You need to log in before you can comment on or make changes to this bug.