Bug 43225 - ACPI Error: Method parse/execution failed, Namespace lookup failure, AE_NOT_FOUND
ACPI Error: Method parse/execution failed, Namespace lookup failure, AE_NOT_F...
Status: CLOSED WILL_NOT_FIX
Product: ACPI
Classification: Unclassified
Component: ACPICA-Core
All Linux
: P1 normal
Assigned To: acpi_acpica-core@kernel-bugs.osdl.org
:
Depends on:
Blocks: 43229
  Show dependency treegraph
 
Reported: 2012-05-10 09:59 UTC by Artem S. Tashkinov
Modified: 2013-01-28 23:59 UTC (History)
7 users (show)

See Also:
Kernel Version: 3.3.4
Tree: Mainline
Regression: No


Attachments
dmesg (58.32 KB, text/plain)
2012-05-10 09:59 UTC, Artem S. Tashkinov
Details
dmidecode (28.23 KB, text/plain)
2012-05-10 10:00 UTC, Artem S. Tashkinov
Details
dmesg: ACPI Errors with ASUS P8Z68V-LX BIOS 3904 and Linux kernel 3.4.4 (71.49 KB, text/plain)
2012-07-12 11:21 UTC, nono
Details

Description Artem S. Tashkinov 2012-05-10 09:59:53 UTC
Created attachment 73241 [details]
dmesg

After I have upgraded BIOS on my motherboard the kernel now spits a lot of ACPI related errors:

[    1.176306] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT3._GTF] (Node f302f7f8), AE_NOT_FOUND (20120111/psparse-536)
[    1.181392] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20120111/psargs-359)
[    1.182384] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT3._GTF] (Node f302f7f8), AE_NOT_FOUND (20120111/psparse-536)
[    1.184426] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20120111/psargs-359)
[    1.185444] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT5._GTF] (Node f302f888), AE_NOT_FOUND (20120111/psparse-536)
[    1.229215] ACPI Error: [DSSP] Namespace lookup failure, AE_NOT_FOUND (20120111/psargs-359)
[    1.230275] ACPI Error: Method parse/execution failed [\_SB_.PCI0.SAT0.SPT5._GTF] (Node f302f888), AE_NOT_FOUND (20120111/psparse-536)
[    3.284422] ACPI: Fan [FAN0] (off)
[    3.284461] ACPI: Fan [FAN1] (off)
[    3.284497] ACPI: Fan [FAN2] (off)
[    3.284531] ACPI: Fan [FAN3] (off)
[    3.284565] ACPI: Fan [FAN4] (off)
[    3.306910] ACPI Warning: 0x0000f000-0x0000f01f SystemIO conflicts with Region \_SB_.PCI0.SBUS.SMBI 1 (20120111/utaddress-251)
[    3.306919] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
Comment 1 Artem S. Tashkinov 2012-05-10 10:00:21 UTC
Created attachment 73242 [details]
dmidecode
Comment 2 Artem S. Tashkinov 2012-06-03 14:18:33 UTC
This problem also affects Asus P8Z68-V LX motherboard http://vip.asus.com/forum/view.aspx?id=20120524162204006 (Subject: [Sharing]BIOS 3904 released May 24, 2012/Forum > Motherboard > P8Z68-V LX)

Probably ASUS messed up with BIOS, I'm not sure.
Comment 3 zheng.z.yan 2012-06-20 03:07:00 UTC
would you please try 3.2 kernel
Comment 4 Artem S. Tashkinov 2012-06-20 08:49:17 UTC
(In reply to comment #3)
> would you please try 3.2 kernel

I tried it to no avail, this bug also affects kernel 3.3.
Comment 5 Robert Moore 2012-06-20 20:06:12 UTC
These types of not found errors are almost always BIOS bugs. Windows will silently abort the control method in these cases, whereas ACPICA will at least make some noise.
Comment 6 Artem S. Tashkinov 2012-06-20 20:25:11 UTC
(In reply to comment #5)
> These types of not found errors are almost always BIOS bugs. Windows will
> silently abort the control method in these cases, whereas ACPICA will at least
> make some noise.

I know Intel has close connections with motherboard manufactures, can you please make a request internally so that Asus fixed their BIOS? I'm sure as an end user I have no chance to draw enough attention to this problem - Asus support will silently ignore my requests.

And feel free to close this bug report as I assume kernel is flawless in this case.
Comment 7 nono 2012-07-12 11:18:38 UTC
I have Asus P8Z68-V LX motherboard and also these ACPI errors with Linux kernel 3.4.4.
Comment 8 nono 2012-07-12 11:21:44 UTC
Created attachment 75251 [details]
dmesg: ACPI Errors with ASUS P8Z68V-LX BIOS 3904 and Linux kernel 3.4.4
Comment 9 Feng Tang 2012-08-15 05:56:27 UTC
Does these warning cause any real problem? like some driver failing to work due to this?
Comment 10 Artem S. Tashkinov 2012-08-15 06:20:43 UTC
(In reply to comment #9)
> Does these warning cause any real problem? like some driver failing to work due
> to this?

I have no tangible problems but people who have similar error messages experience quite serious problems, see bug 43229
Comment 11 Alan 2012-09-06 11:40:53 UTC
On the basis on this box they are not causing problems - closing this one as WONTFIX - 43229 is clearly a bit different

Note You need to log in before you can comment on or make changes to this bug.