Bug 43221 - ACPI Backlight support reported when not present
ACPI Backlight support reported when not present
Status: CLOSED DUPLICATE of bug 43168
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 17:29 UTC by Tiziano Bacocco
Modified: 2012-05-15 02:19 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.4-rc5
Tree: Mainline
Regression: Yes


Attachments
acpidump (225.08 KB, application/octet-stream)
2012-05-09 19:44 UTC, Tiziano Bacocco
Details

Description Tiziano Bacocco 2012-05-09 17:29:12 UTC
After this commit ( found with bisect ) , nouveau refuses to control backlight because kernel reports it to be controlled by ACPI even if it isn't
This happens on SONY VAIO VPCF12Z1E



ea9f8856bd6d4ed45885b06a338f7362cd6c60e5 is the first bad commit
commit ea9f8856bd6d4ed45885b06a338f7362cd6c60e5
Author: Igor Murzov <intergalactic.anonymous@gmail.com>
Date:   Fri Mar 30 21:32:08 2012 +0400
     ACPI video: Harden video bus adding.
     
     It is always better to check return values, so add some new checks and
     correct existing ones.
     
     v2: Be consistent and don't mix errors from -E* and AE_* namespaces.
     
     Signed-off-by: Igor Murzov <e-mail@date.by>
     Signed-off-by: Len Brown <len.brown@intel.com>
 :040000 040000 aae58fd9e4c1f8216e00ff3236c72ed20220f2bd 466e3008e5e44c7976a49c59f0226ccb91d3c2f9 M drivers

acpi_video_backlight_support() is the failing function after this commit
Comment 1 Zhang Rui 2012-05-09 17:40:27 UTC
please attach the acpi dump output of your laptop.
Comment 2 Tiziano Bacocco 2012-05-09 19:44:53 UTC
Created attachment 73237 [details]
acpidump
Comment 3 Len Brown 2012-05-15 02:19:57 UTC
This commit
(ACPI video: Harden video bus adding.)
also caused bug 43168,
so close the newer bug as a duplicate of the older one...

*** This bug has been marked as a duplicate of bug 43168 ***

Note You need to log in before you can comment on or make changes to this bug.