Bug 43209 - PAE and radeon integrated rs690 (x1200) prevents dri
Summary: PAE and radeon integrated rs690 (x1200) prevents dri
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-05 16:35 UTC by Steven
Modified: 2015-02-19 17:34 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.4
Tree: Mainline
Regression: No


Attachments

Description Steven 2012-05-05 16:35:01 UTC
Originally reported here: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/993802

Please see original post for more info and let me know if I can provide anything else.

Description copied from original:

3D acceleration doesn't seem to work on the PAE kernel (which Ubuntu has made the default in my grub menu). The screen goes black (signal lost) after leaving grub, and only comes back with the login menu. If I use the non-PAE kernel, same version and everything, it seems to work. I've provided snippets of dmesg and xorg logs of both. Significant differences, I've noticed:

PAE Xorg.0.log:
[ 25.741] (II) RADEON(0): GPU accel disabled or not working, using shadowfb for KMS
[ 25.750] (II) RADEON(0): KMS Color Tiling: disabled

PAE: [ 25.741] (II) RADEON(0): GPU accel disabled or not working, using shadowfb for KMS
non-PAE: [ 22.066] (II) RADEON(0): mem size init: gart size :1fdff000 vram size: s:40000000 visible:3f7d7000
(an extra digit included?)

and PAE dmesg:
[ 2.046120] [drm] Loading RS690/RS740 Microcode
[ 2.057778] [drm] radeon: ring at 0x0000000060001000
[ 2.194499] [drm:r100_ring_test] *ERROR* radeon: ring test failed (scratch(0x15E4)=0xCAFEDEAD)
[ 2.194502] [drm:r100_cp_init] *ERROR* radeon: cp isn't working (-22).
[ 2.194506] radeon 0000:01:05.0: failed initializing CP (-22).
[ 2.194508] radeon 0000:01:05.0: Disabling GPU acceleration
[ 2.318118] [drm:r100_cp_fini] *ERROR* Wait for CP idle timeout, shutting down CP.
[ 2.440936] Failed to wait GUI idle while programming pipes. Bad things might happen.
[ 2.441053] [drm] radeon: cp finalized

$ lsb_release -rd

Description: Ubuntu 12.04 LTS
Release: 12.04

$ apt-cache policy linux-image-3.2.0-24-generic-pae:

linux-image-3.2.0-24-generic-pae:
  Installed: 3.2.0-24.38
  Candidate: 3.2.0-24.38
  Version table:
 *** 3.2.0-24.38 0
        500 http://archive.ubuntu.com/ubuntu/ precise-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     3.2.0-24.37 0
        500 http://archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
Comment 1 Steven 2012-05-07 00:36:39 UTC
In an effort to extend my desktop's life, I just tried plugging in an ATI Radeon HD 6450 and got the same result.  I guess this is a bug in the radeon driver on PAE kernels?  Would expect more people reporting problems, though....
Comment 2 Luis Montes 2012-09-04 04:35:19 UTC
Same here, on a 3.2.0-29-generic-pae kernel with a PCIe radeon:
VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Turks [Radeon HD 6570]
I get:
[drm:r600_ring_test] *ERROR* radeon: ring test failed (scratch(0x8504)=0xCAFEDEAD)
radeon 0000:01:00.0: disabling GPU acceleration

I don't get acceleration, but other than that, the system works reasonably well, so that might be the reason some people don't see the problem?

There was a similar report on the lkml about a year ago, but I tried a similar patch to that described in there and it caused a panic.

https://lkml.org/lkml/2011/6/3/277
Comment 3 Alan 2015-02-19 17:34:12 UTC
This bug relates to a very old kernel. Closing as obsolete.

Note You need to log in before you can comment on or make changes to this bug.