Bug 43203 - xhci stacktrace at connection of USB device to USB 3.0 port
Summary: xhci stacktrace at connection of USB device to USB 3.0 port
Status: RESOLVED INSUFFICIENT_DATA
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-04 18:31 UTC by marius.kotsbak+linux.bugs
Modified: 2015-02-19 17:35 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.2.0
Tree: Mainline
Regression: No


Attachments

Description marius.kotsbak+linux.bugs 2012-05-04 18:31:39 UTC
Also, the device does not work. The problem is not there in 3.4-rc5, so there is probably a patch that should be backported to 3.2.

Details from downstream Ubuntu bug https://bugs.launchpad.net/ubuntu/+source/linux/+bug/994248

[ 7232.104168] ------------[ cut here ]------------
[ 7232.104200] WARNING: at /build/buildd/linux-3.2.0/drivers/usb/host/xhci.c:3493 xhci_address_device+0x263/0x290()
[ 7232.104214] Hardware name: T1005
[ 7232.104220] Modules linked in: option usb_wwan usbserial uas usb_storage bnep rfcomm parport_pc bluetooth ppdev dm_crypt snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep arc4 binfmt_misc snd_pcm ath9k mac80211 snd_seq_midi snd_rawmidi snd_seq_midi_event snd_seq uvcvideo videodev ath9k_common ath9k_hw joydev snd_timer hid_multitouch snd_seq_device ath snd cfg80211 sparse_keymap dm_multipath psmouse serio_raw soundcore snd_page_alloc mac_hid lp parport dm_raid45 xor dm_mirror dm_region_hash dm_log usbhid hid r8169 i915 wmi drm_kms_helper drm i2c_algo_bit video
[ 7232.104384] Pid: 31, comm: khubd Tainted: G W 3.2.0-24-generic-pae #38-Ubuntu
[ 7232.104395] Call Trace:
[ 7232.104411] [<c1592996>] ? printk+0x2d/0x2f
[ 7232.104428] [<c105a632>] warn_slowpath_common+0x72/0xa0
[ 7232.104441] [<c1434b43>] ? xhci_address_device+0x263/0x290
[ 7232.104453] [<c1434b43>] ? xhci_address_device+0x263/0x290
[ 7232.104467] [<c105a682>] warn_slowpath_null+0x22/0x30
[ 7232.104480] [<c1434b43>] xhci_address_device+0x263/0x290
[ 7232.104494] [<c10685f0>] ? usleep_range+0x40/0x40
[ 7232.104508] [<c140ad8c>] hub_set_address+0x4c/0xe0
[ 7232.104521] [<c140bc27>] hub_port_init+0x167/0x660
[ 7232.104536] [<c1036578>] ? default_spin_lock_flags+0x8/0x10
[ 7232.104550] [<c140dd0b>] hub_port_connect_change+0x28b/0x640
[ 7232.104565] [<c140e4ed>] hub_events+0x42d/0x560
[ 7232.104579] [<c1079f8d>] ? finish_wait+0x4d/0x70
[ 7232.104591] [<c140e620>] ? hub_events+0x560/0x560
[ 7232.104603] [<c140e645>] hub_thread+0x25/0x140
[ 7232.104616] [<c1079e90>] ? add_wait_queue+0x50/0x50
[ 7232.104628] [<c107968d>] kthread+0x6d/0x80
[ 7232.104641] [<c1079620>] ? flush_kthread_worker+0x80/0x80
[ 7232.104655] [<c15af8fe>] kernel_thread_helper+0x6/0x10
[ 7232.104664] ---[ end trace 86a64641ed540051 ]---
[ 7232.104675] xhci_hcd 0000:02:00.0: Virt dev invalid for slot_id 0x3!
[ 7232.308066] usb 6-2: device not accepting address 4, error -22
[ 7232.308109] xHCI xhci_free_dev called with unaddressed device
[ 7232.420225] usb 6-2: new high-speed USB device number 5 using xhci_hcd
[ 7232.420252] xhci_hcd 0000:02:00.0: ERROR: unexpected command completion code 0x0.
[ 7232.624196] xhci_hcd 0000:02:00.0: ERROR: unexpected command completion code 0x0.
[ 7232.828193] usb 6-2: device not accepting address 5, error -22
[ 7232.940187] usb 6-2: new high-speed USB device number 6 using xhci_hcd
[ 7232.940211] xhci_hcd 0000:02:00.0: ERROR: unexpected command completion code 0x0.
[ 7233.144577] usb 6-2: Device not responding to set address.
[ 7233.348104] usb 6-2: device not accepting address 6, error -71
[ 7233.460127] usb 6-2: new full-speed USB device number 7 using xhci_hcd
[ 7233.460154] xhci_hcd 0000:02:00.0: ERROR: unexpected command completion code 0x0.
[ 7233.664119] usb 6-2: Device not responding to set address.
[ 7233.868179] usb 6-2: device not accepting address 7, error -71
[ 7233.868252] hub 6-0:1.0: unable to enumerate USB device on port 2

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: linux-image-3.2.0-24-generic-pae 3.2.0-24.38
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic-pae 3.2.16
Uname: Linux 3.2.0-24-generic-pae i686
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
ApportVersion: 2.0.1-0ubuntu7
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC269VB Analog [ALC269VB Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: marius 2046 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0x98200000 irq 52'
   Mixer name	: 'Realtek ALC269VB'
   Components	: 'HDA:10ec0269,1458b100,00100100'
   Controls : 16
   Simple ctrls : 9
Date: Thu May 3 23:39:45 2012
EcryptfsInUse: Yes
HibernationDevice: RESUME=UUID=49e028f9-7435-4850-8244-8523020782de
MachineType: GIGABYTE T1005
ProcEnviron:
 LANGUAGE=nb_NO:nb:no_NO:no:nn_NO:nn:en
 TERM=xterm
 PATH=(custom, user)
 LANG=nb_NO.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic-pae root=UUID=f1d0446d-3ea3-46a7-9842-8773acca78e6 ro quiet splash i8042.noloop=1 vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.2.0-24-generic-pae N/A
 linux-backports-modules-3.2.0-24-generic-pae N/A
 linux-firmware 1.79
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/30/2010
dmi.bios.vendor: GIGABYTE
dmi.bios.version: GSBF05
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: T1005
dmi.board.vendor: GIGABYTE
dmi.board.version: Base Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: Chassis Manufacturer
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnGIGABYTE:bvrGSBF05:bd08/30/2010:svnGIGABYTE:pnT1005:pvrGSBF05:rvnGIGABYTE:rnT1005:rvrBaseBoardVersion:cvnChassisManufacturer:ct1:cvrChassisVersion:
dmi.product.name: T1005
dmi.product.version: GSBF05
dmi.sys.vendor: GIGABYTE
Comment 1 Alan 2014-04-09 15:48:59 UTC
Is this still seen on a current (3.14) kernel ?

Note You need to log in before you can comment on or make changes to this bug.