Bug 43186 - Wireless not connecting with Intel Wifi Link 5100 and N mode
Wireless not connecting with Intel Wifi Link 5100 and N mode
Status: CLOSED DUPLICATE of bug 56581
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-01 10:43 UTC by Marc Tommasi
Modified: 2014-10-05 07:38 UTC (History)
6 users (show)

See Also:
Kernel Version: 3.2.0-24 and 3.4.0-999
Tree: Mainline
Regression: No


Attachments
Dmesg (77.63 KB, text/plain)
2012-05-01 10:45 UTC, Marc Tommasi
Details
lspci (13.70 KB, application/octet-stream)
2012-05-01 10:46 UTC, Marc Tommasi
Details
dmidecode (14.79 KB, application/octet-stream)
2012-05-01 10:47 UTC, Marc Tommasi
Details
dmesg (76.53 KB, application/octet-stream)
2012-05-02 10:38 UTC, Marc Tommasi
Details

Description Marc Tommasi 2012-05-01 10:43:34 UTC
Wireless not connecting with 3.2.0. The bug persists since at least 2.6.38.
Also tested with latest kernel (3.4.0), same effect.

WORKAROUND: I had to disable N mode with

options iwlwifi 11n_disable=1

in /etc/modprobe.d/disable11n.conf
Comment 1 Marc Tommasi 2012-05-01 10:45:08 UTC
Created attachment 73133 [details]
Dmesg
Comment 2 Marc Tommasi 2012-05-01 10:46:15 UTC
Created attachment 73134 [details]
lspci
Comment 3 Marc Tommasi 2012-05-01 10:47:13 UTC
Created attachment 73135 [details]
dmidecode
Comment 4 John W. Linville 2012-05-01 14:00:22 UTC
The dmesg output ends by saying that you are associated, which would normally mean "connected".  What is happening that you are classifying as "not connected"?
Comment 5 Marc Tommasi 2012-05-02 10:38:04 UTC
Created attachment 73158 [details]
dmesg

Oops, the first dmesg attachment was with N mode disabled...
This new one is with N mode enabled and shows several connection trials without any success.     
Marc.
Comment 6 Len Brown 2012-06-12 03:04:00 UTC
*** Bug 43310 has been marked as a duplicate of this bug. ***
Comment 7 Emmanuel Grumbach 2014-03-18 11:05:14 UTC

*** This bug has been marked as a duplicate of bug 56581 ***

Note You need to log in before you can comment on or make changes to this bug.