Bug 43136 - Elantech touchpad detected as Logitech mouse
Elantech touchpad detected as Logitech mouse
Status: RESOLVED INVALID
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-20 11:22 UTC by ubase133
Modified: 2012-04-28 11:45 UTC (History)
1 user (show)

See Also:
Kernel Version: 3.3.2
Tree: Mainline
Regression: No


Attachments
dmesg (67.00 KB, text/plain)
2012-04-20 11:23 UTC, ubase133
Details
xorg log (30.62 KB, text/plain)
2012-04-20 11:24 UTC, ubase133
Details

Description ubase133 2012-04-20 11:22:30 UTC
On ASUS laptop K52JU the touchpad works (two fingers scrolling and two-three fingers buttons emulation, too) but is detected by the kernel as a Logitech mouse and handled by evdev pointer catchall under Xorg. This is bad because you can't change touchpad settings like speed, acceleration, buttons emulation, side scrolling ecc. through Xorg rules files. The touchpad is Elantech.

I read this was a kernel issue that was fixed in 3.3, but for me is still here.
The kernel is configured with Slackware's huge-smp config (almost every driver is selected).

I found this in dmesg:

[12.069781] psmouse serio4: elantech: synaptics_send_cmd query 0x01 failed.


cat /proc/bus/input/devices:

I: Bus=0011 Vendor=0002 Product=0005 Version=0063
N: Name="ImPS/2 Logitech Wheel Mouse"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input9
U: Uniq=
H: Handlers=mouse0 event9 
B: PROP=0
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103
Comment 1 ubase133 2012-04-20 11:23:19 UTC
Created attachment 73004 [details]
dmesg
Comment 2 ubase133 2012-04-20 11:24:20 UTC
Created attachment 73005 [details]
xorg log
Comment 3 Dmitry Torokhov 2012-04-20 21:40:56 UTC
I forwarded this to Elantech guys.
Comment 4 Dmitry Torokhov 2012-04-27 21:27:02 UTC
Would you mind sharing why you marked this report as resolved so that people having similar problems would have more data, please?
Comment 5 ubase133 2012-04-28 11:45:16 UTC
The bug does not exist in this kernel. My mistake, i was still running the old 2.6 (affected by the bug) believing it was 3.3.2. Misleading bootloader labels.
Sorry for the false report

Note You need to log in before you can comment on or make changes to this bug.