Bug 43129 - suspend stalls if EHCI - Asus EEE PCs (r252b, probably also 1225b)
Summary: suspend stalls if EHCI - Asus EEE PCs (r252b, probably also 1225b)
Status: NEW
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Alan Stern
Depends on:
Reported: 2012-04-19 17:45 UTC by Adrian Batzill
Modified: 2013-01-31 15:22 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.4-rc3
Regression: No
Bisected commit-id:

dmesg output of the machine (68.85 KB, text/plain)
2012-04-19 17:45 UTC, Adrian Batzill
decompiled dsdt of the laptop (483.77 KB, text/plain)
2012-04-19 17:46 UTC, Adrian Batzill
lspci output (35.49 KB, text/plain)
2012-04-19 17:59 UTC, Adrian Batzill
dmidecode dump (10.64 KB, text/plain)
2012-04-19 17:59 UTC, Adrian Batzill
kern.log.1 after a reboot after failed suspend (118.67 KB, text/plain)
2012-04-21 13:52 UTC, Adrian Batzill

Description Adrian Batzill 2012-04-19 17:45:59 UTC
Created attachment 72984 [details]
dmesg output of the machine


I have a new Asus EEE Pc r252b.
Whenever I try to shut down the system (halt/poweroff/shutdown), Linux correctly shuts down but then reboots.
The behaviour is different from a normal reboot however. When I try to shut down, the Hard disk spins down at some point in time.
Also the break before the Bios-screen comes up again is longer if I try to shut down instead of when I try to reboot.

Also, suspend/resume does not work correctly.
When trying to suspend, everything is shut down including the hard disk. However, the Laptop stays on (Power LED is on instead of blinking and fan is still running).
The laptop has to be unplugged and the battery has to be removed in order to make it work again.
When trying suspend to disk, the same happens. However, the next boot will then correctly resume the old session.

This also seems to affect the new eee pc 1225b, according to this bug report:

The two devices are almost equal. In fact, using dmidecode, my r252b reports 1225b as the baseboard product name.

(btw: Sometimes when booting up, the buitin keyboard and mouse don't work (but worked in grub before). Could this also be related to the same issue or should I file a new bug for that?)

Let me know if you need more information.
Comment 1 Adrian Batzill 2012-04-19 17:46:55 UTC
Created attachment 72985 [details]
decompiled dsdt of the laptop
Comment 2 Adrian Batzill 2012-04-19 17:59:23 UTC
Created attachment 72986 [details]
lspci output
Comment 3 Adrian Batzill 2012-04-19 17:59:52 UTC
Created attachment 72987 [details]
dmidecode dump
Comment 4 Adrian Batzill 2012-04-21 12:02:06 UTC
For the record:
The same bug exists on multiple devices as reported here:
The patch posted in that other bug report fixes the problem
Comment 5 Adrian Batzill 2012-04-21 13:52:46 UTC
Created attachment 73030 [details]
kern.log.1 after a reboot after failed suspend

With the patch in the other bug, only the power off/reboot problem is fixed.
I now attached a kern.log.1 which shows up after a force-reboot after a failed suspend (only the last part of it because it's pretty big).
Comment 6 bjorn.ottervik 2012-06-06 22:15:56 UTC
A 1225b here. The suspend/resume issue can be worked around by creating the file described here → http://askubuntu.com/questions/53372/suspend-hibernate-doesnt-work-on-an-asus-laptop
Hopefully that helps someone find out what the real problem is, and if not, there's at least a work-around. The laptop still lose input every 1/5 boots roughly, but suspending/resuming often brings it back.
Comment 7 bjorn.ottervik 2012-06-06 22:17:58 UTC
Thought; Perhaps this should be brought to the attention of the Drivers/USB group instead of ACPI?
Comment 8 bjorn.ottervik 2012-07-02 20:52:18 UTC
Adding i8042.reset i8042.nomux to kernel boot parameters fixes the input issue.
Comment 9 Stéphane Gourichon 2012-07-04 08:06:04 UTC
Hi all,

I'm experiencing a suspend/resume problem on another Asus laptop, n55s (n55sf ) and script on 
http://askubuntu.com/questions/53372/suspend-hibernate-doesnt-work-on-an-asus-laptop is an efficient workaround. No identified drawback.


> The laptop still lose input every 1/5 boots
roughly, but suspending/resuming often brings it back.

What do you mean "the laptop lose input" ? Are keyboard and mouse ignored ? I think I never experienced that.
Comment 10 Len Brown 2013-01-30 21:18:32 UTC
shutdown problem appears fixed, so next is the suspend hang.

The script mentioned by Bjorn in comment #6 and Stephane in comment #9
will unbind/bind EHCI on suspend/resume.

moving bug to EHCI category.
Comment 11 Stéphane Gourichon 2013-01-31 07:03:28 UTC

> shutdown problem appears fixed,

If that is useful information, on Ubuntu, it appeared to be fixed from their kernel named "3.2.0-26-generic".

Ref: https://bugs.launchpad.net/linux/+bug/951143
Comment 12 Alan Stern 2013-01-31 15:22:39 UTC
The EHCI problem has been fixed in the 3.5 kernel.  The fix (commit dbf0e4c7257f8d684ec1a3c919853464293de66e, "PCI: EHCI: fix crash during suspend on ASUS computers") has also been applied to stable kernels for earlier versions.

Note You need to log in before you can comment on or make changes to this bug.