Bug 43123 - centrino: Wifi Networking is intermittent at best.
Summary: centrino: Wifi Networking is intermittent at best.
Status: CLOSED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: drivers_network-wireless@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-19 00:59 UTC by Christopher Phelps
Modified: 2014-03-23 07:48 UTC (History)
6 users (show)

See Also:
Kernel Version: 3.5
Tree: Mainline
Regression: Yes


Attachments
lshw on the box (19.40 KB, text/plain)
2012-04-19 15:20 UTC, Christopher Phelps
Details

Description Christopher Phelps 2012-04-19 00:59:40 UTC
On my Lenovo T500 and T510 everytime I update my system to the 3.2+ trunk of the kernel, I get intermittent connection to my wifi connection.  It always says I am connected but I can't ping out regularly, can't update my system because I can't connect to the servers, can't install new software, and can't do any work online.  This is a no go for me on the system, if I reset my wifi connection ... ie turn off the radio and then turn it back on ... it seems to work again for maybe a minute and then it doesn't work again.  As such at this time I have to downgrade my kernel to 3.0.  The connection should be stable, this is no longer about an issue with my laptop, as I have tested it extensively.  The issue seems to be with the updated kernel.  I pride myself in being bleeding edge and now I can no longer do this with Linux as I do not have a stable connection, or any connection for that matter, past the 3.0 branch of the kernel.
Comment 1 John W. Linville 2012-04-19 14:35:14 UTC
What hardware are you using?

What is the earliest kernel that displays the problem?  And the latest that does not have the problem?  Have you done a git bisect of the issue?
Comment 2 Christopher Phelps 2012-04-19 15:20:58 UTC
Created attachment 72982 [details]
lshw on the box
Comment 3 Christopher Phelps 2012-04-19 15:22:55 UTC
Attached my hardware list (via lshw)

Earliest kernel where I have experienced this is 3.2 the latest that I have not seen it is 3.0 (didn't test 3.1), I dont know how to do a git bisect.
Comment 4 Josh G 2012-07-18 18:07:25 UTC
I concur/have same issue.. Xubuntu 12.04.. running 3.2.. generic-pae now.. Same intermittent wifi.. As described..
Comment 5 Alan 2012-09-05 16:44:43 UTC
                description: Wireless interface
                product: Centrino Ultimate-N 6300
                vendor: Intel Corporation
Comment 6 Maat Ghandi 2012-11-02 16:24:16 UTC
I confirm this extremely annoying behavior as well
 - sometimes will stay connected, usually will not. Sometimes will drop instantly, other times after five minutes.
 - happens on all public wifi systems I have used, open and password protected
 - I have never had a problem with my home network (router= 2Wire, 2701HG-B)
 - seems to correlate with signal strength, meaning the times when I can maintain a signal are when I'm in a high strength area. However, signal drops in places where there is plenty of signal (i.e. other laptops are just fine)
 - when a signal is dropped I usually cannot reconnect without restarting network-manager
 - it seems like bringing down eth0 helps establish a connection (even though it will be dropped) but this could be more superstitious than anything at this point.

Kernel: 3.2.0-31-generic
OS: Ubuntu 12.04
Laptop model: 2012 Thinkpad x220t
wireless card: Centrino Ultimate-N 6300

lspci -vv -s 03:00.0

03:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 3e)
	Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 45
	Region 0: Memory at f2400000 (64-bit, non-prefetchable) [size=8K]
	Capabilities: <access denied>
	Kernel driver in use: iwlwifi
	Kernel modules: iwlwifi

modinfo iwlwifi

alias:          iwlagn
license:        GPL
author:         Copyright(c) 2003-2011 Intel Corporation <ilw@linux.intel.com>
version:        in-tree:
description:    Intel(R) Wireless WiFi Link AGN driver for Linux
firmware:       iwlwifi-5150-2.ucode
firmware:       iwlwifi-5000-5.ucode
firmware:       iwlwifi-6000g2b-6.ucode
firmware:       iwlwifi-6000g2a-5.ucode
firmware:       iwlwifi-6050-5.ucode
firmware:       iwlwifi-6000-4.ucode
firmware:       iwlwifi-100-5.ucode
firmware:       iwlwifi-1000-5.ucode
firmware:       iwlwifi-135-6.ucode
firmware:       iwlwifi-105-6.ucode
firmware:       iwlwifi-2030-6.ucode
firmware:       iwlwifi-2000-6.ucode
srcversion:     2EA00FA7EBFF006707244AA
Comment 7 Simon Strandman 2012-11-08 18:09:39 UTC
I have the same problem on Ubuntu 12.10 (3.5 kernel). Wifi works for a while but suddenly it just stops working. NetworkManager looks like it's connected with good signal strength but the network doesn't work at all. If I disconnect and reconnect to the AP I just get a message that it couldn't connect and a prompt to enter the password. It works again for a while after a reboot or a sleep/resume cycle (perhaps turning off/on the adapter will work to). This is really annoying of course. I will try with kernel 3.6 from kernel.org now but I guess that wont make a difference.

The hardware is a intel centrino wireless-n 6230.
Comment 8 Emmanuel Grumbach 2014-03-18 08:26:16 UTC
Is this still an issue?

Note You need to log in before you can comment on or make changes to this bug.