Bug 43107 - i915: Missed a PM interrupt
Summary: i915: Missed a PM interrupt
Status: RESOLVED DUPLICATE of bug 42907
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-15 08:59 UTC by Martin Mokrejs
Modified: 2012-04-19 20:44 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.3.2
Tree: Mainline
Regression: No


Attachments
dmesg (only the parts right after bootup) (46.94 KB, text/plain)
2012-04-15 08:59 UTC, Martin Mokrejs
Details
/proc/interrupts (3.10 KB, text/plain)
2012-04-15 10:17 UTC, Martin Mokrejs
Details
.config (81.55 KB, text/plain)
2012-04-15 10:17 UTC, Martin Mokrejs
Details

Description Martin Mokrejs 2012-04-15 08:59:38 UTC
Created attachment 72922 [details]
dmesg (only the parts right after bootup)

I just woke up my external LCD display attached via HDMI cable to my Dell Vostro 3550 laptop:

HDMI hot plug event: Codec=3 Pin=5 Presence_Detect=0 ELD_Valid=1
HDMI status: Codec=3 Pin=5 Presence_Detect=0 ELD_Valid=0
------------[ cut here ]------------
WARNING: at drivers/gpu/drm/i915/i915_irq.c:652 ironlake_irq_handler+0x356/0x411()
Hardware name: Vostro 3550
Missed a PM interrupt
Modules linked in: firewire_sbp2 firewire_ohci firewire_core usbmon iwlwifi usb_storage i2c_i801
Pid: 22029, comm: plugin-containe Not tainted 3.3.2-default #2
Call Trace:
 <IRQ>  [<ffffffff81072642>] warn_slowpath_common+0x80/0x98
 [<ffffffff810726ee>] warn_slowpath_fmt+0x41/0x43
 [<ffffffff81366bcc>] ironlake_irq_handler+0x356/0x411
 [<ffffffff8108fe33>] ? ttwu_do_activate.clone.49+0x57/0x5c
 [<ffffffff810319c5>] ? read_tsc+0x9/0x19
 [<ffffffff810b8789>] handle_irq_event_percpu+0x29/0x11f
 [<ffffffff810b88b2>] handle_irq_event+0x33/0x51
 [<ffffffff81042ba7>] ? ack_APIC_irq+0x10/0x12
 [<ffffffff810badfe>] handle_edge_irq+0x9b/0xbe
 [<ffffffff8102d083>] handle_irq+0x1f/0x27
 [<ffffffff8102cdb4>] do_IRQ+0x48/0xa0
 [<ffffffff816403eb>] common_interrupt+0x6b/0x6b
 <EOI>  [<ffffffff81640ae2>] ? system_call_fastpath+0x16/0x1b
---[ end trace 716da4cc6266e2c0 ]---
HDMI hot plug event: Codec=3 Pin=5 Presence_Detect=1 ELD_Valid=1
HDMI status: Codec=3 Pin=5 Presence_Detect=1 ELD_Valid=1
HDMI: detected monitor PLB2403WS at connection type HDMI
HDMI: available speakers: FL/FR
HDMI: supports coding type LPCM: channels = 2, rates = 32000 44100 48000, bits = 24

The LCD works and my X sessions as well. ;-0
Comment 1 Chris Wilson 2012-04-15 09:06:16 UTC
id:1315483222-2195-1-git-send-email-daniel.vetter@ffwll.ch
Comment 2 Daniel Vetter 2012-04-15 10:07:23 UTC
Patches are actually merged, so this looks more like a new issue. Also, we already have a report of a sighting of this warning after these patches have been merged, hence marking as a dupe

*** This bug has been marked as a duplicate of bug 42907 ***
Comment 3 Martin Mokrejs 2012-04-15 10:17:40 UTC
Created attachment 72925 [details]
/proc/interrupts

For completeness I am adding some more info about my system.
Comment 4 Martin Mokrejs 2012-04-15 10:17:59 UTC
Created attachment 72926 [details]
.config
Comment 5 Martin Mokrejs 2012-04-19 20:44:43 UTC
I just wonder whether it was related to 
"[drm] MTRR allocation failed.  Graphics performance may suffer." message in dmesg or not. Needless to say, I still have the message, even with 3.4-rc3.

Note You need to log in before you can comment on or make changes to this bug.