Bug 43103 - Unable to connect to 5Ghz wireless using Intel 4965 a/b/g/n
Unable to connect to 5Ghz wireless using Intel 4965 a/b/g/n
Status: CLOSED UNREPRODUCIBLE
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: Stanislaw Gruszka
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 19:37 UTC by Darren Watt
Modified: 2012-05-25 17:45 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.4.0-999-generic-pae
Tree: Mainline
Regression: No


Attachments
dmesg (64.23 KB, text/plain)
2012-04-13 19:37 UTC, Darren Watt
Details
lspci (15.25 KB, text/plain)
2012-04-13 19:38 UTC, Darren Watt
Details
modprobe -r iwl4965 good (2.6.39.4) (370.84 KB, text/plain)
2012-04-19 20:30 UTC, Darren Watt
Details
modprobe -r iwl4965 bad (3.0.0-0300) (353.91 KB, application/x-gzip)
2012-04-19 20:33 UTC, Darren Watt
Details

Description Darren Watt 2012-04-13 19:37:52 UTC
Created attachment 72913 [details]
dmesg

Unable to connect to 5Ghz, 2.4Ghz working fine, older versions of Ubuntu working up to and including ubuntu 11.04, broken after this point. Tested in mainline build, same problem occurs.
Occasionally connects, but usually just keeps requesting password for the network. They've recommended I open as a kernel bug.

Info:

darren@darren-xps:~$ uname -r
3.4.0-999-generic-pae
Comment 1 Darren Watt 2012-04-13 19:38:17 UTC
Created attachment 72914 [details]
lspci
Comment 2 Darren Watt 2012-04-13 19:39:24 UTC
Let me know if you need any further info. Thanks.
Comment 3 Darren Watt 2012-04-13 19:40:52 UTC
The original distro bug
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/974674
Comment 4 Stanislaw Gruszka 2012-04-16 13:52:05 UTC
Is this regression (i.e. some older kernel is able to connect with 5GHz AP) ?
Comment 5 Stanislaw Gruszka 2012-04-16 13:53:45 UTC
Ahh, I should read description more carefully. It is regression - ubuntu 11.04 worked, what kernel version is there?
Comment 6 Darren Watt 2012-04-16 18:56:35 UTC
(In reply to comment #5)
> Ahh, I should read description more carefully. It is regression - ubuntu 11.04
> worked, what kernel version is there?

Working fine on 11.04, same hardware, same router, same wlan.
darren@darren-XPS-M1530:~$ uname -r
2.6.38-13-generic-pae
Comment 7 Stanislaw Gruszka 2012-04-17 11:18:43 UTC
Ok, so this is most likely regression between 2.6.38 and 2.6.39 where the driver split was done between iwlwifi and iwlegacy. Please install 2.6.39 and confirm that the things do not work there (if works on 2.6.39, please find two consecutive kernel versions where bug was introduced i.e 3.0 and 3.1). Then provide verbose logs on good and bad kernel, so I could compere what we do differently regarding device programming on that kernel in your environment. How to generate logs is described here:
https://bugzilla.kernel.org/show_bug.cgi?id=35932#c2
Comment 8 Darren Watt 2012-04-17 22:04:46 UTC
2.6.39 - I lose wifi access altogether, would you still need the logs for this?
Comment 9 Stanislaw Gruszka 2012-04-18 18:31:05 UTC
You mean that 2.6.39 works even worse than 3.4 ? Hmm, did you use latest -stable release i.e. 2.6.39.4 ?
Comment 10 Darren Watt 2012-04-18 21:38:15 UTC
My bad, I was using an RC. Working ok on 2.6.39.4, will carry on testing when I can to work out when the problem jumps in. Cheers.
Comment 11 Darren Watt 2012-04-19 20:30:41 UTC
Created attachment 72991 [details]
modprobe -r iwl4965 good (2.6.39.4)

connects to 5ghz ok.
Comment 12 Darren Watt 2012-04-19 20:33:01 UTC
Created attachment 72992 [details]
modprobe -r iwl4965 bad (3.0.0-0300)

Fails to connect to 5ghz, repeatedly requests password for WEP only, even though the encryption is WPA. WPA not an option in the dropdown for encryption type.
Comment 13 Stanislaw Gruszka 2012-04-20 12:46:44 UTC
Logs does not include debug messages, there is:

> Apr 19 21:25:08 darren-XPS-M1530 kernel: [  122.136672] iwl4965: Unknown parameter `debug'

You did not compile with CONFIG_IWLWIFI_LEGACY_DEBUG option (option name can be different i.e current kernel it is CONFIG_IWLEGACY_DEBUG). Also do not forgot to clean up logs (i.e. do "echo > /var/log/kernel") before module load.
Comment 14 Darren Watt 2012-04-21 13:35:35 UTC
Hi - current progress, I compiled 3.4 with the debug options and currently it is working and connecting to 5Ghz. I will update next time it fails to connect.
Comment 15 Stanislaw Gruszka 2012-04-21 20:19:50 UTC
So kernel update must fix some (mac80211?) bug. I do not believe that compiling without CONFIG_IWLEGACY_DEBUG breaks thinks (or maybe, can you check?).

Ok, I'm closing this bug, if issue will repeat just reopen it.

Note You need to log in before you can comment on or make changes to this bug.