Bug 43100 - brcmsmac driver: associated with ap but dhclient fails to aquire ip
brcmsmac driver: associated with ap but dhclient fails to aquire ip
Status: RESOLVED UNREPRODUCIBLE
Product: Drivers
Classification: Unclassified
Component: network-wireless
All Linux
: P1 normal
Assigned To: drivers_network-wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-13 13:51 UTC by Patrick
Modified: 2012-09-04 15:51 UTC (History)
3 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments
/var/log/syslog of linux 3.4-rc4 (271.60 KB, text/plain)
2012-04-13 13:51 UTC, Patrick
Details

Description Patrick 2012-04-13 13:51:55 UTC
Created attachment 72907 [details]
/var/log/syslog of linux 3.4-rc4

Hardware: Samsung SF510 (shark) laptop

Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)

I'm using the brcmsmac module. I can see various access points in network-manager, including my home network, "Basel". When trying to connect to "Basel", however, it doesn't work. My interpretation of /var/log/syslog tells me that the failure is probably be caused by the brcmsmac driver that for some reason is not sending/receiving any packets to/from the access point.

Any suggestions about how to further track this down this most welcome!

I am currently testing this with linux 3.4-rc2.

I have tested 3.3.2 previously and it had the same problem.

Linux 3.2.14 does not have have the problem. The driver works fine there.
Comment 1 Patrick 2012-04-13 13:59:40 UTC
Other, probably related bug reports:

http://comments.gmane.org/gmane.linux.kernel/1272203

https://bugzilla.kernel.org/show_bug.cgi?id=42686
  (sorry, found that only now, could be an exact duplicate)

https://bbs.archlinux.org/viewtopic.php?pid=1074977#p1074977
Comment 2 Arend van Spriel 2012-04-17 12:23:16 UTC
bug 42686 is about iwlagn device so it would only be a duplicate when it is a mac80211 issue. From the log it shows dhcp is failing. 9 out of 10 times that means packets are not properly encrypted. wireless sniff or some logging info from your AP would help to determine that.
Comment 3 Patrick 2012-04-17 21:51:26 UTC
Hello, thanks for following up on this bug. I'm sorry to say that it 
seems to be non-reproducible at the moment. Let's "suspend" it. The 
last 2 times I bootet into 2.4-rc2, the wireless network got actually 
connectet normally. The first time, there was a strange lang between 
Step 4 and 5 of about a minute... ?? But otherwise everything worked 
fine.

Maybe the device (*cough*) just had to (*cough* ehr...) got used to the 
new driver.  - No - seriously - I don't know what might have been 
the problem here, but let's suspend it. Sorry for the noise.

Note You need to log in before you can comment on or make changes to this bug.