Bug 43097 - Screen brightness and other Fn keys do not work on HP Folio 13
Screen brightness and other Fn keys do not work on HP Folio 13
Status: CLOSED DUPLICATE of bug 54621
Product: ACPI
Classification: Unclassified
Component: EC
All Linux
: P1 normal
Assigned To: Lan Tianyu
https://bugs.launchpad.net/bugs/974568
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-12 17:37 UTC by Nick Harris
Modified: 2013-04-10 02:54 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.4
Tree: Mainline
Regression: No


Attachments
dmesg (folio 13-2000) (54.22 KB, text/plain)
2012-09-16 18:09 UTC, Stefan Nagy
Details
dmidecode (folio 13-2000) (12.06 KB, text/plain)
2012-09-16 18:10 UTC, Stefan Nagy
Details
ACPI Tables (folio 13-2000) (290.05 KB, text/plain)
2012-09-16 18:10 UTC, Stefan Nagy
Details
lspci -vvnn (folio 13-2000) (33.07 KB, text/plain)
2012-09-16 18:11 UTC, Stefan Nagy
Details
Disassembled ASL source code file - DSDT (folio 13-2000) (476.56 KB, text/plain)
2012-09-16 18:13 UTC, Stefan Nagy
Details
fwts results log (folio 13-2000) (311.48 KB, text/plain)
2013-02-03 18:02 UTC, Stefan Nagy
Details

Description Nick Harris 2012-04-12 17:37:09 UTC
Hardware: HP Folio 13 1000ea

Description:	Ubuntu precise (development branch)
Release:	12.04

I have had a good search online about this topic and the best advice seems to be that I should raise a bug here.
There has been good discussion in the forum here:
  http://ubuntuforums.org/showthread.php?t=1913496

But ultimately the screen brightness, and wifi toggle keys do not work, or seem to register in showkey, xev etc.
The media keys register an event, but do not seem to be mapped correctly to the appropriate action.

I see the same behaviour in 11.10 also...

Here is the url of this bug posted on launchpad: https://bugs.launchpad.net/bugs/974568
Comment 1 Ben Guthro 2012-04-17 17:45:09 UTC
FWIW, this also occurs with the 3.2.y stable kernel (tested up to 3.2.14)
Comment 2 Stefan Nagy 2012-08-06 09:16:08 UTC
I seem to be affected by the same bug on another sub-model, the HP Folio 13-2000, on Debian Wheezy (linux-image-3.2.0-3-amd64, 3.2.21-3).

For more information on my hardware see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=683777 – I reported this downstream before I found this report.
Comment 3 Stefan Nagy 2012-09-16 18:09:20 UTC
Created attachment 80271 [details]
dmesg (folio 13-2000)
Comment 4 Stefan Nagy 2012-09-16 18:10:04 UTC
Created attachment 80281 [details]
dmidecode (folio 13-2000)
Comment 5 Stefan Nagy 2012-09-16 18:10:46 UTC
Created attachment 80291 [details]
ACPI Tables (folio 13-2000)
Comment 6 Stefan Nagy 2012-09-16 18:11:39 UTC
Created attachment 80301 [details]
lspci -vvnn (folio 13-2000)
Comment 7 Stefan Nagy 2012-09-16 18:13:11 UTC
Created attachment 80311 [details]
Disassembled ASL source code file - DSDT (folio 13-2000)
Comment 8 Stefan Nagy 2012-09-16 18:23:59 UTC
I tested this with upstream kernel 3.5.3 and added some attachments which might me useful. I'd also like to add some more details on the affected keys:

Neither xev nor showkey, evtest, xinput or acpi_listen report anything at all when I press (Fn together with) certain keys. Affected are the following combinations: Fn+F2 (display brightness down), Fn+F3 (display brightness up), Fn+F12 (wireless on/off).

Other action keys work well out of the box like Fn+F6 (last music title), Fn+F7
(play/pause), Fn+F8 (next music title),…

If I forgot something relevant please tell me and I'll add the requested information as soon as possible.
Comment 9 Stefan Nagy 2013-02-03 18:02:21 UTC
Created attachment 92491 [details]
fwts results log (folio 13-2000)

According to https://wiki.ubuntu.com/Kernel/Reference/WMI "typically we are interested in WMI if a laptop or netbook has implemented hotkey events using WMI. In this case, we need to write a driver or extend and existing driver to capture the appropriate WMI events and map these onto key events."

I used the fwts Live-CD to get information about the WMI events. I'll attach the log-file (for all fwts tests). I guess this is the interesting part:

Found WMI Event, Notifier ID: 0xa0, GUID: 2B814318-4BE8-4707-9D84-A190A859B5D0, Instance 0x01
FAILED [MEDIUM] WMIUnknownGUID: Test 1, GUID 2B814318-4BE8-4707-9D84-A190A859B5D0 is unknown to the
kernel, a driver may need to be implemented for this GUID.
Comment 10 Stefan Nagy 2013-03-25 16:25:43 UTC
The patch provided in bug #54621 (comment #13 by Lan Tianyu) fixes this issue for me (HP Folio 13-2000). All three keys work perfectly with the patch applied.
Comment 11 Lan Tianyu 2013-04-10 02:47:50 UTC

*** This bug has been marked as a duplicate of bug 54621 ***

Note You need to log in before you can comment on or make changes to this bug.