Bug 43076 - Kernel panic after upgrade to 3.3.1
Summary: Kernel panic after upgrade to 3.3.1
Status: RESOLVED DUPLICATE of bug 43098
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: IA-64 (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: platform_ia-64
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-09 10:04 UTC by valère monseur
Modified: 2012-04-13 08:35 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.3.1
Tree: Mainline
Regression: No


Attachments
lspci output (4.15 KB, application/octet-stream)
2012-04-09 10:05 UTC, valère monseur
Details
lsusb info (505 bytes, application/octet-stream)
2012-04-09 10:05 UTC, valère monseur
Details

Description valère monseur 2012-04-09 10:04:41 UTC
Hi,

I've upgraded from 3.2.9 to 3.3.1 and I face a kernel panic after the messages: "Decompressing Linux...Parsing ELF...done." and "Booting the kernel".

The error message is "PANIC : early exception 06 rip 10 : ffffffff81456a10 error 0 cr 2 0"

I'm running a laptop DELL XPS L501X.
In attach, you can find the output of lspci and lsusb.
Comment 1 valère monseur 2012-04-09 10:05:16 UTC
Created attachment 72859 [details]
lspci output
Comment 2 valère monseur 2012-04-09 10:05:31 UTC
Created attachment 72860 [details]
lsusb info
Comment 3 valère monseur 2012-04-09 10:07:01 UTC
I'm running archlinux. You can find the way the kernel is built here:
https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/linux

What other info should I put or action should I take to find where the problem could be ?
Comment 4 valère monseur 2012-04-09 10:12:33 UTC
Ok, sorry for this report done too early. Seems it's already known in the distro and followed-up:

https://bugs.archlinux.org/task/29240
Comment 5 valère monseur 2012-04-09 11:44:47 UTC
Mmmm, finally the bug mentionned above is not the problem (at least the workaroung mentionned don't work) -> reopening.

So, my original question remains: what other info should I put or action should I take to find where the problem could be ?
Comment 6 j.heather 2012-04-11 07:52:37 UTC
I'm seeing this too. Same hardware, running on Fedora 16 and Fedora 17 Alpha/Beta. Worked for me up to 3.2.10; the update to 3.3 then hit this bug.

It is something to do with the wifi driver: disabling wifi in the BIOS allows the machine to boot (but a laptop without wifi isn't much use).

Simply turning the wifi off with the soft key combo before the GRUB screen doesn't help. I'd hoped that I could get round it by turning it off with the key combo, and then turning it back on after booting, but the panic still happens. And if I turn it off in the BIOS, I can't then turn it back on with the key combo after booting.
Comment 7 willcode4 2012-04-11 10:10:39 UTC
Same problem on Dell XPS15/L501X. Had to disable BOTH the wifi and ethernet nic in bios. Disabling just wifi didn't work.
Comment 8 nathansamson 2012-04-11 13:50:42 UTC
Exactly the same problem here, on the exact same hardware.



Component: 	IA-64
Assigned To: 	platform_ia-64@kernel-bugs.osdl.org

Why is this assigned to IA-64? The Dell XPS is an AMD 64-bit capable intel (i7 - i5 - i3) architecture.
So it should be  x86-64 or i386 (IA 64 is itanium, i7 is not itanium).

I observed the bug with 64 bit kernel, did anyone use a 32 bit kernel?
Comment 9 valère monseur 2012-04-11 14:55:18 UTC
@nathansamson@gmail.com: Indeed it's not Itanium but x86_64. Unfortunately I don't have authority to change the assignee.
Comment 10 j.heather 2012-04-12 21:07:54 UTC
@valere: Dare I suggest opening a new bug with the right architecture? The current assignee has not yet seen fit to comment or to reassign, and this won't get looked at otherwise.

If you do open a new bug, please post the link here so that we can copy our comments across and join in the game.
Comment 11 valère monseur 2012-04-13 08:34:54 UTC
@j.heather: new bug entry created: https://bugzilla.kernel.org/show_bug.cgi?id=43098

Marking this one as duplicate
Comment 12 valère monseur 2012-04-13 08:35:25 UTC

*** This bug has been marked as a duplicate of bug 43098 ***

Note You need to log in before you can comment on or make changes to this bug.