Bug 43064 - [00:1a.0 Intel USB] Asus U36SD kernel freeze at suspend
[00:1a.0 Intel USB] Asus U36SD kernel freeze at suspend
Status: CLOSED DUPLICATE of bug 42728
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-07 08:34 UTC by fougner89
Modified: 2012-07-14 15:33 UTC (History)
3 users (show)

See Also:
Kernel Version: 3.2.0
Tree: Mainline
Regression: No


Attachments

Description fougner89 2012-04-07 08:34:23 UTC
Since as far as I can remember, suspend never worked due to the following USB controllers not powering off at suspend, resulting in a freeze (?).

00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)

A fix is documented here, manually turning the controllers off when computer is going to sleep.
https://help.ubuntu.com/community/Asus_U36SD#Suspend

Some debugging information is available here
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/975341


I will try to do my best helping with additional information if requested.
Comment 1 fougner89 2012-04-07 08:50:59 UTC
Mainline 3.4-rc1, not sure if the same bug exists, suspend doesn't work, but there is no freeze as far as I can tell. It seems it doesn't even "try to" suspend. However, some devices (like wifi) are malfunctioning after trying to do a suspend.
Also, it looks like the fix for 3.2 doesn't work in 3.4-rc1. Will test some more to make sure.
Comment 2 Lan Tianyu 2012-04-09 06:42:46 UTC
Have you debugged the issue by steps in the sourcetree/Documentation/power/basic-pm-debugging.txt? If no, try it.
Comment 3 fougner89 2012-04-09 11:09:42 UTC
The following STD tests were made with the USB controller fix.

Hibernation in "reboot mode" worked 5+ times in a row.

"platform mode" did not shutdown the computer, the screen went black and nothing happened. However, when I boot it up again my session is restored.

"shutdown mode" worked 3 times in a row.


Now for the STR part. The USB controller fix is disabled, to be able to reproduce the problem. init=/bin/bash, running s2ram -f the screen goes black for a few seconds, then back to my session, this happens for all pm_test string, such as "freezer", "devices"... "core". All seems fine, until I set pm_test to none (which is the default?). The computer goes bonkers, fan spinning up, all I see is a blinking _ in the upper left corner.

If you want me to test something else, just tell me and I'll try to help.
Comment 4 AceLan Kao 2012-07-04 08:22:51 UTC
Hi,

Could you test this kernel? I added your pci id in it.
http://people.canonical.com/~acelan/bugs/lp951143/
Comment 5 fougner89 2012-07-04 12:51:43 UTC
Marking this as duplicate of #42728, because my problem is related to the same USB controller as in #42728

*** This bug has been marked as a duplicate of bug 42728 ***

Note You need to log in before you can comment on or make changes to this bug.