Bug 43061 - resolver.3 man page: RES_DEBUG option has effect only if libresolv compiled with DEBUG defined
resolver.3 man page: RES_DEBUG option has effect only if libresolv compiled w...
Status: RESOLVED CODE_FIX
Product: Documentation
Classification: Unclassified
Component: man-pages
All Linux
: P1 normal
Assigned To: documentation_man-pages@kernel-bugs.osdl.org
http://man7.org/linux/man-pages/man3/...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-06 22:39 UTC by Nathan Stratton Treadway
Modified: 2013-03-05 06:46 UTC (History)
2 users (show)

See Also:
Kernel Version: n/a
Tree: Mainline
Regression: No


Attachments

Description Nathan Stratton Treadway 2012-04-06 22:39:39 UTC
The resolver.3 man page's description of the available _res.options flag says:

RES_DEBUG
              Print debugging messages.

However, from looking at the libresolv source, I get the impression that if the library was not compiled with "DEBUG" defined then the RES_DEBUG option is silently ignored.  

Since it appears to be fairly common for the library to be compiled without DEBUG, it seems worth adding a note to the man page mentioning that RES_DEBUG will be ignored in that situation.

(As far as I can tell from the build logs, both Debian and Ubuntu build the eglibc packages without DEBUG defined.  Is there any easy way to tell on a given running system the whether libresolv was build with or without DEBUG defined?)

It might also be worth mentioning the compile-time issue on the resolv.conf.5 page (in the paragraph for the "debug" option).
Comment 1 Michael Kerrisk 2013-03-05 06:46:47 UTC
Thanks Nathan. I've applied the patch below.

Cheers,

Michael

diff --git a/man3/resolver.3 b/man3/resolver.3
index 991b263..f659325 100644
--- a/man3/resolver.3
+++ b/man3/resolver.3
@@ -27,7 +27,7 @@
 .\" Modified 1993-07-25 by Rik Faith (faith@cs.unc.edu)
 .\" Modified 2004-10-31 by aeb
 .\"
-.TH RESOLVER 3 2012-04-23 "GNU" "Linux Programmer's Manual"
+.TH RESOLVER 3 2013-03-05 "GNU" "Linux Programmer's Manual"
 .SH NAME
 res_init, res_query, res_search, res_querydomain, res_mkquery, res_send,
 dn_comp, dn_expand \- resolver routines
@@ -185,6 +185,10 @@ has been called.
 .TP
 .B RES_DEBUG
 Print debugging messages.
+This option is only available if glibc was built with debugging enabled,
+.\" See resolv/README.
+.\" Support for RES_DEBUG was made conditional in glibc 2.2.
+which is not the default.
 .TP
 .B RES_AAONLY
 Accept authoritative answers only.
diff --git a/man5/resolv.conf.5 b/man5/resolv.conf.5
index 9a3ca54..1358b73 100644
--- a/man5/resolv.conf.5
+++ b/man5/resolv.conf.5
@@ -18,7 +18,7 @@
 .\"
 .\" Added ndots remark by Bernhard R. Link - debian bug #182886
 .\"
-.TH RESOLV.CONF 5 2012-11-11 "" "Linux Programmer's Manual"
+.TH RESOLV.CONF 5 2013-03-05 "" "Linux Programmer's Manual"
 .UC 4
 .SH NAME
 resolv.conf \- resolver configuration file
@@ -133,7 +133,9 @@ where \fIoption\fP is one of the following:
 sets
 .BR RES_DEBUG
 in
-.IR _res.options .
+.IR _res.options
+(only effective if glibc was built with debug support; see
+.BR resolver (3)).
 .TP
 .BI ndots: n
 .\" Since glibc 2.2

Note You need to log in before you can comment on or make changes to this bug.