Bug 4306 - USB no longer survives resume in 2.6.11
USB no longer survives resume in 2.6.11
Status: REJECTED UNREPRODUCIBLE
Product: ACPI
Classification: Unclassified
Component: Power-Sleep-Wake
i386 Linux
: P2 normal
Assigned To: acpi_power-sleep-wake
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-08 00:50 UTC by Martin Lorenz
Modified: 2005-08-17 10:41 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.11
Tree: Mainline
Regression: ---


Attachments
the part of the syslog that was written during suspend/resume (4.06 KB, text/plain)
2005-03-08 00:52 UTC, Martin Lorenz
Details
the part of the syslog that was written during suspend/resume (more context) (23.10 KB, text/plain)
2005-03-08 01:10 UTC, Martin Lorenz
Details
My current Kernel config (from /proc/config.gz) (7.35 KB, application/x-gzip)
2005-03-08 01:13 UTC, Martin Lorenz
Details

Description Martin Lorenz 2005-03-08 00:50:32 UTC
Distribution: After upgrade to 2.6.11 (from 2.6.9) my USB-port needs
unloading/reloading of ehci/ohci modules to gut back to work after S3

Hardware Environment: SHARP PC-MM10
Software Environment: debian SID
Problem Description: Since I compiled 2.6.11 (using the config from 2.6.9 plus
the extra options make asked me :-) the usb subsystem no longer works after
suspending to ram. unloading and reloading ehci and ohci modules fixes it....

Steps to reproduce: boot
                    suspend-to-ram
                    resume
Comment 1 Martin Lorenz 2005-03-08 00:52:20 UTC
Created attachment 4688 [details]
the part of the syslog that was written during suspend/resume
Comment 2 Martin Lorenz 2005-03-08 00:56:23 UTC
BUGs #1884 and #2438 contain a lengthy description of my system
Comment 3 Martin Lorenz 2005-03-08 01:10:20 UTC
Created attachment 4689 [details]
the part of the syslog that was written during suspend/resume (more context)
Comment 4 Martin Lorenz 2005-03-08 01:13:06 UTC
Created attachment 4690 [details]
My current Kernel config (from /proc/config.gz)
Comment 5 Martin Lorenz 2005-03-08 23:45:49 UTC
Just discovered that the described behaviour is not always reproducible
I did not change anything in my suspend/resume process nor in my kernel or any
other part of the system but lately it worked.

on the other hand yesterday evening I lost all ACPI events after one
suspend/resume cycle...
I had similar problems in early 2.6-rc and 2.6 kernels (until 2.6.3 I think)

Comment 6 Andrew Morton 2005-05-25 15:31:54 UTC
Can you please retest 2.6.12-rc5 and provide an update?
Comment 7 Martin Lorenz 2005-05-26 12:02:11 UTC
seems to work again

but a new strange thing strikes me: the udev rule i configured for my memory-stick 
no longer reacts on the serial number of the stick

i had to rwrite the rule to take the vendor name instead.
it seems, that some fields no longer are reported to hotplug ...

Comment 8 Len Brown 2005-08-17 10:41:10 UTC
thanks for re-testing. please open a new bugzilla on
the memory stick issue if that is still a problem.

Note You need to log in before you can comment on or make changes to this bug.