Bug 4305 - USB mouse lockup
Summary: USB mouse lockup
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: i386 Linux
: P2 high
Assignee: Dmitry Torokhov
Depends on:
Reported: 2005-03-07 12:29 UTC by Ryan Daly
Modified: 2008-09-22 15:35 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.9-5.0.3.EL
Regression: ---
Bisected commit-id:


Description Ryan Daly 2005-03-07 12:29:29 UTC
Red Hat Enterprise WS v4

Hardware Environment:
Dell Precision 670n

Problem Description:
At various times, my mouse will lock up.  Pulling the mouse physically from the
USB port and reinserting will get the mouse working once again.

Steps to reproduce:
Not sure.  At various times, the mouse will simply lock.  I'm sure something is
triggering this, but haven't been able to narrow it down as of yet.
Comment 1 Nishanth Aravamudan 2005-03-09 11:16:06 UTC
Please retry with the current mainline kernel (2.6.11). If you are unable to
reproduce it there, I will close the bug. If you can't test with 2.6.11, then I
suggest filing a RedHat bug.
Thanks, Nish
Comment 2 Ryan Daly 2005-03-10 06:32:57 UTC
OK.  If you feel that the bug has been resolved, I'll wait until Red Hat 
updates their kernel and go from there.  You can leave this open or close.  If 
this continues to happen, I'll refile a bug.  Thanks.
Comment 3 Ryan Daly 2005-03-11 12:07:59 UTC
Do you know of a specific patch that has addressed this issue?
Comment 4 Ryan Daly 2005-03-17 11:24:28 UTC
Any updates on this?  Would you be able to provide me with a specific patch 
that resolved this issue in a later kernel?
Comment 5 Nishanth Aravamudan 2005-03-17 11:40:01 UTC

Sorry, I got doing other things for a bit there. I don't have any specific
patches, but the general setup for BugMe is that if a bug isn't reproducible in
mainline (currently, technically), then it is no longer a bug. I just
wanted to confirmation that the bug should stay open.

Like I said, if the bug does dissappear with, feel free to file a RHEL
bug on their Bugzilla and have them backport whatever patch fixed it.

Comment 6 Ryan Daly 2005-03-21 09:36:01 UTC
I just finished installing the kernel, and the bug is still present. 
What I find triggers this the most is if you're holding down one of ALT, CTRL,
or a combination of both.

I'm using FVWM for my window manager, and I have these keys set to change
certain behavior.  I've been finding that based on how much I'm doing with those
keys determines how frequently my mouse will lock on me.
Comment 7 Ryan Daly 2005-03-21 11:07:49 UTC
I've confirmed that this problem exists using different USB mice and on multiple
Comment 8 Dmitry Torokhov 2005-03-21 11:22:13 UTC
Your keyboard - is it PS/2 or USB as well? And is it possible that it's 
X/window manager that is locking up - if you switch to cnosole (and have GPM 
running) is mouse still not responsive?
Comment 9 Ryan Daly 2005-03-21 14:04:26 UTC
My keyboard is PS/2.

I've verified that the window manager remains active while the mouse is locked 
up.  I was able to type and minimize windows through key combinations.  I've 
also locked the mouse up under GNOME.

I just locked the mouse up using gpm, so this bug appears to be present all 
Comment 10 Natalie Protasevich 2007-11-17 22:28:54 UTC
Any update on this problem please.
Comment 11 Ryan Daly 2007-11-18 08:23:31 UTC
I have found that the issue appeared to be resolved with a BIOS update.  The system being used was a Dell Precision WorkStation 670.  You may want to investigate such an update for your system.
Comment 12 Alan 2008-09-22 15:35:45 UTC
USB legacy SMI problem methinks - various Dells had those

Note You need to log in before you can comment on or make changes to this bug.