Bug 430 - ACPI + PCI breaks ISA SoundBlaster
ACPI + PCI breaks ISA SoundBlaster
Status: CLOSED CODE_FIX
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts
i386 Linux
: P2 normal
Assigned To: Len Brown
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-02 20:13 UTC by Shawn Starr
Modified: 2004-03-03 14:59 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.5.xx-2.6.xx
Tree: Mainline
Regression: ---


Attachments
pci_link.c patch (8.89 KB, patch)
2003-11-04 21:23 UTC, Len Brown
Details | Diff

Description Shawn Starr 2003-03-02 20:13:17 UTC
Distribution: LFS 
Hardware Environment: IBM 300PL 6892-N2U PIII (Katmai) 450Mhz 
Problem Description: ACPI/PCI dont notice ISA irqs used 
 
Steps to reproduce: If I set pci=noacpi I have no IRQ conflicts. However, disabling  
pci=noacpi I get conflicts even though all IRQs are correct and are properly 
allocated. 
 
the /proc/interrupts for when pci=noacpi is set and disabled are identical however 
conflicts are reported by the ISAPnP OSS Soundblaster driver. 
  
PCI routing with ACPI isn't aware of ISA interrupts in use or ISA interrupts required.
Comment 1 Andy Grover 2003-03-03 08:05:03 UTC
known problem - don't know quite what to do yet. I think this means ACPI has 
to go from assigning IRQs to all link devices at boot to doing so on the fly.
Comment 2 Dave Jones 2003-03-17 15:49:34 UTC
Is this related to the other ACPI / IRQ problems too ?
If so, those other bugs can be marked as a dupe of this.
Comment 3 Shawn Starr 2003-05-12 20:56:36 UTC
Do we know if there is a solution for 2.5/2.6? if not, move this bug to POST 
2.6 fixes?
Comment 4 Andy Grover 2003-05-21 14:11:43 UTC
*** Bug 529 has been marked as a duplicate of this bug. ***
Comment 5 Cesar Eduardo Barros 2003-08-02 11:33:52 UTC
I also got hit by this. My ISA SB AWE PnP card will work only with pci=noacpi.
Without it, the sound card seems to work fine but the kernel receives zero
interrupts from it (/proc/interrupts is the same both with and without
pci=noacpi), which makes the sound stop after the first second of playback.

I did not get any conflicts (nothing else uses the IRQ). The motherboard is a
P5AB (ALi M1533).
Comment 6 Cesar Eduardo Barros 2003-10-10 11:13:32 UTC
People who are having problems should try test7. Something seems to have changed
in ACPI which fixed things for me. See bug 1139 comment 2.
Comment 7 Len Brown 2003-11-04 08:33:54 UTC
I've changed the summary to be specific to the soundblaster failure, 
let me know if that is not accurate. 
 
Please attach the dmesg and /proc/interrupts for the system 
with pci=noacpi, and without. 
 
Please also attach your .config to show what PNP options are selected 
and the output of acpidmp so we can see what the BIOS is telling 
ACPI to do. 
 
thanks, 
-Len 
 
 
Comment 8 Len Brown 2003-11-04 21:23:09 UTC
Created attachment 1353 [details]
pci_link.c patch

Please test this patch.  It applies to both current 2.4.23 and 2.6.0
If you need to reserve an IRQ for a Sound card, you can
now specify it on the command line, eg acpi_irq_isa=5
will reserve IRQ5 for an ISA sound blaster rather than
mapping PCI interrupts to that IRQ.

Please attach resulting dmesg and /proc/interrupts.

thanks,
-Len
Comment 9 Len Brown 2003-11-28 21:54:16 UTC
The attached patch is in 2.4.23-rc5, and is staged for post-2.6.0. 
Please re-open if you have any trouble with it. 
 
thanks, 
-Len 
 
Comment 10 Shawn Starr 2004-02-23 12:56:58 UTC
I have yet to test the patch currently using 2.6.3-bk4.. I will report back and
or reopen ticket if I experience problems...

Note You need to log in before you can comment on or make changes to this bug.