Bug 42984 - scrabled video with nouveau drivers on mac mini (320m)
scrabled video with nouveau drivers on mac mini (320m)
Status: NEW
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-24 01:26 UTC by garegin
Modified: 2013-05-27 19:45 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.2
Tree: Mainline
Regression: No


Attachments

Description garegin 2012-03-24 01:26:09 UTC
I had this problem with ubuntu 11.10 and every other distro. tried it in both bios emulation and efi. the efi is broken with or without KMS. I suspect this is because under efi the same driver is being used in KMS or UMS whereas in bios emulation, the nomodeset option in grub loads the vesa driver.

right now in using kernel 3.2.1 and it the same problem with every distro you can think of.
the video chip is 320m. I have tried it on a mbp with intel graphics and it works perfect under efi and bios.
Comment 1 garegin 2012-04-16 04:15:17 UTC
fixed with kernel 3.3 with bios emulation. although I don't actually know if this was caused by the kernel itself.
Comment 2 Peter Hedlund 2012-04-19 01:36:45 UTC
Unfortunately back in 3.4-rc3. Using a Macbook Air 3,2 also with a Nvidia 320M chip.
Comment 3 garegin 2012-04-19 03:11:40 UTC
i wish the enterprise distros like RHEL and debian had some shame and just used vesa for the trouble models until nouveau was fixed.
Comment 4 Peter Hedlund 2012-05-03 19:21:32 UTC
Still present in 3.4-rc5.
Comment 5 garegin 2012-05-04 04:14:47 UTC
is bios emulation or efi?
Comment 6 Peter Hedlund 2012-05-04 17:40:02 UTC
(In reply to comment #5)
> is bios emulation or efi?

Doesn't matter. Neither works. Information is available in the Ubuntu bug report https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nouveau/+bug/898784.
Comment 7 Peter Hedlund 2012-05-04 17:42:46 UTC
Is there a way to change the regression tag to Yes?
Comment 8 Peter Hedlund 2012-05-07 01:12:13 UTC
Still present in 3.4-rc6.
Comment 9 garegin 2012-05-07 02:53:04 UTC
how can we confirm that this is a kernel bug? can the problem be with something in the userspace?
Comment 10 Peter Hedlund 2012-05-07 03:58:13 UTC
If I boot a 3.2 kernel the bug is there, with a 3.3 kernel it is gone, and with a 3.4 kernel it is back. All other software remains the same.
Comment 11 Marcin Slusarz 2012-05-12 10:21:44 UTC
Dithering?

http://nouveau.freedesktop.org/wiki/Dithering
Comment 12 Peter Hedlund 2012-05-13 22:51:16 UTC
(In reply to comment #11)
> Dithering?

eDP-1 connected 1440x900+1920+0 (normal left inverted right x axis y axis) 286mm x 179mm
	EDID:
		00ffffffffffff000610df9c00000000
		23140103801d12780aef059757549227
		22505400000001010101010101010101
		010101010101c223a0d450841a30402a
		36001eb3100000180000000100061030
		00000000000000000a20000000fe004c
		503133335750312d54504131000000fc
		00436f6c6f72204c43440a202020001f
	dithering depth:	auto
		supported: auto         6 bpc        8 bpc       
	dithering mode:	auto
		supported: auto         off          static 2x2   dynamic 2x2 
	scaling mode:	Full
		supported: None         Full         Center       Full aspect 
	color vibrance: 150 (0x00000096)	range:  (0,200)
	vibrant hue: 90 (0x0000005a)	range:  (0,180)
   1440x900       59.8*+
   1152x864       60.0  
   1024x768       59.9  
   800x600        59.9  
   640x480        59.4  
   720x400        59.6  
   640x400        60.0  
   640x350        59.8

Any variant of xrandr --output eDP-1 --set dithering i have tried fails with

X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  150 (RANDR)
  Minor opcode of failed request:  11 (RRQueryOutputProperty)
  Serial number of failed request:  29
  Current serial number in output stream:  29

Since dithering is reported as both a mode and a depth I don't know how to set up the xrandr command. Google is not being very friendly on the matter.

However, this would still not answer why a 3.3 kernel works and 3.2 or 3.4 do not.
Comment 13 Peter Hedlund 2012-05-21 22:28:17 UTC
The bug is still present in kernel 3.4.0 final. Anybody on how to test the dithering?
Comment 14 garegin 2012-05-22 01:13:00 UTC
it's not dithering. the whole image is garbled. it's not a line pattern.
Comment 15 m.b.lankhorst@gmail.com 2012-07-09 08:33:00 UTC
This bug is fixed with commit a6a17859f1b and can be closed. It's backported to 3.2 stable and 3.4 with confirmation on 3.2.27

Note You need to log in before you can comment on or make changes to this bug.