Bug 42963 - Kernel Oops by watchdog timer
Kernel Oops by watchdog timer
Status: RESOLVED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-19 16:36 UTC by Mate Soos
Modified: 2012-03-19 17:27 UTC (History)
0 users

See Also:
Kernel Version: 3.2.0-1-amd64
Tree: Mainline
Regression: No


Attachments
The above files, gzipped (21.54 KB, application/x-gzip)
2012-03-19 16:36 UTC, Mate Soos
Details

Description Mate Soos 2012-03-19 16:36:30 UTC
Created attachment 72653 [details]
The above files, gzipped

[1.] One line summary of the problem
When unplugging a USB stick, kernel Oopses

[2.] Full description of the problem/report:
The kernel oops-ed when I pulled out an umounted 8GB USB key. This seems
to be visible in the "messages" file. All the data attached, except for
the "messages" has been produced after a reboot, since the system
hanged. Luckily, the "messages" got saved. The system after restart
should have exactly the same modules loaded as before.

[3.] Keywords (i.e., modules, networking, kernel):
USB, Kernel Ooops, Watchdog

[4.] Kernel version (from /proc/version):
$ cat
 /proc/version
Linux version 3.2.0-1-amd64 (Debian 3.2.4-1) (waldi@debian.org) (gcc
version 4.6.2 (Debian 4.6.2-12) ) #1 SMP Sun Feb 5 15:17:15 UTC 2012

It's from Debian squeeze, debian package version "linux-image-3.2.0-1-amd64"

[5.] Output of Oops.. message (if applicable) with symbolic information
     resolved (see Documentation/oops-tracing.txt)
In the "messages" text file you will find these.

[6.] A small shell script or example program which triggers the
     problem (if possible)
Unfortunately, I can't reproduce.

[7.] Environment
[7.1.] Software (add the output of the ver_linux script here)
Attached.

[7.2.] Processor information (from /proc/cpuinfo):
Attached.

[7.3.] Module information (from /proc/modules):
Attached.

[7.4.] Loaded driver and hardware information (/proc/ioports, /proc/iomem)
Both attached.

[7.5.] PCI information ('lspci -vvv' as root)
Attached.

[7.6.] SCSI information (from /proc/scsi/scsi)
bash: /proc/scsi/scsi: No such file or directory

I hope this helps in triaging and/or resolving this bug.
Comment 1 john stultz 2012-03-19 17:27:34 UTC
The kernel logs show the kernel as tainted, due to the binary firegl driver being used here. The firegl driver also shows up in the backtrace (multiple times).

Since there's no way for us to debug issues with binary only drivers, I'm marking this bug as invalid.  If you can reproduce this issue without loading the firegl driver, we can take a closer look.

thanks
-john

Note You need to log in before you can comment on or make changes to this bug.