Bug 42958 - snd_pcm lockdep report from 3.3-rc6
snd_pcm lockdep report from 3.3-rc6
Status: RESOLVED WILL_NOT_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks: 42644
  Show dependency treegraph
 
Reported: 2012-03-18 19:30 UTC by Maciej Rutecki
Modified: 2013-11-29 08:16 UTC (History)
4 users (show)

See Also:
Kernel Version: 3.3-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2012-03-18 19:30:08 UTC
Subject    : snd_pcm lockdep report from 3.3-rc6
Submitter  : Dave Jones <davej@redhat.com>
Date       : 2012-03-12 14:35
Message-ID : 20120312143514.GA1881@redhat.com
References : http://marc.info/?l=linux-kernel&m=133156298430759&w=2

This entry is being used for tracking a regression from 3.2. Please don't
close it until the problem is fixed in the mainline.
Comment 1 Takashi Iwai 2013-11-29 08:16:57 UTC
Actually this is no regression, so no need for tracking further.
The lockdep report is mostly a false-positive in this case.  The code needs to be better, simpler, but it doesn't mean that the current code is buggy.

Note You need to log in before you can comment on or make changes to this bug.