Bug 42931 - gma500_gfx: crash on suspend
Summary: gma500_gfx: crash on suspend
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(Other) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-other
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-14 16:25 UTC by Dennis Jansen
Modified: 2012-08-08 09:34 UTC (History)
2 users (show)

See Also:
Kernel Version: 3.3.0-rc7
Tree: Mainline
Regression: No


Attachments
Screen 1 (206.42 KB, image/jpeg)
2012-03-14 17:07 UTC, Dennis Jansen
Details
Screen 2 (193.25 KB, image/jpeg)
2012-03-14 17:08 UTC, Dennis Jansen
Details
Screen 3 (186.00 KB, image/jpeg)
2012-03-14 17:11 UTC, Dennis Jansen
Details

Description Dennis Jansen 2012-03-14 16:25:57 UTC
The driver loads and works fine, but when trying to suspend, the system locks up and (with no_console_suspend) shows a lot of debug messages and then completeley hangs up. I will attach pictures of those messages.
Comment 1 Dennis Jansen 2012-03-14 17:07:34 UTC
Created attachment 72585 [details]
Screen 1
Comment 2 Dennis Jansen 2012-03-14 17:08:16 UTC
Created attachment 72586 [details]
Screen 2
Comment 3 Dennis Jansen 2012-03-14 17:11:00 UTC
Created attachment 72587 [details]
Screen 3

Screens not necessarily in that order. Please refer to the timecodes for that.

Let me know if you need anything else. Bug may well be related to #42929
https://bugzilla.kernel.org/show_bug.cgi?id=42929
Comment 4 Dennis Jansen 2012-03-14 17:14:02 UTC
(Here I loaded the gma500_gfx module before suspend, in the other one I didn't.)
Comment 5 Alan 2012-08-08 09:34:54 UTC
Should be fixed in 3.5

Note You need to log in before you can comment on or make changes to this bug.