Bug 42929 - GMA500: Regression: 3.3.0-rc7 - Display remains black after S3 (vga console)
GMA500: Regression: 3.3.0-rc7 - Display remains black after S3 (vga console)
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2012-03-14 13:08 UTC by Dennis Jansen
Modified: 2013-04-09 06:23 UTC (History)
5 users (show)

See Also:
Kernel Version: 3.3.0-rc7
Tree: Mainline
Regression: Yes


Attachments
dmesg after suspend (39.23 KB, text/plain)
2012-03-14 13:14 UTC, Dennis Jansen
Details
lspci (1.23 KB, text/plain)
2012-03-14 13:15 UTC, Dennis Jansen
Details

Description Dennis Jansen 2012-03-14 13:08:24 UTC
It was last working in 3.2.1, in 3.3.0-rc7+ it's no longer working.

I will attach a dmesg and lspci. Let me know what else I can do to debug the issue.

PS. Responses might be a bit slow this time, sorry. Also, if I had time for a bisect, I wouldn't post this.
Comment 1 Dennis Jansen 2012-03-14 13:12:01 UTC
Important: The display stays off after trying to suspend. The system doesn't suspend, though. At least not noticeably. It is still responsive after suspend, though.
Comment 2 Dennis Jansen 2012-03-14 13:14:44 UTC
Created attachment 72582 [details]
dmesg after suspend
Comment 3 Dennis Jansen 2012-03-14 13:15:13 UTC
Created attachment 72583 [details]
lspci
Comment 4 Dennis Jansen 2012-03-14 17:17:07 UTC
Possibly related in some way to:
https://bugzilla.kernel.org/show_bug.cgi?id=42931
Where I loaded the gma500_gfx graphics driver module before suspend and suspend fails.
Comment 5 Zhang Rui 2012-03-19 08:47:56 UTC
IMO, it seems there are two issues here
1) S3 resumes immediately after suspend
2) black screen after suspend

issue 2) is probably caused by the broken gma500_gfx driver.

And issue 1) is probably caused by EHCI?

> [   17.524804] ehci_hcd 0000:00:1d.7: wake-up capability enabled by ACPI

could you please try to run 
"echo disabled > /sys/bus/pci/devices/0000:00:1d.0/power/wakeup" to disable the EHCI wakeup and see if the problem still exists?
Comment 6 Dennis Jansen 2012-03-19 09:30:55 UTC
Oh, yes, it's true. Sorry! I forgot the LID > /proc/acpi/wakeup.
So issue 1) is gone.
Comment 7 Len Brown 2012-03-20 02:23:06 UTC
re: LID > /proc/acpi/wakeup

Hmm, so the LID was causing an immediate wakeup?
Has this always been an issue and you've always used this workaround,
or is this a new problem?

re: black screen

ACPI is not responsible for resuming the screen -- the graphics driver is.
So this would be an issue with your graphics driver.
Can you describe the version that works and the version that fails?
Comment 8 Dennis Jansen 2012-03-20 07:10:15 UTC
No, this is an old problem. Since 2.6.34. See here:
https://bugzilla.kernel.org/show_bug.cgi?id=16512
Comment 9 Frank Seidel 2012-04-07 10:03:43 UTC
Having black screen issue also/still with released 3.3.0 kernel.
gma500_gfx is the gpu driver there (for the cedartrail gma3600).
Underneath / besides display not powering up all seems to work.
So to me this really could be related to #4291.
Comment 10 Alan 2012-08-31 17:06:26 UTC
Please test 3.5, that should have fixed most of these cases
Comment 11 Dennis Jansen 2012-09-16 18:08:05 UTC
It's fixed! Works great! Thanks!!!


Now the X display area is moved up about 20 pixels... opening another bug fot that. ;)

Note You need to log in before you can comment on or make changes to this bug.