Bug 42858 - thermal throttling doesn't seem to trigger on Thinkpad T420s
Summary: thermal throttling doesn't seem to trigger on Thinkpad T420s
Status: CLOSED WILL_FIX_LATER
Alias: None
Product: Power Management
Classification: Unclassified
Component: cpufreq (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Rafael J. Wysocki
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-03-04 10:52 UTC by Pierre Ossman
Modified: 2013-07-05 05:31 UTC (History)
6 users (show)

See Also:
Kernel Version: 3.2.7
Tree: Mainline
Regression: No


Attachments

Description Pierre Ossman 2012-03-04 10:52:56 UTC
I have a new Thinkpad T420s and I'm noticing it getting massively hot when putting some load on the CPU. powertop shows it spending all its time in Turbo mode for both cores. Thermal reporting shows it hovering around 90° with the fan on full. It hasn't been throttled even once though:

./cpu0/thermal_throttle/core_power_limit_count:0
./cpu0/thermal_throttle/core_throttle_count:0
./cpu0/thermal_throttle/package_power_limit_count:0
./cpu0/thermal_throttle/package_throttle_count:0
./cpu1/thermal_throttle/core_power_limit_count:0
./cpu1/thermal_throttle/core_throttle_count:0
./cpu1/thermal_throttle/package_power_limit_count:0
./cpu1/thermal_throttle/package_throttle_count:0
./cpu2/thermal_throttle/core_power_limit_count:0
./cpu2/thermal_throttle/core_throttle_count:0
./cpu2/thermal_throttle/package_power_limit_count:0
./cpu2/thermal_throttle/package_throttle_count:0
./cpu3/thermal_throttle/core_power_limit_count:0
./cpu3/thermal_throttle/core_throttle_count:0
./cpu3/thermal_throttle/package_power_limit_count:0
./cpu3/thermal_throttle/package_throttle_count:0

This doesn't really seem safe for the CPU or my lap. :/
Comment 1 Pierre Ossman 2012-03-05 07:39:54 UTC
I also noticed this in dmesg:

[ 1510.425741] thinkpad_acpi: unknown possible thermal alarm or keyboard event received
[ 1510.425752] thinkpad_acpi: unhandled HKEY event 0x6040
[ 1510.425757] thinkpad_acpi: please report the conditions when this event happened to ibm-acpi-devel@lists.sourceforge.net
Comment 2 Len Brown 2012-03-06 02:24:16 UTC
what kernel version  (uname -a)

please show either

# grep . /proc/acpi/thermal*/*/

or

# grep . /sys/class/thermal/*/*

to show us what the trip points and current temperatures are.

if you booth without the thinkpad_acpi driver,
does the system behave differently?
Comment 3 Pierre Ossman 2012-03-06 06:45:30 UTC
~
[drzeus@mjolnir]$ uname -a
Linux mjolnir.ossman.eu 3.2.7-1.fc16.x86_64 #1 SMP Tue Feb 21 01:40:47 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

~
[drzeus@mjolnir]$ grep . /proc/acpi/thermal*/*/
grep: /proc/acpi/thermal*/*/: No such file or directory

~
[drzeus@mjolnir]$ grep . /sys/class/thermal/*/*
/sys/class/thermal/cooling_device0/cur_state:0
/sys/class/thermal/cooling_device0/max_state:17
/sys/class/thermal/cooling_device0/type:Processor
/sys/class/thermal/cooling_device1/cur_state:0
/sys/class/thermal/cooling_device1/max_state:17
/sys/class/thermal/cooling_device1/type:Processor
/sys/class/thermal/cooling_device2/cur_state:0
/sys/class/thermal/cooling_device2/max_state:17
/sys/class/thermal/cooling_device2/type:Processor
/sys/class/thermal/cooling_device3/cur_state:0
/sys/class/thermal/cooling_device3/max_state:17
/sys/class/thermal/cooling_device3/type:Processor
/sys/class/thermal/cooling_device4/cur_state:6
/sys/class/thermal/cooling_device4/max_state:15
/sys/class/thermal/cooling_device4/type:LCD
/sys/class/thermal/thermal_zone0/mode:enabled
/sys/class/thermal/thermal_zone0/passive:0
/sys/class/thermal/thermal_zone0/temp:43000
/sys/class/thermal/thermal_zone0/trip_point_0_temp:97000
/sys/class/thermal/thermal_zone0/trip_point_0_type:critical
/sys/class/thermal/thermal_zone0/type:acpitz


I'll test without thinkpad_acpi and see what happens.
Comment 4 Pierre Ossman 2012-03-17 11:30:50 UTC
The problem remains even without thinkpad_acpi. :/
Comment 5 Zhang Rui 2012-03-19 08:54:58 UTC
would you please check if this patch helps?

http://marc.info/?l=linux-acpi&m=132854533918079&w=2
Comment 6 Zhang Rui 2012-05-24 08:14:59 UTC
bug closed as there is no response from the bug reporter.
please feel free to reopen it if the problem still exists in the latest upstream kernel.
Comment 7 Julien Iguchi-Cartigny 2012-05-27 14:10:12 UTC
Seems this problem is still present for a lot of thinkpad users, see:

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/751689
Comment 8 Julien Iguchi-Cartigny 2012-05-27 18:50:37 UTC
I've the same problem with my ubuntu T500, and a lot of thinkpad seems also to have the overheating problem (please see the URL from comment #7). Please see some tests I have described here to resolve this bug:

http://askubuntu.com/questions/133030/overheating-and-reboot-with-ubuntu-11-10-and-12-04-on-thinpad-t500

After checking the source of my kernel (latest kernel for ubuntu 12.04, i.e. 3.2.0-24-generic-pae), i can see that the patch from comment #5 is already present. 

If this problem is only present in thinkpad models, the bug maybe related to thinkpad-acpi ?
Comment 9 Aaron Lu 2013-03-13 06:35:34 UTC
Hi Julien,

Is this problem still present on latest upstream kernel? Thanks.
Comment 10 Lan Tianyu 2013-07-05 05:31:33 UTC
Since no response for long time, Close this bug as WILL_FIX_LATER. Please feel  reopen this bug if there is any update.

Note You need to log in before you can comment on or make changes to this bug.